Jump to content

Photo

Fallout 3 wont launch... (Steam + Windows 7)


  • Please log in to reply
12 replies to this topic

#1
jimdigritz

jimdigritz

    Stranger

  • Members
  • Pip
  • 7 posts
I've read a bunch of posts here but have yet to find one that solves this issue.

After 3 years playing games on my old rig at minimum graphical settings I treated myself to a bang up to date PC. Runs perfectly and 99.9% of games work.... except Fallout 3

My specs:

Windows 7 Ultimate (x64) (build 7100)
2.67 gigahertz Intel Core i7 920
Gigabyte EX58-UD3R
6Gb RAM
ATI 4890
Catalyst 9.8, driver version 8.640
Fallout 3 (through Steam)

When I launch Fallout 3 from steam the Launcher appears, and I can edit graphics settings without a problem, however when I click "Play" the launcher dissapears and I'm back at the desktop. No errors, nothing.

Having googled it I'm well aware of some issues with Win7 and F3, however they all seem subtly different.

I have tried:

Deleting and resinstalling game through steam
Updating to the latest ATi drivers
Creating a shortcut to FalloutLauncher.exe and Fallout3.exe and running them as Administrator
Taking Ownership (http://www.sevenforu...p-shortcut.html) of all User folders that contain Fallout3 .ini files
Setting all permissions on the C:\Users\yourname\Documents\My Games\Fallout3 folder to 'Allow'
** I can't uncheck the Read Only flag on the folder, it just resets **

Still no joy.

My gut feeling is that this is a permissions issue.

Has anyone got this working??


Jim

#2
tortured Tomato

tortured Tomato

    Nightshade Mutant

  • Supporter
  • PipPipPipPip
  • 2,128 posts
You could try to disable the User Account Control.
UAC may block some files in the "Program Files" folder. That's why F3 should be installed outside of the Programe folder.

Also try to install the latest GfWL-Client, delete your Fallout.ini in your My Games folder and run the latest Patch, Windowsupdate

#3
jimdigritz

jimdigritz

    Stranger

  • Members
  • Pip
  • 7 posts

You could try to disable the User Account Control.
UAC may block some files in the "Program Files" folder. That's why F3 should be installed outside of the Programe folder.

Also try to install the latest GfWL-Client, delete your Fallout.ini in your My Games folder and run the latest Patch, Windowsupdate


Thanks for the reply.

Okay still no joy.

UAC: FO3 is installed outside the Progam folder, it is (with all my working steam games) on another drive in a steamapps folder.
1.7 Patch: Crashes. Comes up with 0xc0000005 error
GfWL: Interesting. GfWL crashes when I try to launch it the client from the Windows menu. After several reinstalls and even trying the LATEST 3.0 GFE version from the MS website which states Windows 7 compatibility, it still crahses. Oddly, whilst an error dialog appears, the actual GfWL client is working perfectly 'underneath'....

Other things I tried:

I tried updating the .Net Framework, even trying the latest 4.0 Beta, still no joy.

After much hair pulling I have identified that ALL games that need GfWL are equally buugered. Both Dawn of War II, and my latest Steam purchase (cos FO3 wasnt working!) Red Faction Guerilla all exhibit the same behaviour - ie they won't start.

Other recent Steam games (that DON'T use GfWL) like Empire: Total War, COD4: Modern Warfare, ARMA2, Company of Heroes, Far Cry 2 and Left 4 Dead all work perfectly...

This leads me to believe that it is moat likely a GfWL issue.. FFS trust Microsoft to be the only publisher NOT to properly support Windows 7.

If anyone else has any idea or has these games running on a similar spec PC I would be interested to hear from them

Jim

#4
tortured Tomato

tortured Tomato

    Nightshade Mutant

  • Supporter
  • PipPipPipPip
  • 2,128 posts
No Mods?
OK, it's just a shot into the dark, but since you have an ATI card you could try installing the C++ 2005 Package

#5
jimdigritz

jimdigritz

    Stranger

  • Members
  • Pip
  • 7 posts

No Mods?
OK, it's just a shot into the dark, but since you have an ATI card you could try installing the C++ 2005 Package


Thanks Psyclops, but as much as wanted this to work, it didn't....


I am 99% sure it is a GfWL issue....


Jim

#6
tortured Tomato

tortured Tomato

    Nightshade Mutant

  • Supporter
  • PipPipPipPip
  • 2,128 posts
Might be another error.
Try to disable the Win7 Aero Theme.
There seems to be a problem with (might be the window transparency).

#7
jimdigritz

jimdigritz

    Stranger

  • Members
  • Pip
  • 7 posts

Might be another error.
Try to disable the Win7 Aero Theme.
There seems to be a problem with (might be the window transparency).


Thanks, nice idea.. I just tried it but it still doesn't work...

Oh and I did try the 2005 C++ (x64) Package with no luck, and then upgraded to the 2008 C++ (x64) Package.. still nada

Am stumped!


jim

#8
overload1977

overload1977

    Jade Green

  • Members
  • PipPipPipPip
  • 1,296 posts
i would have to say its steam myself, never liked it from day one, can you run your version of fallout without running steam ?

if you can`t get it running go get your money back , and go down the shops a buy a copy, if you wait untill oct there will be a game of the year ver out with all the dlc :)

also try going to the bethsoft website and see if they can help you, i don`t think a lot of people on here have the steam version i`m sorry to say :/

#9
Vinze

Vinze

    Enthusiast

  • Banned
  • PipPip
  • 115 posts

I've read a bunch of posts here but have yet to find one that solves this issue.

After 3 years playing games on my old rig at minimum graphical settings I treated myself to a bang up to date PC. Runs perfectly and 99.9% of games work.... except Fallout 3

My specs:

Windows 7 Ultimate (x64) (build 7100)
2.67 gigahertz Intel Core i7 920
Gigabyte EX58-UD3R
6Gb RAM
ATI 4890
Catalyst 9.8, driver version 8.640
Fallout 3 (through Steam)

When I launch Fallout 3 from steam the Launcher appears, and I can edit graphics settings without a problem, however when I click "Play" the launcher dissapears and I'm back at the desktop. No errors, nothing.

Having googled it I'm well aware of some issues with Win7 and F3, however they all seem subtly different.

I have tried:

Deleting and resinstalling game through steam
Updating to the latest ATi drivers
Creating a shortcut to FalloutLauncher.exe and Fallout3.exe and running them as Administrator
Taking Ownership (http://www.sevenforu...p-shortcut.html) of all User folders that contain Fallout3 .ini files
Setting all permissions on the C:\Users\yourname\Documents\My Games\Fallout3 folder to 'Allow'
** I can't uncheck the Read Only flag on the folder, it just resets **

Still no joy.

My gut feeling is that this is a permissions issue.

Has anyone got this working??


Jim


Get FOSE and launch it with the FOSE_Loader.exe, totally eliminates Steam out of the process.

#10
jimdigritz

jimdigritz

    Stranger

  • Members
  • Pip
  • 7 posts

Get FOSE and launch it with the FOSE_Loader.exe, totally eliminates Steam out of the process.


Thanks for all your help guys...

I just installed FOSE as per the instructions and it doesn't work. I get this error
Attached File  Capture.PNG   55.58KB   14 downloads

So if this is COMPLETELY bypassing Steam and GfWL then this is a FO3/Red Faction Guerilla/DoWII issue...

Hmm

Jim




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Page loaded in: 0.898 seconds