Jump to content

Photo

Fallout 3 Crash Fix Guide


  • Please log in to reply
51 replies to this topic

#1
RastahMan

RastahMan

    Fan

  • Members
  • PipPipPip
  • 457 posts
Hi!I seen a lots of topics like "Fallout crashes, freeze" or something like that.So i decided to gather most popular and efective tips from net and and my experience:

First tip:

1. Click Start
2. Click “All Programs”.
3. Go to the ffdshow folder.
4. Click “Audio decoder configuration.”
5. In the left hand pane, click “Info & debug.” or "DirectShow control".This is the second entry in the list.
6. In the right hand pane, near the bottom, find a check box labelled “Don’t use ffdshow in:”
7. Check that box, and in the text box underneath (it lights up when you check the check box), add “fallout3.exe” (don’t include the quotes). If there is already something in that box, put a semi-colon ( ; ) after what’s already there, and fallout3.exe after that. Do NOT use spaces, since ffdshow will think that’s part of the filename. A valid entry would be “explorer.exe;fallout3.exe” (without quotes).
8. Finally, click “Ok” and start Fallout 3.

Second:

1.Turn off autosave on sleep,fast travel and wait(sounds stupid but it help fix crashes)

Third:

1.The fix for this Fallout 3 bug is very easy: just copy and paste and you are ready to go:
-Open the folder My documents / My Games / Fallout3
-Edit the file FALLOUT.ini.
-Inside FALLOUT.ini look for a group called [general].
-Inside the general group, after all the configuration parameters, just copy and paste the following 2 lines:

bUseThreadedAI=1
iNumHWThreads=2

Now close and save the Fallout 3 configuration file.

#2
Parktoid

Parktoid

    Stranger

  • Members
  • Pip
  • 1 posts
I went to make an account to thank you for this, as step 3 worked.
I was blocked from making the account because the name was taken... I've never seen anyone else use this name. Turns out I made an account on here a long time ago and forgot about it.
So awesome. Double thanks.

#3
toreto41

toreto41

    Stranger

  • Members
  • Pip
  • 1 posts
I´ve done this 3 steps and I still crash on general map. ¿any advice?

#4
jusalilpanda

jusalilpanda

    Stranger

  • Members
  • Pip
  • 1 posts
Sorry for the blast-from-the-past bump. This topic shows up first on le Google so I thought I'd throw in what I discovered to be extremely important to making step three work (I didn't try another step):

For Step 3 find bUseThreadedAI and (after you change the value to 1, if necessary) make sure that iNumHWThreads=2 IMMEDIATELY FOLLOWS.

I didn't think it would matter for an *.ini file so I threw "iNumHWThreads=2" at the end of the file but Fallout 3 still crashed (a lot). Somewhere else on the interwebs someone mentioned placing the values consecutively so I tried. To my great surprise it worked!

#5
NerdyDinosaur

NerdyDinosaur

    Enthusiast

  • Members
  • PipPip
  • 106 posts
I wonder if you're second tip will work because I thought it was fallout 3 freaking out about the mods I have. I can't enter buildings or save without it crashing. I can walk around the wasteland and fast travel, but I cannot enter buildings like Moriarty's.

#6
Godzilla022

Godzilla022

    Enthusiast

  • Members
  • PipPip
  • 119 posts
greetings everyon,e, i got fallout 3 on win 7 und i allready fixed a bug that causes the game to crash whilst loading, but now it seems to crash when i want to kill the first radroach in the vault, please help?

#7
Hegs94

Hegs94

    Stranger

  • Members
  • Pip
  • 1 posts
Hey everyone, so I've pretty much done everything: taken off autosave, edited the .ini file (even going so far as to customize the new commands to try and make the work load lighter), lowered the game quality down to the lowest settings, cycled through my power options, and a whole plethora of other crap. Mind you I combined all of these things in different ways to try and find the right cocktail to fix the crashing error. Sadly my efforts have so far been in vain, as I've barely gotten anything (at it's worst it'll make it barely a minute into gameplay, at it's best maybe a little over 5). I've tried everything but it still won't work. Please don't tell me that my computer (a G74sx) is too powerful for Fallout (which just sounds silly saying in the first place, especially since I know people with far more powerful desktop rigs can play it). Also mind you I didn't encounter really any errors till now, at level 9, even after playing through Anchorage. There were some intermittent crashes, but nothing too overwhelming. It just makes no sense, can someone please give me some advice.

Oh, some additional info: I also downloaded the unofficial patch in the hopes that something in there might help, it seems to be at it's worst indoors while selecting stuff, and I have 1 mod (the Underground Hideout mod).

Oh and this isn't my first playing time Fallout or anything just to clarify, just my first time playing it on PC.

So again, if anyone has some advice I'd really appreciate it.

Edited by Hegs94, 16 February 2012 - 05:47 AM.


#8
Greentears

Greentears

    Stranger

  • Members
  • Pip
  • 7 posts
my fallout will not even get up and ingame i go to make a new game a boom it crash and i have not played it once

why must it do this !!

my game dose not love me :(

if someone can help then thanks

#9
GrindedStone

GrindedStone

    Stupid Human

  • Banned
  • PipPipPipPip
  • 1,025 posts
I would say delete your my documents/mygames/ fallout folder. This contains your configs but also savegames. Which I have found some issues with the .fos named back up save games. This also varys greatly depending on how you start the game either load or continue. So really I'm saying delete your save games an start over, but there are issues with Windows 7 an this my documents config folder. Some say you need to take ownership of the folder or files thru the security settings. I fear though the real answer for you guys is going to be listed in a windows 7 forum. Such as Windows Seven Forums Fallout 3 topic When you delete that folder an run the default launcher then the folder gets generated again, which might fix the problem. It would also auto detect settings again. You should also try disabling AA an AF as I heard that there were some direct conflicts between the game an the newer technology and/or drivers. You can also try moving the master volume slider all the way down then load into a game as a way to eliminate sound as a possible cause.

Edited by GrindedStone, 24 February 2012 - 01:41 AM.


#10
Beliathor

Beliathor

    Stranger

  • Members
  • Pip
  • 4 posts
Just wanted to make an addition to jusalilpandas reply. I came across the comment numerous times and had an idea about the sixth time I saw it.

After changing bUseThreadedAI make sure to put iNumHWThreads=2 right after that:

so instead of

bUseThreadedAI=1
iNumHWThreads=2

write

bUseThreadedAI=1iNumHWThreads=2

It does not even make sense,but I haven't had a crash since.




Page loaded in: 1.217 seconds