Jump to content

Photo

Skyrim.ini or SkyrimPrefs.ini ?? Confused.


  • Please log in to reply
18 replies to this topic

#1
wolfsangeleyes

wolfsangeleyes

    Huntress

  • Members
  • PipPipPipPipPip
  • 13,530 posts
Hi everyone,

Like many of you i'm also suffering from lags when using the mouse. In fact it is so terrible i haven't been able to play the game yet. After googling the problem for an hour and a half i found some answers and tried them. I have changed the default setting of the bMouseAccelaration to 0, (after making a back up of course) which helped somewhat but the Vsync is giving me nightmares. Trouble is the advices given on various websites all contradict one another.

Steam showed an article from the PC Gamer and it tells you to disable Vsync if you suffer from sluggish framerate and elimates mouselag.

Quote<<Disable Vsync: Access the SkyrimPrefs.ini again and add iPresentInterval=0 to the bottom of the [Display] section. This can improve a sluggish framerate and eliminate instances of mouse lag. Thanks to Tweak Guides for this one.>>

Access the SkyrimPrefs.ini......which one? There are two, one is located under C\Documents\Games\Skyrim. The other is located in Steamapps\Common\Skyrim\Skyrim.
The SkryrimPrefs.ini file in Documents\Games already has the iPresentInterval (set to 1 by default) so i doubt if that's the one they mean. And i find it a bit redudant to add something that is already there (yes i did try changing the default setting 1 to 0. No difference.)

Because the PC gamer gave thanks to Tweak Guides i decided to take a look there.

Quote<<
To disable VSync in Skyrim, add iPresentInterval=0 to the bottom of the [Display] section of theSkyrim.ini file in the \Users\[Username]\My Documents\My Games\Skyrim directory.>>

Ok, now that is confusing. One tells you to make the changes in the SkyrimPrefs.ini file and the other one tells you to do it in the Skyrim.ini :unsure:


Skyrim reddit was also quoted so i decided to take a look there, which confused me even more.

Quote <<How do I fix the vsync ("laggy mouse") problem?

  • Go to your Steam Directory -> steamapps -> common -> skyrim -> Skyrim
  • Create a backup of the SkyrimPrefs.ini file
  • Open the file, then scroll down to where it says [Display]
  • Add to the bottom of the section iPresentInterval=0
  • Save, exit, and play>>
It now seems i have to make changes in the SkyrimPrefs.ini file located under steamapps\common\etc, NOT the one located under Documents\Games.:ohdear:
To add to the confusements, it seems that all these websites credit the same person. Either people are misquoting him or they found out what works for them. I don't know. All i know is i'm confused and i don't want to meddle with the wrong ini file and end up messing everything up.

I would appreciate it if there's someone who could set me straight. I may not be a native english speaker but my comprehension of the language is good enough. I doubt if i misread something, but if i did please let me know because after installing the game over 30 hours ago i'm desperate to start playing it..properly.
Thanks in advance.:)

Wolfsangeleyes

Edited by wolfsangeleyes, 12 November 2011 - 08:19 PM.


#2
TalHawkins112

TalHawkins112

    Newbie

  • Members
  • Pip
  • 14 posts
I would appreciate a reply to this question as well, as I am having the same problem.

#3
Wisp1979

Wisp1979

    Journeyman

  • Members
  • Pip
  • 38 posts
*Bump*
I'm also very confused by all the different ini's. If anyone knows an authoritative source about tweaking Skyrim's ini, please post here...

#4
Fatalmasterpiece

Fatalmasterpiece

    Devil's Advocate

  • Premium Member
  • 1,264 posts
idk but you could just force vsync off in your gpu settings.

#5
wolfsangeleyes

wolfsangeleyes

    Huntress

  • Members
  • PipPipPipPipPip
  • 13,530 posts
Thank you, Fatalmasterpiece for your suggestion.

Unfortunately i don't have a clue on how to do that, so i decided to take a gamble and use the advice given by the Tweak Guide. (especially since i remember reading that for Oblivion, you only tweak the ini file under Documents\Games)

Anyway, this is what i did and it did improve the slugginess/laggy mouse. Not a full 100 %, but still a whole lot better than what it was.

Quote<<
To disable VSync in Skyrim, add iPresentInterval=0 to the bottom of the [Display] section of theSkyrim.ini file in the \Users\[Username]\My Documents\My Games\Skyrim directory.>>

For now i'm satisfied and hopefully it will help you guys figuring out which ini file to tweak.
Still, if there are people with better solutions, please, please let us know.

Happy gaming everyone.:dance:

#6
wolfsangeleyes

wolfsangeleyes

    Huntress

  • Members
  • PipPipPipPipPip
  • 13,530 posts
Update..

Even though it lagged less than before i still find it difficult to play and after a while i get a bit light headed. I even changed all the other ini files under Steamapps\Common\etc out of sheer desperation but it doesn't make any difference. (on the bright side, it didn't crash the game either)
It may not lag as much as it did before all the tweaking but to play like this for any longer than 15 minutes....:wallbash:

I think i'll return to Oblivion for now untill there's a patch or upgrade or something, because this is just too annoying.

#7
trens

trens

    Stranger

  • Members
  • Pip
  • 1 posts

http://dl.dropbox.com/u/1310775/skyrimPrefs.jpg

That is location of the .ini file I have edited.

I suppose you installed yours to the C:\program files\, whereas I installed mine in x:\

BTW when I capitalize a letter in a directory name, folder name, I am just doing that so it is easier to read.

So navigate into your Steam folder, then locate the folder SteamApps double click, then Common double click, Skyrim, then Skyrim again.

X:\steam\steamapps\common\skyrim\Skyrim

so your is

c:\Program Files\Steam\SteamApps\Common\Skyrim\Skyrim

Now I have only edited the one in the game directory and have not touched the one in the my profile.

It, I believe, has worked for me.


Every thing I said applies to the changes in the file, but the location of the file I believe is off.

It is in your local profile.

for my win7 install it is.

C:\Users\*YourUserID*\Documents\My Games\Skyrim

for winXP I think it would be, not 100% sure, its been a while since I've used WinXP.

c:\docuements and settings\*YourUserID*\My documents\My games\skyrim

^this is probably wrong, but you can just search for the file from the 'c:\documents and settings\*YourUserID*

Sorry for the confusion.

Edited by trens, 13 November 2011 - 06:57 PM.


#8
Wisp1979

Wisp1979

    Journeyman

  • Members
  • Pip
  • 38 posts
Hmm... So one of you used the file in /documents/mygames/skyrim and the other went for the file in /steam/steamapps/common/skyrim/skyrim.

Doesn't make sense... Can someone please explain why there's these different ini's and which one to use for what?

#9
wolfsangeleyes

wolfsangeleyes

    Huntress

  • Members
  • PipPipPipPipPip
  • 13,530 posts
Good question. I remember reading somewhere for Oblivion, that when you install the game, the computer automatically makes additional ini files under C\Documents as a backup or something. Not sure if i understood that correctly.
I guess the same goes for Skyrim but as for the why, i am completely oblivious (excuse the pun :tongue: )

Which ini file to use? I tried them all, one at a time and all of them. Yes, my mouse is less laggy but i feel as if i'm playing the game drunk.
Running in a straight line is fine but when i turn corners, it's as if i have no control and end up walking into walls. I find it extremely difficult to aim my cursor and open containers.
It really feels as if my character is tipsy and that makes me light headed.

I also tried to locate the original author/person that official websites are quoting and crediting...dead man posting.
I wanted to ask him directly what the best way to go is.
Trouble is you have to register and pay an one time fee of 10 dollars. I don't have pay-pal and don't want to pay that much money just to ask a question.

Perhaps someone here reading this knows that person and could ask him, because i'm tired of official websites giving their own version of his advice.
Perhaps what works for one, doesn't necessarily work for someone else but as to why that is...i'm clueless.

(excactly 48 hours ago i began installing my game and i'm still stuck in the beginning of the game, trying to get through the tutorial :ohdear: )

#10
wolfsangeleyes

wolfsangeleyes

    Huntress

  • Members
  • PipPipPipPipPip
  • 13,530 posts
Update...it's working!:dance:

Finally figured it out by searching the web some more which location is best to make the changes under. The changes (such as bMouseAcceleration and i PresentInterval, both set to 0) are done in the SkyrimPrefs.ini file under C/Username/Documents/My Games/Skyrim.

Leave the one in the Steamapps. alone. You don't need to make any changes there.
As Trens mentioned above, he made the changes in the same location and it worked for him as well.
I also read somewhere that if you make changes in the SkyrimPrefs.ini file under the Steamapps. folder that the game ignores those changes.
Apparantly the game only acknowledges the changes made in both the Skyrim.ini and the SkyrimPrefs.ini file in C/Username/Documents/My Games/Skyrim. Don't know if this is true but it could explain a lot.

Don't forget to increase the ''look sensitivity'' under settings> gameplay when you continue the game.

Lowering settings (i lowered mine from medium to low) can increase performance a lot and got rid of my lag all together, even though you might still need to tweak the settings like described above. It simply means your videocard may be a bit outdated, despite the latest drivers. And despite what the game/my pc suggested. It said i could play at medium.....eh no i can't.

AA is off, so is Anisotropic Filtering. ( i have them enabled through my Cathalyst Control Center) under options, when you launch the game. Apparently that could slow it down as well.

For the difference in mouse sensitivity between the y and the x-axis:

Go to C\Documents\Games\Skyrim again, but this time open the Skyrim.ini file (NOT the SkyrimPrefs.ini)

Add the following to the bottom of the list:

[Controls]
fMouseHeadingYScale=0.0150
fMouseHeadingXScale=0.0200

There is no [Control] in that ini file, so i included it (the word control in brackets) Some websites included it, some did not even mention it (again, confusing!!) so i decided to try it this way first and it worked. I can't really notice a difference between x and the y axis any more.

I really wish that official gaming sites such as PC Gamer would read their own articles, especially when they quote/credit other sites but end up telling you to make the changes in a completely different folder. These official sites should make sure that they give the same advice and not their own version.:facepalm:
A lot of people have been confused by these contradictions which left us running around in circles and it took me almost 5 days to figure out which one i should 'listen' to.
That and lowering my settings.

Hope this helps.:thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Page loaded in: 0.818 seconds