Jump to content

Photo

Mod Organizer


  • Please log in to reply
9844 replies to this topic

#3331
Tannin42

Tannin42

    Old hand

  • Premium Member
  • 785 posts
In response to post #7751760. #7754485, #7759109 are all replies on the same post.

The advantage would be so small you'd never know. The dimensions here are such that you might be able to save a few milliseconds in hours of playtime. Certainly not worth investing time for.

#3332
_Melk_

_Melk_

    Journeyman

  • Premium Member
  • 28 posts
In response to post #7734506. #7744235, #7744884 are all replies on the same post.

I use symbolic links to the SKSE files (2 dlls, 1 exe) from the Main Skyrim Directory, and I use MO to install the SKSE data directory (as a mod).

Since then I'm able to use it with different profiles.

To use symbolic links, use MKLINK command line (windows) from the skyrim directory for the necessary files...

1) mklink skse_1_9_32.dll c:\exampledir\skse_1_9_32.dll
2) mklink skse_steam_loader.dll c:\exampledir\skse_steam_loader.dll
3) mklink skse_loader.exe c:\exampledir\skse_loader.exe

4) Add skse_loader.exe (from the skyrim directory --therefore the symbolic link you just created) as an executable in MO.

5) Install the data portion of SKSE as a mod and put it up there in the order (mine is right after the unoffical patches)

there you go, should work. -- Don't forget to run SKSE instead of skyrim in MO

P.S. You don't really need to create symlinks -- I just do it to keep my skyrim dir clean ( me being OCD I guess ;)

#3333
Wolve64

Wolve64

    Regular

  • Supporter
  • PipPip
  • 51 posts

My bet here is that I'm being a complete idiot by asking this question and I've done some blatantly wrong, but I'll ask anyway. 

 

I'm using MO of course, and I install my mods however none of them work in-game. Are the mods I install supposed to go in the ModOrganizer\mods folder? Or am I missing something, as far as I know mods have to be in the Skyrim\data folder to work, right? Basically I install a mod using MO in the standard way you would expect, but it doesn't show in game. 

 

Sorry, I'm new at using MO. Any help would be appreciated and I apologize in advance if I'm being a complete idiot.

 

Thanks.

 

EDIT: Never mind, I've fixed it. I have a tendency to do that, post an issue then fix it almost five minutes later...


Edited by Wolve64, 07 April 2013 - 09:11 AM.


#3334
pascaliedema

pascaliedema

    Fan

  • Members
  • PipPipPip
  • 263 posts
hey tannin. i'm having an issue. the problem i'm having is that whenever i try to run oblivion via mod organizer. oblivion always crashes before the bethesda logo. i don't have the steam version. i have the retail GOTY of oblivion. i tried removing the steam appid from the settings. use script extender loader. but none of these work. i really wanna use mod organizer to play mods with oblivion but it's just not possible now. hope it can be solved :)

#3335
mrj0j0e

mrj0j0e

    Fan

  • Members
  • PipPipPip
  • 348 posts
First of all, this is without a doubt the best Mod Manager I have used, I love being able to install my mods separately from one another.

Now onto my question, I have recently done a fresh install of Skyrim and mods with this Mod organizer but I'm getting fairly regular CTD when I use spells or enter a building. I cannot see any conflicts that would cause this in the Mod Manager but I do know that I merged some of my mod compatibility patches to the main mods themselves.

Does mod organizer place these after the correct mod or should I have installed the compatibility patches separately and prioritised them myself?

Also, what is the best way of tracking CTD, is there a crash log I can use?

Many thanks any help you can provide me with.

#3336
mrj0j0e

mrj0j0e

    Fan

  • Members
  • PipPipPip
  • 348 posts
In response to post #7775132.

...One more thing.

Can I get BOSS to organise my mods on the left hand pane of MO or does it only arrange the ESP? Cheers.

#3337
Luinithil

Luinithil

    Fan

  • Members
  • PipPipPip
  • 474 posts
In response to post #7775132. #7775211 is also a reply to the same post.

Could you please detail what exactly you did when you installed your mods? When you say "merged your compatibility patches to the main mods", do you mean you used the "Merge" function during the MO installation process? Or do you mean you actually used TES5Edit/CK to open and edit plugin content? Using MO's merge during install should be fine, it's how you should install mods with optional files like compatibility patches. In which case, the mod and its patches and optional files and things should all be in the same folder, and all the prioritisation you do is to the mod and its files as a whole.

I'm not too familiar with CTD causes from both entering a building or using spells, but it sounds like it might be that your game is expecting something to happen or needs some file or other, then isn't finding it which then causes it to crash. Either that, or you're managing to run out of memory whenever you're going indoors, and the crashes when using spells is a different issue altogether. Are you using the INI tweak iLargeIntRefCount=999999? try reverting that to the vanilla value and see if that helps if you are.

To track what Skyrim is doing, you should enable Papyrus logging. Open MO's INI editor in Tools and in Skyrim.ini, add these lines to your Papyrus section (make one if it doesn't exist yet):

[Papyrus]
bEnableLogging=1
bEnableTrace=1
bLoadDebugInformation=1


BOSS is only for organising your plugin load order, any arranging of your mods on the left pane has to be done by you-- the left pane is basically what your order of installation (mod priority in MO controls which files overwrite what in the virtual Data folder Skyrim will read) would be if you were using NMM or Wrye Bash. There isn't any real issue with your installation order that could cause CTDs, unless any of your mods say that you need to install mod X before installing their mod Y, in which case then putting mod Y above mod X in the order of priority, instead of below mod X, would give you problems.

Basically if the read me says "install mod X before mod Y", your priority list should look like:

Mod X
Mod Y

If you reverse it so it becomes

Mod Y
Mod X

You've gotten it wrong and this will cause problems.

#3338
tdkdarpej

tdkdarpej

    Enthusiast

  • Members
  • PipPip
  • 205 posts
Thanks for this mod manager. Very useful. I have encountered one bug, at least on my part. For example, on the left side pane if I try reinstall a mod, and then cancel, I cannot open the mod in explorer. When I close the manager and start it up again, the mod has disappeared from the list, its esp files have disappeared etc. I believe this occurs with the external scripted installer mod types, for example sky ui. If select it from the left side pane when it is already installed, right click it and reinstall and then cancel, I cannot interact with it. Restarting the manager makes the mod completely disappear. Apart from this, very nice program. Very useful with texture mods too.

#3339
mrj0j0e

mrj0j0e

    Fan

  • Members
  • PipPipPip
  • 348 posts
In response to post #7775132. #7775211, #7777774 are all replies on the same post.

@Luinithil, Thank you for your detailed response, it's good to get some clarification on those few points.

It would seem I have been installing the mods correctly, I have been using BOSS ESP load order as a guideline to my mod order on the left hand pane.

Just to clarify the compatibility patches, I am merging them into the mods main file via MO but for an example, Consistent Older People has an Ethereal Elvern Overhaul Patch, however I have loaded the COP mod before EEO as I am supposed to, will the merged COP EEO Patch be moved after EEO automatically or do I need to install the patch separately and load it after EEO on the left hand side?

Thanks again for the help Luinithil, greatly appreciated.

#3340
mrj0j0e

mrj0j0e

    Fan

  • Members
  • PipPipPip
  • 348 posts
In response to post #7775132. #7775211, #7777774, #7778183 are all replies on the same post.

I'm still getting CTD and I cannot workout which mod is causing it. I seem to get a repeat crash when I go near the Giant camp close to Whiterun, this is the last part of my log if it helps?

[04/08/2013 - 08:41:45PM] Error: (000DC556): cannot enable an object with an enable state parent.
stack:
[ (000DC556)].lvlpredatorscript.Enable() - "<native>" Line ?
[ (000DC556)].lvlpredatorscript.OnCellLoad() - "LvlPredatorScript.psc" Line 26




Page loaded in: 6.223 seconds