Jump to content

Photo

Performance Tweaks For Smooth Gameplay


  • Please log in to reply
144 replies to this topic

#81
JookyThingy

JookyThingy

    Regular

  • Members
  • PipPip
  • 68 posts
@xavfx, I don't know why you only see 2-3fps difference. I'll give you a few more settings to try. But first, remove all those settings from the ini files and get a good idea of the default performance for comparison. Put those settings in skyrim.ini. Try the settings for 6 cores again just to make sure.

This below is the settings I use. It's intended for 4 cores.:

[General]

iNumHWThreads=4
iHWThread6=3
iHWThread5=3
iHWThread4=3
iHWThread3=2
iHWThread2=2
iHWThread1=2
iRenderingThread2HWThread=1
iRenderingThread1HWThread=0
iAIThread2HWThread=3
iAIThread1HWThread=2
bMultiThreadMovement=1
bUseThreadedParticleSystem=1
bUseThreadedBlood=1
bUseThreadedMorpher=1
bUseThreadedTempEffects=1
bUseThreadedTextures=1
bUseThreadedMeshes=1
bUseThreadedLOD=1
bUseThreadedAI=1
bUseHardDriveCache=0

[BackgroundLoad]

bUseBackgroundFileLoader=1
bUseMultiThreadedFaceGen=1
bBackgroundCellLoads=1
bUseMultiThreadedTrees=1
bBackgroundLoadLipFiles=1

[HAVOK]

iNumThreads=2

And these below are the settings I'd use for 2 cores:

[General]

iNumHWThreads=2
iHWThread6=1
iHWThread5=1
iHWThread4=1
iHWThread3=0
iHWThread2=0
iHWThread1=0
iRenderingThread2HWThread=0
iRenderingThread1HWThread=0
iAIThread2HWThread=1
iAIThread1HWThread=1
bMultiThreadMovement=1
bUseThreadedParticleSystem=1
bUseThreadedBlood=1
bUseThreadedMorpher=1
bUseThreadedTempEffects=1
bUseThreadedTextures=1
bUseThreadedMeshes=1
bUseThreadedLOD=1
bUseThreadedAI=1
bUseHardDriveCache=0

[BackgroundLoad]

bUseBackgroundFileLoader=1
bUseMultiThreadedFaceGen=1
bBackgroundCellLoads=1
bUseMultiThreadedTrees=1
bBackgroundLoadLipFiles=1

[HAVOK]

iNumThreads=2

Please note that one guy had already tried the tweaks for his 2 core cpu and found it didn't even work. I don't know why it didn't work for him but I speculate that somehow Skyrim didn't like to be forced to assign threads when the cpu only has two cores. Maybe it prefers to assign threads on its own based on some algorithm or something when the cpu only has 2 cores. I just don't know. You should still try it because you have 6 cores so it's possible that Skyrim will be forced to use the other cores even if the settings tell Skyrim to use only cores 0-1 in the ini.

If the settings for 2 cores above doesn't work, try these below. It's only a variation of the thread assignments.:

[General]

iNumHWThreads=2
iHWThread6=1
iHWThread5=1
iHWThread4=1
iHWThread3=0
iHWThread2=0
iHWThread1=0
iRenderingThread2HWThread=1
iRenderingThread1HWThread=0
iAIThread2HWThread=1
iAIThread1HWThread=0
bMultiThreadMovement=1
bUseThreadedParticleSystem=1
bUseThreadedBlood=1
bUseThreadedMorpher=1
bUseThreadedTempEffects=1
bUseThreadedTextures=1
bUseThreadedMeshes=1
bUseThreadedLOD=1
bUseThreadedAI=1
bUseHardDriveCache=0

[BackgroundLoad]

bUseBackgroundFileLoader=1
bUseMultiThreadedFaceGen=1
bBackgroundCellLoads=1
bUseMultiThreadedTrees=1
bBackgroundLoadLipFiles=1

[HAVOK]

iNumThreads=2

You can also try different variations on the thread assignments with the other settings for 4 and 6 cores to see if it makes any difference. Remember, Skyrim numbers cpu cores this way: 0-1 for 2 cores, 0-1-2-3 for 4 cores, 0-1-2-3-4-5 for 6 cores, 0-1-2-3-4-5-6-7 for 8 cores, and so forth. Tell us how it goes.

#82
I2edShift

I2edShift

    Dragon Hunter

  • Premium Member
  • 2,056 posts
So, I've tried your copy/pasting your given settings for a quad core + hyperthreading CPU, as I use a i7 930 @ 4.0 Ghz, and I've MAYBE seen 1 FPS increase in an area where I was previously CPU bound? Even then that can just be statistical noise. The game also "feels" no different. Maybe my machine is to powerful to notice the difference? Using a overclocked GTX 680 4gb, so I have a lot of GPU horsepower to.

#83
JookyThingy

JookyThingy

    Regular

  • Members
  • PipPip
  • 68 posts
@12edShift, check resource meter how many cores are used with and without the tweaks. That's a very powerful machine so even if it didn't use 8 cores, it could still be able to run Skyrim at full fps and the tweaks wouldn't do much more. But I'm just speculating here. Compare my machine. i5, GTX 285, 4GB ram. I get a significant boost in performance especially in the minimum fps. A few other guys with i7 cpus got a boost too. On the other hand, make sure you put the settings in skyrim.ini located in my documents/my games/skyrim folder. They won't work anywhere else. And check for duplicates. If there's duplicates but with different values, I have no idea which one takes precedence, or if Skyrim reverts to defaults. I really don't know why it doesn't work for you. What's your fps without the tweaks?

Edited by JookyThingy, 14 July 2012 - 02:07 AM.


#84
I2edShift

I2edShift

    Dragon Hunter

  • Premium Member
  • 2,056 posts
Resources on threads are identical with the modified .ini file or unmodified. Same four threads are working all the time. Yes, they're in the correct .ini file, under the appropriate headers, I also made a new header/section if it wasn't there already. Specifically backroundload & havok. Well, vanilla top-whiterun is already at 60 FPS, but If I add "Beatiful Whiterun" to it I become CPU bound down to 46-48 FPS. EDIT: I did some further testing and thought it was working for me, but with a default Skyrim.ini, I can actually see the game use all 8 of my threads through my task manager. Very interesting.

Edited by I2edShift, 14 July 2012 - 05:01 AM.


#85
kaizersoze27

kaizersoze27

    Faithful poster

  • Supporter
  • PipPipPipPip
  • 1,904 posts
Hi There,

I have an AMD 8 core (FX 8120) processor with NVidia GTX 360 graphics. Any help on this?

Thank you

#86
jacktthompson

jacktthompson

    Ethereal

  • Premium Member
  • 1,043 posts
I believe Bethesda fixed multithreading in a recent patch, however I think it still may be limited by the engine.

@I2edShift, What is your fps difference with the default ini and the modified ini with the thread assignments?

Edit: I thought about this a little more and threads do not necessarily mean all 4 hardware cores are being used. Some processes use 30 threads and one core for example.

One way to quantitatively measure this is run FRAPS or similar in a certain area and note the difference.

Edited by jacktthompson, 16 July 2012 - 08:25 PM.


#87
JookyThingy

JookyThingy

    Regular

  • Members
  • PipPip
  • 68 posts
To check what settings are used currently, you can use the console command saveinifiles or saveini, then check the thread settings in those files. Do this with default settings first to see if Skyrim will automatically assign cores to different threads when you don't assign them manually. Then do it with the settings and see if they stick.

If Jack is right about the latest patch, then it's possible Skyrim now reverts to a default thread scheme (probably by correctly identifying the number of cores you have) if you fool around with the settings, even if those settings end up being the same ones Skyrim will assign automatically when you don't assign them manually. If that's true, then the tweaks here have been made irrelevant, at least with the latest patch. Not only that, but the settings themselves appear to be useless.

I'd like to get confirmation first about the above, but this means the tweaks are not needed anymore, and I'll eventually remove it.

#88
jacktthompson

jacktthompson

    Ethereal

  • Premium Member
  • 1,043 posts
Yes. Agree we need more testing. Even though Skyrim correctly identifies number of hardware cores now does not mean it assigns threads to all four or eight cores optimally. There is some disagreement about actual utilization of four cores among the forums. So the settings are not irrelevant.

Edited by jacktthompson, 15 July 2012 - 11:34 PM.


#89
loso64

loso64

    Journeyman

  • Members
  • Pip
  • 49 posts
@JookyThingy i use latest patch and it gave me boost of 20fps+ and stability so not it is not irrelevant

#90
JookyThingy

JookyThingy

    Regular

  • Members
  • PipPip
  • 68 posts
@loso64, thanks for the headsup. I'll keep it then.




Page loaded in: 1.159 seconds