Jump to content

Photo

Creation Kit NPC Facial Textures Help


  • Please log in to reply
63 replies to this topic

#1
LieutenantHawk

LieutenantHawk

    Regular

  • Members
  • PipPip
  • 90 posts
I'm working on some follower MODs for Skyrim but I've hit a bit of a speed bump. The characters I make have the right tones on their body, but no facial coloring appears in-game. From the neck up, the color is completely different from the rest of the body, and no detail tints or paint appears. Does anyone know what's wrong?
Also, I can't find an option for adding scars in the CK.

Thanks in advance for any help!
-Hawk

Edited by LieutenantHawk, 28 February 2012 - 02:48 AM.


#2
gsmanners

gsmanners

    Faithful poster

  • Members
  • PipPipPipPip
  • 2,333 posts
Okay, the problem is two-fold (AFAIK).

1) You need FaceGenData (in Data/Textures/Actors/Character/FaceGenData/FaceTint/<esm name>/<id>.dds
2) You need an ESM (to go with the data).

So, first you have to ESM-ify your plugin, then load it into the CK. That done, you need to select your NPCs and press Ctrl-F4 (and confirm).

And there you go. I think that's all you need to do. :tongue:

#3
LieutenantHawk

LieutenantHawk

    Regular

  • Members
  • PipPip
  • 90 posts

Okay, the problem is two-fold (AFAIK).

1) You need FaceGenData (in Data/Textures/Actors/Character/FaceGenData/FaceTint/<esm name>/<id>.dds
2) You need an ESM (to go with the data).

So, first you have to ESM-ify your plugin, then load it into the CK. That done, you need to select your NPCs and press Ctrl-F4 (and confirm).

And there you go. I think that's all you need to do. :tongue:


How exactly does one "esm-ify" an esp file? And I'm not sure what do do with the FaceGenData.

#4
gsmanners

gsmanners

    Faithful poster

  • Members
  • PipPipPipPip
  • 2,333 posts
That's a good question. I think there's something like tesvsnip could do that.

You'll also need to add bAllowMultipleMasterLoads=1 in [General] in SkyrimEditor.ini in your folder that has CreationKit.exe in it.

EDIT: Okay, I just tried following my own advice, and it seems to work fine (at least for me).

Edited by gsmanners, 28 February 2012 - 04:21 PM.


#5
sanwyrth

sanwyrth

    Journeyman

  • Members
  • Pip
  • 37 posts

That's a good question. I think there's something like tesvsnip could do that.

You'll also need to add bAllowMultipleMasterLoads=1 in [General] in SkyrimEditor.ini in your folder that has CreationKit.exe in it.

EDIT: Okay, I just tried following my own advice, and it seems to work fine (at least for me).


I have the same problem too :/
I did everything according to your descriptions but still nothing. Only thing I got was the \Data\Textures\actors\character\FaceGenData\FaceTint\Follower.esm\code.dds, still the game doesn't seems to read it >_<
Any other suggestions? :s
Thanks.

Edited by sanwyrth, 28 February 2012 - 05:02 PM.


#6
No_Aardvarks_Allowed

No_Aardvarks_Allowed

    Old hand

  • Premium Member
  • 533 posts


That's a good question. I think there's something like tesvsnip could do that.

You'll also need to add bAllowMultipleMasterLoads=1 in [General] in SkyrimEditor.ini in your folder that has CreationKit.exe in it.

EDIT: Okay, I just tried following my own advice, and it seems to work fine (at least for me).


I have the same problem too :/
I did everything according to your descriptions but still nothing. Only thing I got was the \Data\Textures\actors\character\FaceGenData\FaceTint\Follower.esm\code.dds, still the game doesn't seems to read it >_<
Any other suggestions? :s
Thanks.

Are you sure you've made your .esp into an .esm? Loading an .esm in the CK and highlighting an actor (or several at the same time), pressing ctrl + F4 should also exports the face mesh to meshes\actors\character\facegendata\facegeom. If you use an .esp, you only export the texture, which isn't enough for custom actors.

Edited by No_Aardvarks_Allowed, 28 February 2012 - 05:09 PM.


#7
sanwyrth

sanwyrth

    Journeyman

  • Members
  • Pip
  • 37 posts



That's a good question. I think there's something like tesvsnip could do that.

You'll also need to add bAllowMultipleMasterLoads=1 in [General] in SkyrimEditor.ini in your folder that has CreationKit.exe in it.

EDIT: Okay, I just tried following my own advice, and it seems to work fine (at least for me).


I have the same problem too :/
I did everything according to your descriptions but still nothing. Only thing I got was the \Data\Textures\actors\character\FaceGenData\FaceTint\Follower.esm\code.dds, still the game doesn't seems to read it >_<
Any other suggestions? :s
Thanks.

Are you sure you've made your .esp into an .esm? Loading an .esm in the CK and highlighting an actor (or several at the same time), pressing ctrl + F4 should also exports the face mesh to meshes\actors\character\facegendata\facegeom. If you use an .esp, you only export the texture, which isn't enough for custom actors.


1) I converted the Follower.esp to Follower.esm with TESVnip (i just saved it as esm, nothing else modified)
2) I opened CK loaded up the Follower.esm. Took the actor i have setted as follower and pressed CTRL+F4, confirmed. (at character's sheet i've also checked the "Is CharGen face preset" but anyway tested with both checked and unchecked)
3) Deactivated the Follower.esp and Activated the Follower.esm at Launcher>Datafiles for not getting double NPC's
Still textures hadn't changed :(
I also checked the datafiles just to be sure and seemed pretty fine to me:
Data\Textures\actors\character\FaceGenData\FaceTint\Follower.esm\code.dds, for the textures and
Data\meshes\actors\character\FaceGenData\FaceGeom\Follower.esm\ a CK file with a code, for meshes
Any suggestions?

Edited by sanwyrth, 28 February 2012 - 08:50 PM.


#8
No_Aardvarks_Allowed

No_Aardvarks_Allowed

    Old hand

  • Premium Member
  • 533 posts
If the follower already is in your save game, it may be s/he is made from the old .esp and not the new .esm and therefore still has the old face. Try disabling and then spawn a new version of the follower, using its .esm base id (which of course is different, since the .esm is loaded earlier). If that doesn't work, I don't get it, since you obviously have the facegen data exported to the right places.

#9
sanwyrth

sanwyrth

    Journeyman

  • Members
  • Pip
  • 37 posts

If the follower already is in your save game, it may be s/he is made from the old .esp and not the new .esm and therefore still has the old face. Try disabling and then spawn a new version of the follower, using its .esm base id (which of course is different, since the .esm is loaded earlier). If that doesn't work, I don't get it, since you obviously have the facegen data exported to the right places.



Yes he was saved .. I guess thats the only thing I have left to try.
I'll be getting to it in a couple of hours and let you know if it worked, thanks for all the help so far tho :)

#10
sanwyrth

sanwyrth

    Journeyman

  • Members
  • Pip
  • 37 posts


If the follower already is in your save game, it may be s/he is made from the old .esp and not the new .esm and therefore still has the old face. Try disabling and then spawn a new version of the follower, using its .esm base id (which of course is different, since the .esm is loaded earlier). If that doesn't work, I don't get it, since you obviously have the facegen data exported to the right places.



I remade him and it worked :).
Thanks!


Edited by sanwyrth, 28 February 2012 - 08:40 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Page loaded in: 1.040 seconds