Jump to content

Photo

"Better horses" mod problem


  • Please log in to reply
12 replies to this topic

#1
Angkorbeer

Angkorbeer

    Stranger

  • Members
  • Pip
  • 7 posts
Hi,

First, I'm a complete noob at using mods: Better Horses is the first I ever try.

I downloaded the mod as well as the Nexus mod manager. I installed both. I started the manager and ticked to activate the better horses mod. So far so good.
In the game, I loaded my last save, went to the Whiterun stables, found the book "How to train your horse" and read it. The instructions said there should be some options dialog after reading the book, but nothing for me.
I go to my horse (Shadowmere) and try to crouch and select it, but it doesn't give me an inventory: My character simply sits on the horse as usual.

I've tried using the command "set HorseSettings to 1". It doesn't give my any syntax error, but it doesn't change anything either.

Any idea what I could be doing wrong ?

Thanks in advance for any suggestions.

Edited by Angkorbeer, 04 March 2012 - 03:23 PM.


#2
warstick

warstick

    Regular

  • Members
  • PipPip
  • 66 posts
Hi Angkorbeer, I have the exact same problem, but have not found a solution so far. When I read the book nothing happens and there is no dialog box. If you have the book in the game that means that most likely you did install the mod correctly. I have tons of mods installed and thought that one of them conflicts with "better horses". But apparently they are not the cause since you have the same problem without other mods installed (if I understood you correctly).

The readme in the mod did mention that some problems might occur if the first time you load a game when the mod is installed your character is mounted on a horse. Was this the case for you? Because it was for me. I tried reinstalling the mod, but apparently there is no way to completely uninstall it. Some parts do get left over. So I can't cancell out that as a possible cause.

It is really a shame, because you are the only person other than me that I have found to mention this problem. I hope someone can help us....

#3
Angkorbeer

Angkorbeer

    Stranger

  • Members
  • Pip
  • 7 posts
Thanks for replying, Warstick.

To answer your question, I wasn't mounted on a horse when I first loaded after installing the mod. And you got me right: I don't have any other mod installed.

Since I couldn't find any solution on the web for the bug, I'd guess writing to the author of the mod would be an option... Or maybe there are more active forums where to ask around?
In any case, if you ever find the solution, please come back and post it here.

Too bad: I don't really enjoy horses all that much in Skyrim. I've played so far without one; until Shadormere was loaned to me. Now I'm stuck with it, and I figure it might as well do what I tell it to, and might as well carry some load. That's what prompted me to seek out a mod in the first place. The Better horses seemed perfect. Bud bad luck, I guess.

Good luck finding a solution!

#4
warstick

warstick

    Regular

  • Members
  • PipPip
  • 66 posts
Angkorbeer! I have finaly found a solution!
It seems that the problem was with the game being ubable for some reason to read the .bsa archive file. To solve the problem (I'm sure it's the same for you) extract the bsa file manually.

Here is how to do it:

1. Better Horses mod contains two files (It_better_horses.bsa and It_better_horses.esp). When you have installed the mod you put these two files into your Skyrim Data folder. Assuming they are still there, remove the .bsa file from the Skyrim Data folder (do not delete, move to desktop or something) but keep the .esp file in place.
2. Now you will have to extract the bsa file manually. For that you will need the BSA Unpacker. Download it here: http://tes.nexusmods...id=3117#content (if the link does not work, just search for it on nexus).
3. Once donwnloaded open the bsa file that you moved to your desktop through the unpacker. When clicking "Extract All" the unpacker will ask you where you want the files extracted to. For now make a new folder on your desktop and extract there.
4. The extracted file will give you two folders: "scripts" and "sound". Copy these folders into your Skyrim Data folder and make sure they combine with the existing ones.

That is it! Now run the game, read the book and the dialog box should now work. Once you select all the preffered options, restart the game.

I have to say that the mod is certainly worth the trouble, it really does make getting a horse worthwhile--don't need a horse just unmount and run where you like, need it, just whistle and there it is with all of your extra gear...

Good Luck!

Edited by warstick, 20 March 2012 - 08:49 PM.


#5
Angkorbeer

Angkorbeer

    Stranger

  • Members
  • Pip
  • 7 posts
Thanks for posting this. I'll try it this evening, or next time I play. I'll keep you posted.

#6
Angkorbeer

Angkorbeer

    Stranger

  • Members
  • Pip
  • 7 posts
It is a great mod ! Etheral Whistle blows !!

It works now, but stupidly, I couldn't test your solution...

Since my first post, I had to reinstal the game. A visual bug occurred after an AMD update, and I reinstalled plus updated all of Skyrim in the process of fixing it. Now, as I reinstalled the mod, it worked for the first time, before I even had a chance to apply your solution and install the bsa's extracted files...
In my old installation, something must have been interfering with the game's ability to read the mod, as you suggested. Probably a missing file.

Nevertheless, you did find a solution. Thanks for posting it. The next people who google this problem will now have a reference.
And thanks for the clear and detailed installation procedure. They should all be written like that.

Good work Warstick !

Edited by Angkorbeer, 21 March 2012 - 03:58 AM.


#7
princessdawn982

princessdawn982

    Journeyman

  • Members
  • Pip
  • 29 posts
Um hi. I'm new at loading mods. This is my 1st one too. I done everything you said,but I can't seam to find the book. Any help?

#8
Angkorbeer

Angkorbeer

    Stranger

  • Members
  • Pip
  • 7 posts
Go to the nearest stables, and look around on top of the barrels. (It's on a barrel to the right of the stables outside of Whiterun, if I remember correctly.)

If you can't find it, maybe the mod isn't installed properly. Write again then and I'll try to coach you. I'm also new at modding : I know a little help is sometimes needed.

#9
princessdawn982

princessdawn982

    Journeyman

  • Members
  • Pip
  • 29 posts
Oh ok thanks. I didn't have it activated right. Everything works fine now!

#10
Angkorbeer

Angkorbeer

    Stranger

  • Members
  • Pip
  • 7 posts
Have Fun!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Page loaded in: 1.355 seconds