Jump to content

Photo

less CTDs maybe none


  • Please log in to reply
54 replies to this topic

#1
fruitgnome

fruitgnome

    Fan

  • Members
  • PipPipPip
  • 477 posts
I had so many ctds (most were random but some were repeatable), so I searched and found this:
http://www.creationk...tings_(Papyrus)
Skyrim.ini
[Papyrus]
fUpdateBudgetMS=1.2
fExtraTaskletBudgetMS=1.2
fPostLoadUpdateTimeMS=500.0 ;Xenon and PS3 use 2000.0
iMinMemoryPageSize=128
iMaxMemoryPageSize=512
iMaxAllocatedMemoryBytes=76800
bEnableLogging=0
bEnableTrace=0
bLoadDebugInformation=0
bEnableProfiling=0

I began by doubling some values and now it looks so:
[Papyrus]
fUpdateBudgetMS=800
fExtraTaskletBudgetMS=800
fPostLoadUpdateTimeMS=2000
iMinMemoryPageSize=256
iMaxMemoryPageSize=512
iMaxAllocatedMemoryBytes=2457600
bEnableLogging=0
bEnableTrace=0
bLoadDebugInformation=0
bEnableProfiling=0

Since this values I had no CTD!
(With these settings Dynavision is almost good running! (I get focus on far away things.)

Hints:
I use many mods with scripts running in loops:
Frostfall
Unread Books Glow
IMCN
and also
WARS
WARZONES

On the side is written something with fps loss but I don't have less fps.

My System
Win 7 64-Bit
i5-750
4 GB Ram
8800 GT

Please report if you have success by changing these values!

THX

#2
Gopher

Gopher

    Resident poster

  • News writer
  • 6,088 posts
Do you know which values made a difference or did it need all of them?

#3
fruitgnome

fruitgnome

    Fan

  • Members
  • PipPipPip
  • 477 posts
All values are discribed on the site I linked.
fPostLoadUpdateTimeMS=2000 is for loonger loading screens so that Papyrus has more time.

Nice to read here from U, Gopher!

Edited by fruitgnome, 30 March 2012 - 06:47 PM.


#4
Gopher

Gopher

    Resident poster

  • News writer
  • 6,088 posts
Ok, just tried them, and I could not see any faster updates on the script BUT I got less stutters in game, PLUS dynavision seemed to react a little smoother. Might have been my imagination as it runs fairly smooth for me already, but I actually think my general game feels smoother.

You may be on to something here.

#5
sikma200

sikma200

    Fan

  • Members
  • PipPipPip
  • 316 posts
I did this, but I keep randomly crashing when I'm fighting the second group of imperials in helgen's keep. please help.

#6
ZoCks

ZoCks

    Old hand

  • Supporter
  • PipPipPip
  • 721 posts
Nice Find! Thanks for the tip!

#7
sikma200

sikma200

    Fan

  • Members
  • PipPipPip
  • 316 posts
I found out I'm still crashing with this on, but its not just when i'm fighting the second group of imperials, I just crash after [I think] 10 seconds. Please reply to me or message me.

#8
fruitgnome

fruitgnome

    Fan

  • Members
  • PipPipPip
  • 477 posts
What System do you have? How are your graphic settings? Try to lower them.

#9
AngeGardien

AngeGardien

    Fan

  • Banned
  • PipPipPip
  • 292 posts
???, why it's writing ps3,

other thing, i view you have only 4gm of memory, it's the minimum to be able to play well, and in more they ask a graphic card whit 1gb of memory, you seem to be on the limit...

#10
Kyokushinoyama

Kyokushinoyama

    Flamekeeper

  • Supporter
  • PipPipPipPipPip
  • 9,596 posts
Hey,

nice find !

Is this value the most important : fPostLoadUpdateTimeMS ?

I got few CTDs, and I'm using much higher values for imaxallocatedmemorybytes and memorypagesize.

Got 230+ mods with some heavy scripts aso.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Page loaded in: 1.153 seconds