Jump to content

Photo

Skyrim Alt-tab mouse fix


  • Please log in to reply
78 replies to this topic

#1
Site Bot

Site Bot

    Fear me

  • Members
  • PipPipPipPipPip
  • 948,340 posts
Skyrim Alt-tab mouse fix

This mod fixes the recent problem of the windows mouse cursor showing up in game as well as the game one, especially after alt-tab

#2
LeonTubrok

LeonTubrok

    Enthusiast

  • Members
  • PipPip
  • 138 posts
I find if you press escape first the bring up menu b4 you alt+tab stops the mouse showing when you come back to skyrim

#3
wheybags

wheybags

    Journeyman

  • Members
  • Pip
  • 35 posts
Yes, but with this you don't have to do that.

#4
moxyll

moxyll

    Stranger

  • Members
  • Pip
  • 1 posts
The .bat file provided with this caused my mouse to disappear on any window that contained "skyrim" in the name, including a browser window opened to this site!

I fixed it by changing this line:
getwindowtitle.exe 2>NUL | find /I /N "Skyrim">NUL

to this:
getwindowtitle.exe 2>NUL | findstr /I /N /R "^Skyrim$">NUL

If you manage to have a window open whose full name is "skyrim", it'll still hide the mouse there. But we can't do anything about that with this setup.

#5
wheybags

wheybags

    Journeyman

  • Members
  • Pip
  • 35 posts
@moxyll
Yeah, I realised this, and I actually just fixed that myself.
I also just changed it around a bi, and replaced nomousy.exe as it was buggy, with an ahk script of my own making.
Thanks.

#6
Zaflis

Zaflis

    Enthusiast

  • Members
  • PipPip
  • 204 posts
To fix the bug, all you need to do is: - Right click your SKSE or Skyrim shortcut and open properties - Go to compatibility tab - Disable themes Have never seen windows cursor in Skyrim again. edit: As i said that, i saw cursor appear -.- But i alt+tabbed without pausing the game first.

Edited by Zaflis, 29 July 2012 - 08:25 PM.


#7
THEphotographer

THEphotographer

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,200 posts
thx a nightmare when capture

#8
wheybags

wheybags

    Journeyman

  • Members
  • Pip
  • 35 posts

To fix the bug, all you need to do is:
- Right click your SKSE or Skyrim shortcut and open properties
- Go to compatibility tab
- Disable themes

Have never seen windows cursor in Skyrim again.

edit: As i said that, i saw cursor appear -.- But i alt+tabbed without pausing the game first.


This mod works without having to do that

#9
meteor71

meteor71

    Journeyman

  • Premium Member
  • 21 posts
This utility does exactly what you said it would do. Nicely done! You have my endorsement.

#10
Krhanal

Krhanal

    Fan

  • Members
  • PipPipPip
  • 342 posts
Um, when I start the game via Launch.bat, it launches two instances of the game. What's up with that?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Page loaded in: 0.968 seconds