Jump to content

Photo

Delphine Wont recruit my follower


  • Please log in to reply
12 replies to this topic

#1
Mussymus

Mussymus

    Stranger

  • Members
  • Pip
  • 2 posts
I Installed The recruit more blades mod and i recruited 9 untill i tried recruiting one more and delphine would say "i will do the oath later just get them geared up" but my follower doesnt leave my side ANY HELPP

#2
OLtos

OLtos

    Newbie

  • Members
  • Pip
  • 19 posts
Hi,

We have the same problem but we do not have the "Recruit More Blades" mod. All we have is UFO. So I am thinking that this problem is not related to that blades mod. However, more of the problem we are having is like this:
When Delphine says she will give the oath later, we get the message, "Follower has left your service.",
then we get confirmation from the game that this quest is completed, and we are given the quest to go and find another recruit. But follower does not leave.
If you then dismiss the follower they go away! They don't stick around the temple.

We are testing the following:
1. Trying a different follower to see if the problem is related to a specific NPC, which may differ from player to player or save game to save game. Our problem seems not to be NPC specific. When we get the dialogue from Delphine that she will give the oath later, the follower does not automatically leave our service.

2. Tried dismissing all other followers before taking that one to Delphine. At that point Delphine did NOT say she would administer the oath later. And, the process went normally. The follower left our service and walked off into the temple.

That was where we stopped. A further test might be:

3. Recruit follower to blades, get appropriate confirmation from Delphine. (In our case the game gives us the confirmation that the follower was recruited and to go and get another one.) Then dismiss the follower. Follower will leave the temple. Maybe Delphine will go and find her later and administer the oath like she says.


The problem seems to be related to the dialogue about giving the oath later. If that happens then weirdness results. If I get to this point again I will test this third option.

#3
knovack1

knovack1

    Anon

  • Premium Member
  • 670 posts

Seriously am I the only person out there that has this VERY ANNOYING BUG with Delphine of course.  I searched all corners of the internet and did not see anyone else with this bug.

 

I always play Skyrim with close to 100 mods, and sure I get bugs here and there.  I have close to 2k hours total invested in Skyrim right now, and this is the FIRST, the VERY FIRST time I got this bug. I ALWAYS played Skyrim with the mod Parthurnaax Dilema.  This mod allows Parthurnaax to stay alive, and yet rebuild the Blades.  Well when I bring Jordis to Delphine, I get as far as Delphine telling me she has to give her the Oath.  Well Delphine DOES NOT GIVE HER THE OATH leaving me stuck with Jordis.  So the trip to Sky Haven Temple was a waste.  Where is the fix for this bug?



#4
SydneyB

SydneyB

    Fire and Blood

  • Premium Member
  • 29,573 posts

I am having the same problem: Delphine says she will give the oath but she doesn't and my follower still follows me, and I get no message about my follower leaving me. I've tried this with Uthgerd and Belrand. 

 

I am using UFO (latest stable version), Paarthunaax Dilema and the Unofficial patches. Disabling UFO completely doesn't fix it either :(



#5
Auzarion

Auzarion

    Enthusiast

  • Members
  • PipPip
  • 138 posts

I got this to. i am using UFO latest and the Paarth Dilema. I remember getting this before. But I cannot remember how I fixed it.

 

The thing I have is I dismiss all followers only leaving one with me. (Only vanilla NPCs I do this with) and I tell Delphine to recruit them. She says okay and says to bring another one. She will administer the oath right away. After this conversation, she doesn't do anything. She does not administer the oath and continues to walk around not doing it. Follower does not leave service and etc. No one can become blades because of this. :|

 

This is my load order only got a few. Maybe its a follower mod? :sad: I have no idea....  Something is affecting the Delphine quest for Skyhaven temple quest line. Its driving me up the wall!! I wonder if we all have the same mod thats doing this and its not UFO or the Paarth dilema.

 

Skyrim.esm=1
Update.esm=1
Unofficial Skyrim Patch.esp=1
Dawnguard.esm=1
Unofficial Dawnguard Patch.esp=1
HearthFires.esm=1
Unofficial Hearthfire Patch.esp=1
Dragonborn.esm=1
Unofficial Dragonborn Patch.esp=1
hornsareforever.esp=1
dD - Realistic Ragdoll Force - Realistic.esp=1
dD-No Spinning Death Animation.esp=1
The Dance of Death - Ultimate Edition.esp=1
Dragon Soul Relinquishment.esp=1
dovahkiinrelax.esp=1
Reduced Distance NPC Greetings.esp=1
AK- Clothe Dead NPCs.esp=1
V740T_MGolDinS&M.esp=0
Helgen Reborn.esp=1
GoTS.esp=1
DrSKnapsacks.esp=1
BarenziahQuestMarkers_Droppable.esp=1
UnlimitedBookshelves.esp=1
SabreFurBag.esp=1
Chesko_WearableLantern.esp=1
RGMsAlchemistsCompendium.esp=1
CraftableClothes.esp=1
LordOfWar_TW2.esp=1
MedievalArmory.esp=1
Plate Armours - Credo.esp=1
W2_HelmetPack.esp=1
W2_HelmetPack-2.esp=1
Shields_of_the_northern_kingdoms.esp=1
TH3WICK3D1-NorthernKingdomsHeavyPlate.esp=1
Cloaks.esp=1
1nivWICCloaks.esp=1
1nivWICSkyCloaksPatch.esp=1
Dr_Bandolier.esp=1
Dr_BandolierDG.esp=1
BandolierForNPCMasterFile.esp=1
BandolierForNPCs.esp=1
BandolierForNPCsCheaperBandoliersDawnguard.esp=1
BandolierForNPCsWIC_V2.esp=1
BandolierForNPCsCloaksOfSkyrim.esp=1
Hothtrooper44_Armor_Ecksstra.esp=1
Hothtrooper44_ArmorCompilation.esp=1
RegentSword.esp=1
Immersive Weapons.esp=1
ArmorOfIntrigue.esp=1
MarksmanArmor-byWitcher5688.esp=1
alb084ImmersiveFollowers.esp=1
Follower Pack I.esp=1
Follower Pack II.esp=1
Follower Pack III.esp=1
Whiterun Guard Followers.esp=1
Sol Followers 2.esp=1
argoniansmore.esp=1
ImperialFollowers.esp=1
khajiitmore.esp=1
Ral-Kur1.1.1.esp=1
WalksInShadows.esp=1
Meesei.esp=1
Zeeri.esp=1
Convenient Horses.esp=1
UFO - Ultimate Follower Overhaul.esp=1
UFO - Dawnguard AddOn.esp=1
UFO - Heartfire AddOn.esp=1
UFO - Dragonborn AddOn.esp=1
UFO - AllwaysDrawWeapons.esp=1
marriagedynamicoutfits.esp=1
My Home Is Your Home.esp=1
FollowerWander2.esp=1
FollowerWander2Serana.esp=1
MIDFollowMeCloser.esp=1
UFOtweak.esp=1
Inconsequential NPCs.esp=1
Immersive Followers.esp=1
JNL - Lots More Followers.esp=1
Fezzik the Giant.esp=1
CompanionValfar.esp=0
4 new followers - khajiits [Mittgang] v1.1.esp=1
KhajiitBrothers.esp=1
KCEYushinFollower.esp=1
Osira the Castrator.esp=1
argonianlove.esp=1
The Paarthurnax Dilemma.esp=1 (Moved this one to see if it may work and as well disabled it. Did not work...)
Equipping Overhaul.esp=1
SkyUI.esp=1
Bashed Patch, 0.esp=1
 


Edited by Auzarion, 22 February 2014 - 06:12 AM.


#6
Trent000

Trent000

    Stranger

  • Members
  • Pip
  • 3 posts

I'm having this issue too - I use to have UFO, but removed it and delete the files (the latter I did because I felt it could relate to this bug) - I've found little on the internet about it, and I've disabled EVERYTHING (even the official DLCs) and still the bug occurs.

 

I'm thinking about looking in the CK for the events needed for the oath to be taken "Correctly" and see if I can make a mod which just gets it to skip that part and forces them into the Blades

 

I've tried a couple of things - I used recyleactor on both Delphine and the follower, with no luck. I've checked my follower count and that's normal, so I think if its UFO related its causing a change in the save file thats not related to the mod being enabled - if thats even possible.
 

If anyones got a fix that would be great thanks


Edited by Trent000, 22 February 2014 - 11:08 PM.


#7
qwerty6969

qwerty6969

    Stranger

  • Supporter
  • Pip
  • 9 posts

Same problem here, get up to the point where she says to bring more followers, follower doesn't leave and delphine does no oath.

Tried both UFO versions with just one follower and even without UFO

I blame UFO because its the only mod that edits this quest as shown in tes5 edit

I can set each stage using the console to finish the quest but no one gets added to the blades and i go dragon hunting alone

 



#8
Trent000

Trent000

    Stranger

  • Members
  • Pip
  • 3 posts

Personally I dont mind hunting dragons without them - but it is a pain that its a persistent change made by the mod.

 

But so UFO does change this quest? Good to know


Edited by Trent000, 02 March 2014 - 04:35 AM.


#9
Auzarion

Auzarion

    Enthusiast

  • Members
  • PipPip
  • 138 posts

Whats the code to skip the quest then? Have to do this 3 times then so she finally says shes the head blade grand master. I would be fine with this as I have made the place a huge hangout of my blades with UFO. So I can just make them follow me when we go blade hunting. :smile:

 

Trent I would love to use that mod fixing Delphine inducting blades if you made it.

 

 

Also found this helpful thing.

Bottom of page

http://www.uesp.net/...ding_the_Blades

Adding Initiates (through the console)?

For whatever reason I am unable to recruit my followers into the Blades. After enabling/disabling a good portion of my Mods (I don't run that many, either) the problem persists. What happens (or, more accurately, what DOESN'T happen) is when I tell Delphine that I have a recruit, she asks if I'm sure (to which I reply 'Yes') and then says she'll say the Oath.

However, she doesn't. After fiddling around with the game a little, I figured out that Delphine will say the Oath if I set the Quest Stage forward during the conversation. However, my Follower doesn't say their part of the Oath, and acts as if nothing happens. Is there a script that they should recieve, or a faction I can put them into, that would effectively make them react as if they had become a Blade? I noticed there was a 'BladesRecruitsFaction'. but I don't know it it's actually used, or how/when to add said follower to it.

 

Blades quest lines at bottom

http://www.uesp.net/...es&oldid=857870

 

Faction IDs  (Blades faction IDs are in there)

http://www.uesp.net/...yrim:Factions_B

 

Blades

BladesFaction 00072834

 

BladesRecruitsFaction 000E652D
 
 
I still haven't been able to fix the problem. :\
 
Tried recruit more blades mods and the like on the nexus and even went to "resetquest freeformskyhaventemplea" to reset the quest but still it persisted with Delphine not giving the Oath. I am baffled as to how and what change made this happen to make her not do the Oath. If a mod was made to allow the blade content to come back with UFO that would be awesome.

Edited by Auzarion, 15 March 2014 - 08:13 PM.


#10
Trent000

Trent000

    Stranger

  • Members
  • Pip
  • 3 posts

I currently work as a programmer with Unreal3 and 4, and have to balance that with uni, so I don't have the time to really learn the CS in the depth I believe this issue requires to solve :(

 

I can however share my logic:

 

First it would be good if someone uses a glitched save in a fresh modless install of skyrim - If the glitch remains then the issue is within the save file (something which is a massive no no in mods - your mod should not without good reason change something that persists when the mods removed, for the very reason we are all having this issue).

 

Try looking for a variable that sets if the oeth can be taken - something that is already in Skyrim (i.e Bethesda variables and data) and that UFO has simply changed. In typing this I'm reminded of something else: in my version of the game Delphine and the "other guy" (i can't remember his name - you escort him out of the ratways etc) never stay inside if I wait.

 

If I wait for any amount of time, when waiting is over they are always at the door, walking as if they have just entered the cell - They NEVER remain in the cell. I wonder if somethings gone wrong there, and hence they never properly start to "live" in the temple. 

 

@Auzarion: Yes I've looked around there and yes I believe there is a script or some special "thing" that occurs that no ones found. Again with the fresh install of Skyrim, it would be worth doing to compare - I recommend looking for something thats instanced (hence saved with the game) that has the power to stop the oath. 

 

Hope that helps - I'll try lend a hand when I get free time :)






Page loaded in: 1.093 seconds