Jump to content

Photo

RaceCompatibility for Dawnguard


  • Please log in to reply
974 replies to this topic

#1
Site Bot

Site Bot

    Fear me

  • Members
  • PipPipPipPipPip
  • 984,179 posts
RaceCompatibility for Dawnguard

This package allows mod authors to make mods based on the RaceCompatibility.esm to work properly with Dawnguard.

#2
Wyldsong

Wyldsong

    Old hand

  • Members
  • PipPipPip
  • 783 posts
You are awesome! Thanks for this! I will be back to endorse in an hour=)

Edited by Wyldsong, 15 September 2012 - 04:38 PM.


#3
narphous

narphous

    Old hand

  • Premium Member
  • 716 posts
Brilliant! Thanks!

#4
RedLeviathan

RedLeviathan

    Fan

  • Members
  • PipPipPip
  • 310 posts
Question...

Are the scripts compatible with UFO and Better Vampires? I noticed that this mod overwrite the scripts from both mods.

#5
TMPhoenix

TMPhoenix

    Faithful poster

  • Premium Member
  • 1,696 posts
I do not know what UFO changes exactly, since the source for the modified script has not been included by the author, but I can tell you that I've used my custom race in combination with UFO without any visible problems.
Of course, I rarely have companions when I start the companions questline and I generally do not use any of the companions as followers. A quick peek with the disassembler shows that the script may change the handling of the PlayerFollowerCount variable only. If that is all, I might be able to produce a script that is 100% compatible. I'll look into this some more.

Better vampires is another story; That mod completely replaces the PlayerVampireQuest script. That's going to be a little more difficult to fix. I'll analyse the script some more, if I can merge the scripts I'll contact the mod author about releasing a compatibility patch.

#6
TMPhoenix

TMPhoenix

    Faithful poster

  • Premium Member
  • 1,696 posts
I've uploaded a new version which adds another optional script that should merge the changes by UFO with the changes of this mod.

#7
pauloelektron

pauloelektron

    Fan

  • Members
  • PipPipPip
  • 362 posts
is Dawnguard mandatory ? ...or I can now update this ESM for the future without getting issues for not having Dawnguard installed. (I'm playing 1.7.7 game version) Thanks.

Edited by pauloelektron, 15 September 2012 - 07:40 PM.


#8
TMPhoenix

TMPhoenix

    Faithful poster

  • Premium Member
  • 1,696 posts
Yes Dawnguard is mandatory, and the game will crash at the menu if you do not have it installed with this mod active.

If you want to use a custom race without Dawnguard installed you could use the original mod found here. Please note that the original mod had a bug in the esm file which could issues because of a missing entry for Wood Elves. A fixed version can be found on the Belua Sanguinare mod page under optional files.

This is not a standalone mod. It is intended to be used as a fix for custom races that are already using the RaceCompatibility mod.

Edited by TMPhoenix, 15 September 2012 - 08:00 PM.


#9
narphous

narphous

    Old hand

  • Premium Member
  • 716 posts
If you're looking at compatibility, would you also see if there's anything needed for extensible follower framework? XFT has already released dawnguard compatibility, so it may not be needed.

#10
TMPhoenix

TMPhoenix

    Faithful poster

  • Premium Member
  • 1,696 posts
The extensible follower framework seems to work around the vanilla script files, so it should work fine. In fact, the author of that mod is the same as the author of the original RaceCompatibility mod.

Edited by TMPhoenix, 15 September 2012 - 09:33 PM.





Page loaded in: 1.038 seconds