Jump to content

Photo

Skyrim Persistant CTD


  • Please log in to reply
9 replies to this topic

#1
Aurora555

Aurora555

    Regular

  • Members
  • PipPip
  • 99 posts

Hi guys,

I've been having this very strange issue with my save game recently.
Whenever I'm at Azura's Shrine, I get a CTD right at the small bride after you have climbed the steps, it's a strange issue because I also have a mod that allows me to teleport to locations, and one of these is the Shrine.

Instead of putting me in the usual fast travel spawn point, the teleport spell puts me right under the statue, and while I'm here I get no CTD. Although, as soon as I go over the small bride (back the way you would normally go) and then try and go back like I normally would I get a CTD again.

I noticed this happened in Winterhold as well, but only on certain occasions, so that may be a different issue. Some of the surrounding areas near the Shrine, for instance round the bottom of the mountain that the statue is on, also CTD without fail.

I've disabled all mods (except Skyrim.esm and Update.esm) and deleted (after making a backup of course) the Data folder to make sure Skyrim wasn't trying to reference a corrupt file or what-not.

I also tried going to the Shrine, then waiting for 31 days in hopes that a cell reset of the area would get rid of any corrupt containers or whatever. Again no luck.

After all of that I still get the same result, crashing in the exact same place at the Shrine


I tried enabling the Papyrus logging but the last process to go through before crashing was the following:

Saving game...
[11/18/2012 - 08:02:36PM] VM is thawing...
[11/18/2012 - 08:02:37PM] VM is freezing...
[11/18/2012 - 08:02:37PM] VM is frozen
and then after another crash:

warning: (FF001E77): Ref is in an unloaded cell, so it cannot cast spells..
stack:
;[ (63036750)].SPELL.RemoteCast() - "<native>" Line ?
;[None].nFrostBlastScript.OnEffectStart() - "nFrostBlastScript.psc" Line 21

I've found no common denominator between all of the crashes in the logs, and if I look at all the evidence (all mods deactivated, data folder and loose files deleted etc) the only thing this leaves is the save game.

To answer your next question, yes I tried using a previous gamesave (one from 20 hours before my current one) and it worked, no CTD at all.

My main question is; Do you think theres a rogue or corrupt script in my gamesave causing a CTD every time I enter that specific exterior cell (so specific that it crashes in EXACTLY the same place) and if this is so what can I do to rectify the issue?

I appreciate the complexity of Bethesda gamesaves and that "Start a new game" seems to be the common "fix", but my hope is one smart cookie out there knows  how to pull a script from the save file.

Any help, input or advice would be appreciated, as I'm out of ideas.

/wall-of-text


Edited by Aurora555, 12 February 2013 - 06:55 PM.


#2
korun

korun

    Old hand

  • Members
  • PipPipPip
  • 684 posts
you've found the solution, but the save remain dead even without the mods installed because they are still there like ghost meaning script. the best will be to make a clean save from the last good one you have, any inside cell you can find, a shop, breezhome and save manually, exit,
1/uninstall every mod you think can be the culprit one by one,load , save, check if it's fine, save, exit, reload  OR
2/re install your teleport mod, and check if it's works fine now, if not »»»go to /1 :D  it seems that your mod and the game engine cross each other

edit: i have had a problem at the shrine once with Apocalypse spell, then in dawnstar etc., get the same line in my log about a frost spell, clean save and uninstall solved the problem
@@

Edited by korun, 12 February 2013 - 10:39 PM.


#3
Aurora555

Aurora555

    Regular

  • Members
  • PipPip
  • 99 posts

The last 'good' save I have is 50 hours before my current gamesave. The only reason there is such a large gap is simply because I never noticed any CTDs since I wasn't in the area, unfortunately.

 

With my last good save, I loaded it up with all the mods I use and then saved the game to a new slot. Once I had done that I fast traveled to the Shrine and there was no CTD at all.

 

Really strange.



#4
korun

korun

    Old hand

  • Members
  • PipPipPip
  • 684 posts

The last 'good' save I have is 50 hours before my current gamesave. The only reason there is such a large gap is simply because I never noticed any CTDs since I wasn't in the area, unfortunately.

 

With my last good save, I loaded it up with all the mods I use and then saved the game to a new slot. Once I had done that I fast traveled to the Shrine and there was no CTD at all.

 

Really strange.

well as i said, it seems that your mod and the game engine cross each other, some time you just have to set 1 hr IG later and nothing happen^^

@@



#5
Aurora555

Aurora555

    Regular

  • Members
  • PipPip
  • 99 posts

Began 3 new games (just for the sake of testing) and each one was fine with all my current mods enabled. (So whatever mods I'm using now didn't cause it, but I already had a hunch that was the case)

 

I'm guessing it was a dirty mod I tried out during my time with that gamesave.

 

It's a shame a new game is required in situations like this. Really think a gamesave cleaner is something Skyrim desperately needs.



#6
korun

korun

    Old hand

  • Members
  • PipPipPip
  • 684 posts

Wrye bash get a function to check your save, it's a good way to know if a master is missing or unload,

it will compare your current Load order with the one in the save, then you can reload the master and make it safe, of course it works only if the master still exist in the data file

 

here, Wrye pics from the profile i'm playing

http://i.imgur.com/vW3LjQD.jpg

http://i.imgur.com/bDdBfBE.png?1

http://i.imgur.com/51UmGbR.png

 

It's not a cleaner obviously, but for me,i find this really usefull when you have a crash or weird behaviour.

 

Wrye bash is really a good tool but you have to use it wisely.

 

@@



#7
Aurora555

Aurora555

    Regular

  • Members
  • PipPip
  • 99 posts

The Wyre Bash technique was a great suggestion, one I hadn't tried before.

 

Had a look for missing master files on the save file but no luck, everything is where and as it should be.

 

Pretty much increases my suspicions theres a killer script inside my game save haha

 

Thanks for your help though Korun, really appreciate it! 



#8
korun

korun

    Old hand

  • Members
  • PipPipPip
  • 684 posts

you're welcome ;)



#9
Aurora555

Aurora555

    Regular

  • Members
  • PipPip
  • 99 posts

Sorry to resurrect this thread but just to let you know Korun the issue has been fixed.

 

I have no idea what I did, apart from tweak the grass density in SkyrimPrefs.ini (which shouldn't be an issue)and installing Bigger Trees (which should make CTDs more common if anything) but I don't know how either of those would cause the issue I described.

 

I also walked around the location a lot trying to find the "deadzone" so I could avoid CTD in future, and thats when I noticed the issue was gone.

 

The only other thing I have done is install the new beta 13.2 driver for my AMD graphics card (the update directly affects Skyrim performance) but I remember the CTD still being an issue after I installed that driver.

 

Wish I could remember so I could help anyone else having a similar issue but I have no idea how it fixed!



#10
korun

korun

    Old hand

  • Members
  • PipPipPip
  • 684 posts

all changes you've described are graphic related, grass density can make your system ctd in Hjaalmarch for exemple because every single grass get a shadow, or, there is many dead trees, then, if you try optional trees (optional file which give leaf to the dead trees every where )from Vurt, all the place is cover by lush trees which wasn't there before so for some people...like my girlfriend :D, you have ctd there now , it depend of the ram you have, gpu and vram also..but as far as i know there not so much trees or grass around Azura,s shrine :)

 

well i'm sure it was a engine error at this very "T" moment, because you pop on unusual place, if you can see the shrine in the CK, there will be a marker just near it, it's where your char must spawn after a fast travel, your mod change the marker to another place, but this time it simply doesn't work, with Skyrim you can't be 100% sure on what happen, may be a dragon was around, or something get a bad script and make the game ctd.

 

i'm testing the beta driver too and so far it get better than it was

i'm ugrid 7 with ini's heavily tweaked except for the grass, i keep it high no more,  so far so good

@@






Page loaded in: 0.944 seconds