Jump to content

Photo

Fallout 3 Freeze Startup(Win7 64bit GOTY)


  • Please log in to reply
3 replies to this topic

#1
Rayness115

Rayness115

    Stranger

  • Members
  • Pip
  • 2 posts

Why Fallout 3?!?! Why!? I want to roam Capital Wasteland so badly,but you are not letting me. Why Fallout 3?! Why are you freezing at the damn birth screen? Why are you doing this to me?!

Long story short : Fallout 3 keeps freezing at the birth screen,usually when the baby comes out and you see the white screen with the blood,or sometimes it moves on and freezes like when he asks for your name or when he talks to his wife.One time I managed to make it to the character screen but when I press done it froze again. 

 

I have tried everything! The fallout.ini, the autosave on wait/sleep etc,changing my theme to windows classic,putting some d9d3 or whatever file,reinstalling and restarting and god knows what else! I have a Samsung R540 laptop that has Windows 7 64-bit with Intel core i3 and ATI Mobility Radeon Premium Graphics card!

Exact stuff from DXDIAG

 

 

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130104-1431)
Language: Greek (Regional Setting: Greek)
System Manufacturer: SAMSUNG ELECTRONICS CO., LTD.
System Model: R540/R580/R780/SA41/E452/E852
BIOS: AMIBIOS Version 03KP.M008.20100927.LDG
Processor: Intel® Core™ i3 CPU M 380 @ 2.53GHz (4 CPUs), ~2.5GHz
Memory: 3072MB RAM
Available OS Memory: 2986MB RAM
Page File: 2345MB used, 5139MB available
Windows Dir: C:\windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

 

GRAPHS CARD

 

Card name: ATI Mobility Radeon HD 5470
Manufacturer: ATI Technologies Inc.
Chip type: ATI display adapter (0x68E0)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_68E0&SUBSYS_C07F144D&REV_00
Display Memory: 1741 MB
Dedicated Memory: 504 MB
Shared Memory: 1237 MB
Current Mode: 1366 x 768 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: unknown
Monitor Id: SEC5441
Native Mode: 1366 x 768(p) (60.003Hz)
Output Type: Internal

 

Now,in all honesty,I have absolutely no idea what the hell FFDSHOW is and where I can find it (I heard its in all programs but NOPE! I searched for FFDSHOW but nope!) so I need help for that all well as it could possibly be the problem. When I search in my computer for FFDSHOW (I write it as ffdshow) it doesnt find anything!!

 

Please  help me,I really want to play this game! I seriously want to! And fyi, it's GOTY edition,all mods removed and game reinstalled along with cache cleaned and registry keys cleaned,no mods or DLC and patch 1.7.0.3


Edited by Rayness115, 17 March 2013 - 03:54 PM.


#2
prensa

prensa

    Resident poster

  • Members
  • PipPipPipPipPip
  • 2,900 posts

Rayness115 - Hello!

"I have absolutely no idea what the hell FFDSHOW is"

ffdshow is just a codec package with an adjustable user interface to allow tweaking.

It's used & often installed by many video or audio programs.

Because it's packaged with something else it's often not realised that it's even there.

It can cause trouble with Fallout 3's handling of sound files if it's installed & should be added to it's list of programs not to be used with.

It's most often associated with radio skipping.

"and where I can find it"

It'll show up in your list of programs, go to your Start menu - All programs & locate a folder called:

ffdshow - Audio Decoder Configuration

Make sure Fallout 3 is on the list in DirectShow Control - Don't use ffdshow in.

It's quite possible you don't have it on your system, all depends on what sort of programs you've installed.

Freezing in Fallout 3 is most often due to the Fallout 3 multi core bug.

Fallout 3 has trouble with multi core computers, mainly with ones that have more than two cores & use hyperthreading.

There is a fix, you need to edit your Fallout 3 .ini file.

"I have tried everything! The fallout.ini"

Make sure you've edited the correct .ini & made both changes.

The .ini you want to change is:

For XP:

My Documents\My Games\Fallout3\

For Vista & Win7:

Documents\My Games\Fallout3

The file you want will be called:

FALLOUT.ini

Open the .ini with Notepad & change this line:

bUseThreadedAI=0

to:

bUseThreadedAI=1

& insert this line under it:

iNumHWThreads=2

Save & close your ini.

Another cause of freezing can be sound card settings, if you have a creative card it should be set to Game Mode.

Hope this helps!

Prensa



#3
Rayness115

Rayness115

    Stranger

  • Members
  • Pip
  • 2 posts

Rayness115 - Hello!

"I have absolutely no idea what the hell FFDSHOW is"

ffdshow is just a codec package with an adjustable user interface to allow tweaking.

It's used & often installed by many video or audio programs.

Because it's packaged with something else it's often not realised that it's even there.

It can cause trouble with Fallout 3's handling of sound files if it's installed & should be added to it's list of programs not to be used with.

It's most often associated with radio skipping.

"and where I can find it"

It'll show up in your list of programs, go to your Start menu - All programs & locate a folder called:

ffdshow - Audio Decoder Configuration

Make sure Fallout 3 is on the list in DirectShow Control - Don't use ffdshow in.

It's quite possible you don't have it on your system, all depends on what sort of programs you've installed.

Freezing in Fallout 3 is most often due to the Fallout 3 multi core bug.

Fallout 3 has trouble with multi core computers, mainly with ones that have more than two cores & use hyperthreading.

There is a fix, you need to edit your Fallout 3 .ini file.

"I have tried everything! The fallout.ini"

Make sure you've edited the correct .ini & made both changes.

The .ini you want to change is:

For XP:

My Documents\My Games\Fallout3\

For Vista & Win7:

Documents\My Games\Fallout3

The file you want will be called:

FALLOUT.ini

Open the .ini with Notepad & change this line:

bUseThreadedAI=0

to:

bUseThreadedAI=1

& insert this line under it:

iNumHWThreads=2

Save & close your ini.

Another cause of freezing can be sound card settings, if you have a creative card it should be set to Game Mode.

Hope this helps!

Prensa

 

Hello and thank you for taking the time to look at my troubles!

 

Apparently,I made the changes at the fallout_default.ini! But I just went and did the same to the FALLOUT.ini located in documents but still nothing. This time i managed to see the doctor though  :biggrin: . Thanks for explaining to me what FFDShow is but I cant find such file in my programs. Nor in remove or change programs in Control Panel. Also I didnt quite understand the creative card and the game mode part would you mind explaining that to me please? Thanks!  :biggrin:   EDIT: Here's a photo of my audio manager. Does it have to do with the creative part?

 

 

 

Attached File  Screenshot_2.png   125.42KB   8 downloads


Edited by Rayness115, 17 March 2013 - 04:41 PM.


#4
prensa

prensa

    Resident poster

  • Members
  • PipPipPipPipPip
  • 2,900 posts

Rayness115 - Hello!

"Hello and thank you for taking the time to look at my troubles!"

No problem! :)

"Thanks for explaining to me what FFDShow is but I cant find such file in my programs."

You probably don't have it on your computer, so it shouldn't be a problem. It's normally only the cause of stuttering radio in game anyway.

You could also paste it into the Start menu seach box just to make sure it's not there.

"Also I didnt quite understand the creative card and the game mode part would you mind explaining that to me please? Thanks!"

Looks like your sound is Realtek rather than Creative which is mine.

I know with my Creative card, trying to play Fallout 3 in any mode other than Game Mode will cause trouble & can result in a freeze not long after starting.

I see you have three modes simillar to the options in mine, try setting it to "Game" & see if that lets you play Fallout 3.

It's worth a try & you can easily turn it back if it does not helps.

Prensa






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Page loaded in: 0.923 seconds