Jump to content

Photo

Wrye Bash


  • Please log in to reply
2299 replies to this topic

#1981
Helicoraptor

Helicoraptor

    Stranger

  • Members
  • Pip
  • 2 posts
In response to post #53984903. #53993638, #53996613, #54001498, #54002118, #54005663, #54007203 are all replies on the same post.


Spoiler

I am having the same problem exactly. Win 7 x64, GOG version, fresh install, no mods, yet Wrye Bash closes on startup. Trying to install the python version didn't make any difference. Here are the crash logs:

BashBugDump:
Wrye Bash starting
Using Wrye Bash Version 307.201612302300
OS info: Windows-7-6.1.7601-SP1
Python version: 2.7.8
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: UTF8; output encoding: None; locale: ('en_GB', 'cp1251')
filesystem encoding: mbcs
Searching for game to manage:
bush.py 71 _supportedGames: Detected the following supported games via Windows Registry:
bush.py 73 _supportedGames: oblivion: c:\gog games\oblivion
bush.py 131 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.py 137 _detectGames: Set game mode to oblivion found in parent directory of Mopy: C:\GOG Games\Oblivion
bush.py 172 setGame: No preferred game specified.
bush.py 152 __setGame: Using oblivion game: C:\GOG Games\Oblivion
testing UAC
mods_metadata.py 224 __init__: Using LOOT API version: 0.10.2
__init__.py 3463 __init__: Fatal error constructing 'Mods' panel.
Traceback (most recent call last):
File "Wrye Bash Launcher.pyw", line 88, in <module>
bash.main()
File "bash\bash.py", line 439, in main
File "bash\basher\__init__.py", line 4037, in Init
File "bash\basher\__init__.py", line 3679, in __init__
File "bash\basher\__init__.py", line 3458, in __init__
File "bash\basher\__init__.py", line 1768, in __init__
File "bash\basher\__init__.py", line 268, in __init__
File "bash\basher\__init__.py", line 228, in __init__
File "bash\balt.py", line 1660, in __init__
File "bash\balt.py", line 1773, in PopulateItems
File "bash\balt.py", line 1718, in PopulateItem
File "bash\basher\__init__.py", line 769, in <lambda>
File "bash\bolt.py", line 163, in formatDate
ValueError: (22, 'Invalid argument')

Debug run:
Found Python at 'C:\Python27\pythonw.exe'
Launching Wrye Bash 307 in debug mode
13:07:32: Debug: ..\..\include\wx/msw/private.h(697): 'UnregisterClass' failed with error 0x00000584 (class still has open windows.).


Edited by Helicoraptor, 01 October 2017 - 11:11 AM.


#1982
RavenMind

RavenMind

    Faithful poster

  • Supporter
  • PipPipPipPip
  • 1,175 posts
In response to post #53984903. #53993638, #53996613, #54001498, #54002118, #54005663, #54007203, #54008148 are all replies on the same post.


Spoiler

Okay, I'd like both of you to go into your \Data folder, and see what the Modified Date is on the Bethesda BSAs. (Oblivion - Meshes.bsa, Oblivion - Sounds.bsa, Knights.bsa, etc.) I suspect you'll find them with the date of 1969. If they're anything other than 1/1/2006, I'd like you to follow the instructions below.
Download BulkFileChanger from here. (It's a freeware utility, no installer, trusted publisher.) The download link is toward the bottom of the page.
Open the program and add all your Bethesda BSA's to it. There should be 18 of them if you have all the DLC's. Alphabetically starting with DLCBattlehornCastle.bsa, ending with Oblivion - Voices2.bsa
Take a look at the screenshot at the download site linked above for reference.
Make sure all the BSAs are selected. Only check the boxes in the Modified row, we don't want/need to change Created or Accessed.
Check the box next to Date & change the date to 01/01/2006
Check the box next to time & change it to 12:00:00 AM
Make sure not to check the Add box.
Keep all File Attributes at No Change.
Click "Do it".

Now go back into Windows Explorer & verify that the Modified Date/Time has changed correctly on those BSAs.
Launch the game once via the launcher, then quit.
Try starting Wrye Bash up again.

I don't *think* it's necessary to redate the ESM/ESPs, but if Wrye Bash still errors out, we may have to redate those as well. If that's the case, load up the Oblivion.ESM, and all the Bethesda ESP's (all start with DLC..., except for Knights.esp). Follow the same steps above, except this time put a check in the Add box, and increment them by 1 minute. Launch OB & close, and try launching WB again.

@Helicoraptor: I see you're using an older WB version. Please either update to the one from this page, or if you're adventurous get the latest "WIP" from here. (Actually, I've had zero problems with this version.)
If you used an installer on that 2016 version, you'll need to follow alt3rn1ty's instructions at the top of the page:

If you have previously used an older installer : Follow this routine ..
1.Close Wrye Bash. Run the new Installer.
2.Uncheck ALL tick boxes on the Installation Locations page.. Then click next until the installer finishes.
( We are merely trying to install the fixed Uninstaller )
3.Run the fixed uninstaller at %COMMONPROGRAMFILES(X86)%\Wrye Bash\uninstall.exe ..
( Should be in your Start Menu / All Programs / Wrye Bash / Uninstall )
4.The fixed Uninstaller will now properly complete the uninstallation.
5.Now use the New Installer again to Re-install Wrye Bash.
This is to clear confused Installations of Wrye Bash, old registry entries any previous installers have set, which can confuse subsequent installations. Dont worry about uninstalling Wrye bash during this routine, your settings will still be in place, and mods zips plus installed mods / files will remain as they were.



Won't be able to get on for about 17 hours to reply back. Good luck to you both! :)

Edited by RavenMind, 01 October 2017 - 12:09 PM.


#1983
Helicoraptor

Helicoraptor

    Stranger

  • Members
  • Pip
  • 2 posts
In response to post #53984903. #53993638, #53996613, #54001498, #54002118, #54005663, #54007203, #54008148, #54009393 are all replies on the same post.


Spoiler

It worked! Thanks bunches!

#1984
blueS123

blueS123

    Enthusiast

  • Members
  • PipPip
  • 131 posts
In response to post #53984903. #53993638, #53996613, #54001498, #54002118, #54005663, #54007203, #54008148, #54009393, #54010968 are all replies on the same post.


Spoiler

Thank you very much for all your support, Mr. RavenMind. The problem actually was in Oblivion.esm file that was dated to 1970. Changing the date modified helped.

#1985
RavenMind

RavenMind

    Faithful poster

  • Supporter
  • PipPipPipPip
  • 1,175 posts
In response to post #53984903. #53993638, #53996613, #54001498, #54002118, #54005663, #54007203, #54008148, #54009393, #54010968, #54012123 are all replies on the same post.


Spoiler

Fantastic! Glad you both got it working. blueS123, thanks for the info about it just being the ESM. Should make life easier for others not having to redate all the BSAs!

I believe this issue has been addressed in the latest Wrye Bash builds. The one I use from here hasn't had a problem with GOG's old dates.

Edited by RavenMind, 02 October 2017 - 09:01 AM.


#1986
EvilMV

EvilMV

    Fan

  • Members
  • PipPipPip
  • 320 posts
Hi,

Does anyone knows how to get Wrye Bash working with custom 7zip keys? It seems that it completely ignores s7zExtraCompressionArguments INI setting.
For example, I have s7zExtraCompressionArguments=-mx=7 -m0=LZMA2:d=32m -mmt=7

When compressing a project to archive or for release by Wrye 7z process has the following command line:

"e:\Games\Bethesda Softworks\Oblivion\Mopy\bash\compiled\7z.exe" a "c:\users\xx\appdata\local\temp\WryeBash_temp\bash_temp_nonunicode_name.tmp.tmp" -t"7z" -ms=off -y -r -o"e:\Games\Bethesda Softworks\Oblivion Mods\Bash Installers" -i!"e:\Games\Bethesda Softworks\Oblivion Mods\Bash Installers\220 - Graphics Improvement Project-43496-v5.1\*" [email protected]:\users\xx\appdata\local\temp\WryeBash_InstallerTempList.txt -scsUTF-8 -sccUTF-8

No compression level and multithreading flags. Maybe I am wrong somewhere?
P.S. This is 307.beta1 standalone, Win10 Pro. INI settings are the same in both default and localized INI.

Edited by EvilMV, 08 October 2017 - 01:26 PM.


#1987
RavenMind

RavenMind

    Faithful poster

  • Supporter
  • PipPipPipPip
  • 1,175 posts
In response to post #54223978.


Spoiler

I have no idea. I spent the last 2 hours getting myself up to speed on 7-Zip switches & playing around with different configurations. Even upgraded the bundled v16.4 7z.exe & .dll with v17.01 (which works). I can't get it to take ANYTHING other than -ms, not even the simplest of switches. Are you able to get a Project packed to Archive at all? I can not, and running WB in debug mode produces a "System ERROR: The parameter is incorrect." in BashBugDump_startup.log, and a "Compression failed: 7z.exe return value: 2" error in BashBugDump.log. I'm even on the latest nightly Python build.

 

Edit: I brought this issue up with the team at the official support forum. Here's a link if you'd like to follow.


Edited by RavenMind, 09 October 2017 - 09:46 AM.


#1988
EvilMV

EvilMV

    Fan

  • Members
  • PipPipPip
  • 320 posts
In response to post #54223978. #54250268 is also a reply to the same post.


Spoiler

Yes, I can pack projects for release or to archive, it works. But the only thing that I can get from options is -ms
I also attempted to put .exe and .dll from 64 bit 7Z version and it works in the same way.

I was running WBSA with different options but when getting a process command line from OS I see that options are ignored.

Thank you for putting this issue to relaetd forum thread.

#1989
RavenMind

RavenMind

    Faithful poster

  • Supporter
  • PipPipPipPip
  • 1,175 posts
In response to post #54223978. #54250268, #54262583 are all replies on the same post.


Spoiler

You were able to get the 64b version working? That's great to know! I used the 32b just in-case the 32b WB/Python didn't like it. I think I'll "upgrade" it to x64 now! :D Sorry I don't have anything more constructive for you at the moment. So far there hasn't been a response at AFK. Utumno is really busy trying to get the new Beta ready for release (which should be really good!). Hopefully someone with knowledge of the code can look into this.

#1990
EvilMV

EvilMV

    Fan

  • Members
  • PipPipPip
  • 320 posts
In response to post #53984903. #53993638, #53996613, #54001498, #54002118, #54005663, #54007203, #54008148, #54009393, #54010968, #54012123, #54040518 are all replies on the same post.


Spoiler

WIP version is even better for me. I was unable to run BAIN wizard with 307.beta1 for "Arena Redone HD" mod. No problems with WIP version (201709160706).




Page loaded in: 1.109 seconds