Jump to content

Photo

Plugin incompatible popup


  • Please log in to reply
20 replies to this topic

#1
RoyBatterian

RoyBatterian

    Recovering A-hole

  • Premium Member
  • 10,369 posts

Lemme just post this in here for higher visibility.

 

Can you please make this a bit more robust so that it knows that plugins for the game and creation kits are not meant to load in each other, all it does is confuse users and make them think either their game or construction/creation kit is somehow broken.

 

Incompatible during query is just a message not an error and doesn't need to be shown to the user under any circumstances.

 

Thank you

 



#2
Pickysaurus

Pickysaurus

    Community Manager

  • Admin
  • 15,456 posts

I'm not 100% sure which game/message you're talking about. Could you be more specific? 



#3
ePath

ePath

    Enthusiast

  • Members
  • PipPip
  • 230 posts

Here: https://imgur.com/la1ZhiB
Which opens up: https://imgur.com/Gr4QI0t

 

And no, they're not manually installed, and they work as intended. I just ignored it after much reinstalling and playing around when I first migrated from NMM to Vortex a good while ago.


Edited by ePath, 10 June 2021 - 10:32 PM.


#4
HadToRegister

HadToRegister

    Awake at stupid o'clock

  • Premium Member
  • 18,842 posts

Nobody has mentioned WHICH GAME(s) yet.



#5
1ae0bfb8

1ae0bfb8

    Resident poster

  • Supporter
  • PipPipPipPipPip
  • 3,886 posts

i'm going to guess Fallout New Vegas?

 

what do i win?



#6
HadToRegister

HadToRegister

    Awake at stupid o'clock

  • Premium Member
  • 18,842 posts

i'm going to guess Fallout New Vegas?

 

what do i win?

 

 

Ah, just looked closer at the 2nd screenshot



#7
Pickysaurus

Pickysaurus

    Community Manager

  • Admin
  • 15,456 posts

Thanks for clarifying. I would raise the challenge to the xNVSE team to say why are they logging these events as errors if they aren't actually errors? 

 

Vortex literally reads the NVSE log file and reports any errors to you. (As it does with SKSE/F4SE/OBSE/FOSE too) 



#8
llde

llde

    Old hand

  • Members
  • PipPipPip
  • 900 posts

Actually after more investigation it seems that there are 2 things that are happening:

1) xSE mark as incompatible during query plugins that should be opened only in the game or the editor. It's not an error (and in fact the term error isn't present in the log in this case)

2) Something similar to the bug described here: https://github.com/N...tex/issues/9234, the logs are mixed and it get somehow confused.

 

Reading the code (cursed node.js) it appears to also affect OBSE too (this is Oblivion users were actually using Vortex, as it has the tendency to break installation of some Oblivion mods).

NVSE or xNVSE aren't doing anything different then OBSE or other extenders


Edited by llde, 11 June 2021 - 03:16 PM.


#9
hlp

hlp

    Fan

  • Premium Member
  • 457 posts
Those are warnings and not errors. Distributing plugins for different edition of a game and/or for different versions of a game in a single distribution is valid. This apply to all xSE extenders.

#10
ePath

ePath

    Enthusiast

  • Members
  • PipPip
  • 230 posts

Those are warnings and not errors. Distributing plugins for different edition of a game and/or for different versions of a game in a single distribution is valid. This apply to all xSE extenders.

Regardless, the user doesn't need nor use this information, wether they are warnings or errors it's irrelevant for us.
It's just confusing and annoying. I myself reinstalled Enhanced Camera several times the first time I used Vortex until I noticed it was working and just ignored it. It is that kind of problem that is still found among new users that drove OP to write this post and what we are trying to say.






IPB skins by Skinbox
Page loaded in: 1.118 seconds