Jump to content

Photo

Textures problem !?

textures

  • Please log in to reply
2 replies to this topic

#1
ZorquanX

ZorquanX

    Newbie

  • Members
  • Pip
  • 17 posts

Been trying to start my own mod since I don't seem to find what I want anywhere and got up to that point where I put an armor part in-game and it doesn't show right in CK or on my character.

 

Everything seems fine in 3dsMax and in NifSkope put all the textures are blackened in CreatonKit and In-Game

 

Attached File  ScreenShot2.jpg   84.19KB   0 downloads

 

Tried to add textures via TextureSets = doing the same.

 

The game behave normally otherwise and as far as the meshes goes everything is fine.

I searched around and didn't found much, maybe in the nif file something needs to be activated but I don't know where to look if someone can point me out I'd like this resolve before I go any further in making this mod please (so I don't have to redo too much stuff).

 

----====----

3ds Max 2009 64-bit

NifSkope 1.1.3 (revision 36ebfdd)

Game + CK up to date

--------------



#2
Tamira

Tamira

    Faithful poster

  • Supporter
  • PipPipPipPip
  • 1,488 posts

What you may try:

 

1. Right click on the mesh in nifskope and --> mesh->face normals

 

2. Check vertex colors settings: If your mesh has vertex colors, the shader flag "SLSF2_Vertex_Colors" in "SkyrimShaderPropertyFlags2 " of "BSLightingShaderProperty" has to be activated and  in NiTriShapeData block "Has Vertex Colors" has to be set to "yes". If it set to "no", the mesh will be dark because engine substitutes missing vertex colors as full black vertex colors. If there are no vertex colors in your NiTriShapeData, change “has vertex Colors” to no and remove the shader flag "SLSF2_Vertex_Colors" in "SkyrimShaderPropertyFlags2”



#3
ZorquanX

ZorquanX

    Newbie

  • Members
  • Pip
  • 17 posts

Tried both...

 

Still black !  :confused:







Also tagged with one or more of these keywords: textures

Page loaded in: 1.026 seconds