Jump to content

Photo

Yet another Invisible Interior Structures Issue.

interior glitch modded invisible wall ceiling floor

  • Please log in to reply
25 replies to this topic

#11
aurreth

aurreth

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,006 posts

Well I'm embarassed.  I just realized I have overlapping Mechanist Lair mods.  I'm gonna disable a couple, do a reinstall on ML Overhaul to make sure I haven't borked up the precombines, and go have another look.

 

Edit:  Ok, nope, wasn't just me, the precombines are bad.  I'm gonna try pulling them out of the BA2, see if maybe they got packed up wrong or something.

 

Edit2:  And that didn't work, they'll need to be regenerated.


Edited by aurreth, 21 August 2021 - 07:11 PM.


#12
xrayy

xrayy

    https://www.opensocietyfoundations.org/

  • Premium Member
  • 8,212 posts

read my frame drops guide and the danger of scrap mods for performance and stability. 

1. you can not mod this game endlessly without flaws.

2. you should know about the shortcomings of scrapmods who let you scrap static objects included in previs/precombines. one wrong click and your game looks like is naked or slows down severely.

3. also some mods are responsible for such problems and raise "a loss of walls" problem! i had this problem with an institute mod.

4. try to remebmer the 1st time you saw this and what mods are new since then. this way i always was able to narrow down a problem like this.

5. load an older save and check if you have the same problem in the same area so you can exclude that it is scrap related.



#13
aurreth

aurreth

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,006 posts

<a bunch of stuff that doesn't apply>

 

Thank you for trying to be helpful, but please read the entire thread, not just the title.  The third post clearly says that the OP does not use a scrapping mod.  The "scrap" mods listed in his load order just add and/or adjust recipes, and that will not break precombines or cause this issue.

 

If you are talking about my side comments on the Mechanist's Lair, yes, I'm aware of all of this, but the problem with the Lair is working precombines don't even exist in the vanilla game.  This is because there is a huge amount of junk, trash, walls, etc. under the floor and behind the walls that the player will never see, but nevertheless gets included when precombines are generated.  The entire cell is incredibly dirty, it was released that way, but cleaning it up is difficult because some of that hidden cruft is linked to the visible areas so you don't know what is necessary and what isn't.  That means that ANY mod for that cell will encounter problems, especially if it extends the buildable area.  The junk makes a working set of precombines and previsibility impossible.


Edited by aurreth, 22 August 2021 - 12:35 PM.


#14
TehPuggishOne

TehPuggishOne

    Enthusiast

  • Premium Member
  • 192 posts

Th

 

You don't have to remove ML Overhaul, just understand that for some reason it's impossible to get a working set of precombines for the Lair in general, so you are going to have issues.  They seem primarily restricted to areas outside the vanilla build boundaries.  Main room?  Fine.  Area where the Mechanist sleeps and the robot workbench room there?  Tearing.  Flashing textures in a lot of other areas.  If you restrict yourself to mostly the main room you won't have problems.  Well, other than the floors are all missing the WorkshopStackableItem keyword so it is hard to place stuff on it without laying down your own floor.

 

I think I'll go check for the offending room boundaries, see if that is the issue.  Those are what cause Vault 95 to glitch out, even without mods.

 

If it happens in the Museum and Corvega you're right, something is breaking them.... InteriorsEnhanced-All-In-One.esp looks like a good candidate.

Well, the main issue is that I've uninstall all of my lighting and fog mods to see if that would fix the issue, but it didn't. That includes Interiors Enhanced. So, it's another mod causing the issue. I forgot to mention that I also have the Construction PA standalone mod, which adds the construction PA to Corvega Assembly Plant, though I've also uninstalled that mod and it didn't fix anything. I do also have CRP which apparently changes some of the interior cells that have visibility to the outside world for the skyboxes and skylighting. I could try removing that as well and see if that also fixes anything.



#15
TehPuggishOne

TehPuggishOne

    Enthusiast

  • Premium Member
  • 192 posts

read my frame drops guide and the danger of scrap mods for performance and stability. 

1. you can not mod this game endlessly without flaws.

2. you should know about the shortcomings of scrapmods who let you scrap static objects included in previs/precombines. one wrong click and your game looks like is naked or slows down severely.

3. also some mods are responsible for such problems and raise "a loss of walls" problem! i had this problem with an institute mod.

4. try to remebmer the 1st time you saw this and what mods are new since then. this way i always was able to narrow down a problem like this.

5. load an older save and check if you have the same problem in the same area so you can exclude that it is scrap related.

I appreciate the help, but everything you've said so far isn't anything new. I've no scrapping mods installed right now, and immersive scrapping does not do what you think it does. I've had scrapping mods installed before, specifically Scrap Everything, but I made sure to revert the changes it made to my ini files after uninstalling it. The issues in question did not start happening until I installed an assortment of lighting mods in place of ELFX since the mod dev of CRP specifically stated that ELFX conflicts heavily with CRP due to its broken precombines trying to overwrite the newly generated precombines that CRP has. That also being said, the mod dev of CRP said that most other lighting mods should be fine to use for interior cells as long as they don't change any precombines for exterior cells.



#16
TehPuggishOne

TehPuggishOne

    Enthusiast

  • Premium Member
  • 192 posts

So, removing CRP sadly did not help with the issue either. I'm honestly at a loss here. I've no idea what could be causing the precombines/previs stuff to disappear inside interior cells. 



#17
TehPuggishOne

TehPuggishOne

    Enthusiast

  • Premium Member
  • 192 posts

OKAY, progress has been some-what made. I took another look at my ini settings and found out that bUsePreculled was set to 0, which I hadn't noticed before for some reason. Upon setting it to back to 1, stuff started to pop in and out both inside interior cells and outside in the world cells. Still no idea what could be causing this issue, but at least I've ironed out one error that was on my part. Removing CRP at least stops meshes from disappearing and reappearing in the commonwealth, but I still don't know what's causing it to happen inside interior cells. If removing CRP caused it to stop, then that means there could be a mod conflicting with CRP. I might be able to find out what mod is doing that through XEdit.



#18
DiodeLadder

DiodeLadder

    Old hand

  • Supporter
  • PipPipPip
  • 524 posts

Do you have anything in the "Vis" folder inside of Fallout 4 / Data?  If your "Vis" folder has something in it, try to move everything out temporarily, just to see if your problem goes away.  (The content in Vis folder is "Visibility" data.  You might have some leftover data from removing a mod - removing a .esp only won't fix this problem.)

 

Your problem reminds me of what happened when I generated visibility without knowing what it actually does (lol).



#19
aurreth

aurreth

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,006 posts

Do you have anything in the "Vis" folder inside of Fallout 4 / Data?  If your "Vis" folder has something in it, try to move everything out temporarily, just to see if your problem goes away.  (The content in Vis folder is "Visibility" data.  You might have some leftover data from removing a mod - removing a .esp only won't fix this problem.)

 

Your problem reminds me of what happened when I generated visibility without knowing what it actually does (lol).

 

Might also want to at least temporarily remove Data/meshes/Precombined.  That, along with Vis, is all the mod or locally added precombine/previsibility data.

 

As for bUsePreculled, that determines whether or not the game respects preculling, i.e. the combination of precombine and previsibility.  It is usually set to zero by scrapping mods to allow you to scrap things you otherwise wouldn't be able to because they potentially break precombines.  So (yeah, longshot here) if you could figure out which of your mods changed that setting in your INI file you'd know which one was causing the problem.

 

Ah, another thing to look for.  Some mods, for reasons I can't understand, clone your INI files and create their own version in your Data directory.  Start Me Up does, Scrap Everything, a few more.  Problem is those clones are full of settings they have no business touching.  Like the path to your saved games, which screws up Vortex profiles badly.

 

You might still have bUsePreculled buried in one of them.  Take a look, and remove the line if you find it.  Don't set it to 1, remove it.



#20
TehPuggishOne

TehPuggishOne

    Enthusiast

  • Premium Member
  • 192 posts

So, I looked for any copied .ini files in my data folder, with none to be found. That being said, temporarily getting rid of the contents inside the vis and precombine folders seems to have fixed the issue. My only question is, what's the catch to having removed those files? I'll keep them saved for the time being until I know for a fact that I can safely delete them.







Also tagged with one or more of these keywords: interior, glitch, modded, invisible, wall, ceiling, floor

IPB skins by Skinbox
Page loaded in: 1.096 seconds