Jump to content

Photo

Import/Export Skyrim LE & SE meshes directly from Blender

blender

  • Please log in to reply
5 replies to this topic

#1
BadPup

BadPup

    Old hand

  • Premium Member
  • 536 posts

I've just finished V1 of a Blender Import/Export tool that supports Skyrim LE & SE and Fallout 4. Yes, you can import from SE and export to LE and it just works.

 

https://github.com/B...yNifly/releases

 

Features
  • Supports FO4, Skyrim LE, Skyrim SE. Import from one game and export to another with minimal twiddling (bone weights, partitions, shape keys).
  • Handles tris and base mesh in one step. No need to separate UV seams or triangulate before exporting
  • Handles expression and chargen tri files for Skyrim and FO4
  • Import tris into an existing mesh or on their own
  • Supports Bodyslide tri files on import and export for body morphs
  • Handles multiple bodyweights in one step. Export _0 and _1 armor weights for Skyrim from a single mesh.
  • Handles Skyrim and FO4 partitions and also FO4 segments
  • Handles skinned and unskinned meshes correctly. Exports head parts to SE correctly.
  • Handles shaders correctly. Set them up in Blender and export.
  • Import-and-forget. What you import will behave correctly on export without fiddling.
  •  


#2
LaurellaBellaBean

LaurellaBellaBean

    Fan

  • Members
  • PipPipPip
  • 477 posts

This might be exactly what I'm looking for! I have some armor meshes that I'd like to edit in Blender (just tiny edits--no changes to the UV mapping or weighting or anything), but I have no knowledge about getting the mesh into Blender and then out of Blender, then getting the mesh into the game. I came to the forum specifically to find out how to do what I mentioned above.



#3
Dragoon23

Dragoon23

    Regular

  • Premium Member
  • 87 posts

Thanks a lot for this. It's working well and makes more complicated edits easier to do.



#4
zwvskyrim

zwvskyrim

    Journeyman

  • Members
  • Pip
  • 29 posts

Nice,

 

blender 2.93.4(LTS)

Gave it a quick test.

Worked very good.

 

Thanks for the tool

 

 



#5
urbon

urbon

    beggar

  • Members
  • PipPipPipPipPip
  • 5,467 posts

DUDE THANK YOUUUUUUUUUUUU.  I didn't have luck with the other tool. Thanks for share it!



#6
LaurellaBellaBean

LaurellaBellaBean

    Fan

  • Members
  • PipPipPip
  • 477 posts

Ugh. Decided to try this out. I use Blender 2.78 and I'm getting a Traceback (more recent call last) error. It says SyntaxError: Invalid Syntax. 

 

"C:\Program Files\Blender Foundation\Blender\2.78\Scripts\Modules\addon_utils.py" , line 330, in enable mod = __import__(module name)

"C:\Users\my name\AppData\Roaming\Blender Foundation\Blender\2.78\Scripts\addons\io_scene_nifly\__init__.py", line 36 log.info(f"Loading pynifly version {bl_info['version'][0]}.{bl_info['version'][2]}")

 

Oh, God, that was agonizing to type out and hopefully I didn't make a mistake. I know nothing about python or dealing with the console or how to copy error messages. Please forgive my noobishness. Would love some help. 


Edited by LaurellaBellaBean, 03 June 2022 - 05:52 AM.






Also tagged with one or more of these keywords: blender

IPB skins by Skinbox
Page loaded in: 1.021 seconds