Jump to content

Photo

Lighting Control Issues

lighting brightness contrast fellout project reality windowed mode gamma

  • Please log in to reply
4 replies to this topic

#1
DZMaven

DZMaven

    Regular

  • Members
  • PipPip
  • 72 posts

Okay, so it appears I've run afoul of some odd bug with regards to losing control of the game's brightness settings. I usually play in windowed mode, 720p, however for some reason in that mode I cannot control the in-game brightness. The brightness slider does nothing in the game settings. I checked it in fullscreen and the slider works, however I don't want to play it in fullscreen as I use windowed 720p for recording and to monitor audacity while I play.

 

I'm currently using fellout and this is currently how things look: http://s10.photobuck...lout01.png.html

I don't think it's supposed to look THAT dark near the middle of the day. 

 

I've tried my game out with Project Reality instead and this is how the same scene looks: http://s10.photobuck...PRShot.png.html

A little better, but not by much. I'd rather not use PR due to blown lighting issues such as this: http://s10.photobuck...ting01.png.html

 

For comparision, this is how the game looks with neither fellout nor PR: http://s10.photobuck...illa01.png.html

 

Even in vanilla, I still have no control over the brightness so I'm rather certain the issue isn't related to Fellout or PR. I've tried adjusting it in fullscreen and going back to windowed, but that doesn't work.

I tried tweaking gamma setting in the ini file as well that did naught. Something about windowed mode is forcing the game to a certain gamma setting.

 

My gpu is a MSI Twin Frozer II HD6870 is that helps. I've tried using the ATI control center for the graphics card, but it has no settings to control or override gamma/brightness for games that I can find. 

 

Does anyone have any ideas how to correct this issue?



#2
prensa

prensa

    Resident poster

  • Supporter
  • PipPipPipPipPip
  • 3,807 posts

DZMaven - Hello!

 

Funnily enough I just read something about this the other day that might help.

 

An issue with Gamma not working in windowed mode is mentioned on the Description page of Fake Fullscreen Mode Windowed - Alt Tab Fix by BUDA20 here:

 

http://fallout3.nexu...om/mods/16001/?

 

" Brightness, Contrast and Gamma Correction
In game Gamma does not work in this mode, there is a perfect tool for that.
Fix using Gamma Panel: download link -> http://majorgeeks.co...anel_d2796.html "

 

I see that the newer version of Fake Fullscreen also contains the ability to alter Gamma etc & may help you, it's here:

 

http://fallout3.nexu...om/mods/16478/?

 

Hope this helps!

 

Prensa


Edited by prensa, 23 July 2013 - 08:44 PM.


#3
DZMaven

DZMaven

    Regular

  • Members
  • PipPip
  • 72 posts

Thanks for the suggestions Prensa. 

 

I tried out the gamma panel and that might definitely help. 

I'm also using Xepha's dynamic weather mod which seems to be a better balance between fellout and Project reality.

 

Update: After some further testing, it appears that gamma panel doesn't actually restore brightness control to the game, but overrides windows/monitor settings to brighten/darken things. Unfortunately this means screenshots and recorded video will still be too dark or bright after I return things to normal and require post-processing adjustment.

 

I tried game companion out, but can't get it to work. Supposedly all I have to do is add fose_loader.exe to it's list of programs to work with and I did so, but it still does nothing for fallout 3.  :confused:


Edited by DZMaven, 25 July 2013 - 03:38 AM.


#4
prensa

prensa

    Resident poster

  • Supporter
  • PipPipPipPipPip
  • 3,807 posts

DZMaven - Hello!

"Update: After some further testing, it appears that gamma panel doesn't actually restore brightness control to the game"

No joy then, shame, strike one. :)

"I tried game companion out, but can't get it to work. Supposedly all I have to do is add fose_loader.exe to it's list of programs to work with and I did so, but it still does nothing for fallout 3. "

I'd never used the newer GameCompanion, I still use the Fake Fullscreen version.

I've chaecked out GameCompanion & it works a little differently.

If you use FOSE in your Desktop icon to launch Fallout 3 you need to add:

fose_loader.exe

To the GameCompanion.ini file under the:

[AutoFFMode]

Once you've done that all you need to do is have GameCompanion running, double click on it's .exe & it will show up in the Taskbar Icons.

After that you start Fallout 3 normally through your Desktop shortcut.

GameCompanion must be running first for anything to happen.

You must also have Fallout 3 set to Windowed mode obviously. :)

You'll know it's working because an FF Mode comes up & the game switches from windowed to fullscreen.

Clicking on the GameCompanion icon in the Taskbar Tray will show a help menu listing the keys that can alter settings like Gamma.

Not sure if the Gamma setting here will be of any more help to you than the other program but it's woth a shot. :)

Prensa



#5
DZMaven

DZMaven

    Regular

  • Members
  • PipPip
  • 72 posts

I figured out the game companion. Fallout 3 has to start before you start game companion. The little I read on it told me opposite so that's where I got confused. 

 

But anyway, in regards to gamma control it does much the same thing as gamma panel. It justs uses pre-defined pre-sets instead of fine adjustments like gamma panel. 

 

It'll make the game a bit more bearable visually if I'm just playing, but it's a still an issue if i decide to record or do photos. I'm thinking I may just have to get creative in a doing a work around for that. 

 

Thanks for the help again. 







Also tagged with one or more of these keywords: lighting, brightness, contrast, fellout, project reality, windowed mode, gamma

IPB skins by Skinbox
Page loaded in: 1.024 seconds