Jump to content

Photo

Horrible FPS at the beginning (prison cell)


  • Please log in to reply
12 replies to this topic

#1
Tintinos

Tintinos

    Newbie

  • Members
  • Pip
  • 10 posts

Hello,

 

Well, new to the forum but not new to the Elder Scrolls series. I have played both Morrowind and Skyrim a lot and it was time to play Oblivion again (haven't played since the game was released).

 

Anyway, I hope you guys can help me solve my little issue. So here it is: 

 

I just installed the game (steam version) so it's fresh, no mods, no anything, I want to play the Vanilla version. 

 

When entering the game, I configure the video settings (I left it as default and only change the resolution to 1920x1080). So far so good. Then I click new game

 

First problem: 

 

- No music or voice over on the video (the one that tells you the little story before you create your character)

 

Second problem:

 

- Right off when I see the character creation, the FPS is at like 5 fps so I cannot do anything as it's unplayable. 

 

 

I have a gaming laptop and I usually play Skyrim on high setting with mods without problems. (I also play Dark Souls 3, Alien Isolation and no problems)

My windows is up to date and so my other programs (wi-fi, sounds, graphic etc...)

Also, I check NVIDEA SETTINGS and the game use my gpu.


So guys, is there anything I can do without relying on mods to fix the game? Your input will be help and if you need anything, I'll try to answer. :) 

 

Cheers!

 

 



#2
HeyYou

HeyYou

    Resident poster

  • Supporter
  • PipPipPipPipPip
  • 12,263 posts

Usually, the terrible FPS came when you LEFT the dungeon after the emperor was assassinated.... Is there a "renderer.txt" file in your My Games\Oblivion folder? Might check that, and see what video solution the game thinks it is using. Sure sounds like it's trying to use the integrated graphics.

 

Might also pull up Task Manager, and see what things look like....



#3
Tintinos

Tintinos

    Newbie

  • Members
  • Pip
  • 10 posts

Hi HeyYou.

 

Yeah, like you said, it seems the game is forcing to use my integrade graphics and not my gpu. Is there a way to force a game to use my gpu beside the nvidea panel? 

 

Here is a copy paste of my renderer.txt (not a amazing gpu but still good for the game):
 

Renderer Device Information:
NVIDIA GeForce GTX 1050 Ti
nvldumd.dll
RenderPath          : BSSM_SV_2_A
PSversion          : 300
VSversion          : 300
VStarget            : vs_2_0
PStarget            : ps_2_a
PS2xtarget          : ps_2_a
maxPS20inst        : 512
3.0 Shaders        : yes
Image space effects : yes
Nonpowerof2textures : yes
FP16ARGB blending  : yes
FP16ARGB filtering : yes
High dynamic range : no
Bloom lighting      : yes
Refraction          : yes
2.0 hair            : yes
SLI mode            : no
Water shader        : yes
Water reflections  : no
Water displacement : no
Water high res      : no
Multisample Type    : 2
Shader Package      : 4


#4
HeyYou

HeyYou

    Resident poster

  • Supporter
  • PipPipPipPipPip
  • 12,263 posts

There likely is a way to force it, but, for the life of me, I can't remember how... :) It's been quite some time since I played Oblivion. Could try disabling the integrated graphics in BIOS, and see if that doesn't improve game performance. (to verify the problem IS which vid solution it is trying to use.)

 

The 1050Ti should run the game great. :D



#5
Tintinos

Tintinos

    Newbie

  • Members
  • Pip
  • 10 posts

I found a way to force it but still the same issue, like 5 FPs in the character creation :/ 

 

I heard disable the music in the .ini file work for some, it's just I don't want to play the game without the music haha.



#6
HeyYou

HeyYou

    Resident poster

  • Supporter
  • PipPipPipPipPip
  • 12,263 posts

Fire up task manager, and see what's going on, that the game struggles so much. The newer hardware should be able to run oblivion with no issues at all....



#7
Tintinos

Tintinos

    Newbie

  • Members
  • Pip
  • 10 posts

I know, that's why I'm surprise I can't run Oblivion and I wanna play the game so bad. 

 

I checked task manager and it seems fine.

 

CPU - 15%

GPU - 15%

GPU engine - 1

Power usage - very high

Power usage trend - very low


Edited by Tintinos, 03 January 2022 - 03:18 PM.


#8
HeyYou

HeyYou

    Resident poster

  • Supporter
  • PipPipPipPipPip
  • 12,263 posts

Wow, that's just bizarre.... Are you plugged in to A/C power? If running on battery, maybe check to see if it is set to 'best battery life', rather than 'best performance'.

 

Could try adding an exception to your antivirus for Oblivion?

 

Run it in compatibility mode for Win 7?



#9
Tintinos

Tintinos

    Newbie

  • Members
  • Pip
  • 10 posts

So I tried: 

- A/C power set to best battery life

- Exception to my antivirus

- Compatibility mode for Win7

 

None works :sad: I don't know what else to try.

 

Even if I put the resolution to the lowest, It's still lag in the character creation, % FPs for everything, even the mouse. 


Edited by Tintinos, 03 January 2022 - 05:43 PM.


#10
RomanR

RomanR

    Enthusiast

  • Members
  • PipPip
  • 134 posts

Perhaps it's a sound problem? Even integrated graphics shouldn't have any problem with Oblivion today. I would try to disable sound HW acceleration - in Oblivion.ini -> section [Audio] -> bDSoundHWAcceleration or bUseSoftwareAudio3D. Because it's strange that you aren't hearing sound or music in intro (OblivionIntro.bik file), maybe it could be some codec or binkw32.dll problem? 

 

Edit: I remember that NVIDIA is sometimes using something which was called NVIDIA Optimus to select which card will be used for particular program.


Edited by RomanR, 03 January 2022 - 07:39 PM.





IPB skins by Skinbox
Page loaded in: 0.932 seconds