Jump to content

Photo

Weird tanline/seams on 3BA

seam; cbbe; 3ba textures; mesh;

  • Please log in to reply
10 replies to this topic

#1
RiqCrow

RiqCrow

    Fan

  • Members
  • PipPipPip
  • 484 posts

Google did not help, so asking here.
 
Got weird issue when having vanilla race and custom race, both having weird seam (like tanlines from swimsuit) on their buttocks. It shows both in Bodyslide and in-game. On vanilla races and custom. When testing, it is invisible in direct light but shows clearly when any shadow (seems light and shadows act differently on those seams, and that area is slightly different coloured than other bodyparts).

 

https://imgur.com/a/FqHcXDc

 
Using 3BA body, and vanilla race Diamond textures CBBE, custom race uses its own textures.

 

Have tried to figure out what affects both vanilla and custom races both. Is this physics mod issue (CBPC / HDT-SMP) or something in mesh underlayers (confused with BSA/UV), but it can't just be conflicting textures as both are on their separate folders and Vortex should not mix those (at least did not earlier).

 

Have tried to Vortex-reinstall almost all mods i can think related to this (3BA, Diamond textures, Racemenu, CPCB, HDT-SMP etc) but issue sticks.

 



#2
RiqCrow

RiqCrow

    Fan

  • Members
  • PipPipPip
  • 484 posts

bumb ;__;



#3
anjenthedog

anjenthedog

    Resident poster

  • Premium Member
  • 2,789 posts

Have you tried using another texture (pure, mature skin, etc) , and if so, does it also display these odd lines?



#4
RiqCrow

RiqCrow

    Fan

  • Members
  • PipPipPip
  • 484 posts

I have issue on both vanilla race and custom race, both using different skin textures in different folders (tested and both have different textures). Atm only common thing is bodyslide mesh (femalebody.nif) but still confused why issue stays there when I use provided ready body-mesh provided by custom race zip... Read something that this could related to skin weight but i don't know how to fix them. To my knowledge this started when mixed texture (femalebody_msn.dds) to wrong folder (which used Diamond skin textures) and this seam appeared after that, but changing/replacing textures now is not fixing the issue. I even reinstalled Bodyslide and 3BA but I dont know if Vortex keeps some files there on background that keeps the issue (it keeps asking that X files are changed and do I want to save change or revert, and never understood fully where it changes them).

 

I mixed up new textures (shitty on purpose) to showcase that problem stays even if replacing all textures, and seam shows clearer

https://imgur.com/a/evnkGwm

 

Dunno if this is caused by mesh (femalebody.tri?), UV or BSA or some sort of weight issue. There is no clipping per se, meaning there are no gaps, but this seam is different coloured and rly visible in any kind of shade. Would like to know what causes this and possibly fix, but can't get my head around what exactly caused and why it stays there.


Edited by RiqCrow, 09 January 2022 - 11:01 AM.


#5
anjenthedog

anjenthedog

    Resident poster

  • Premium Member
  • 2,789 posts

Maybe it's your tan line mod? Could be something wrong with the textures or its reference body

 

PS> thanks for the reminder,. Been meaning to get rid of mine, since I don't use it (for me, the problem is that everything NOT tanned is as white as printer paper, and I don't know jack about futzing with skin tone paint layers in racemenu)



#6
RiqCrow

RiqCrow

    Fan

  • Members
  • PipPipPip
  • 484 posts

I don't have any tan line texture-mod, just Diamond Textures CBBE and use 3BA-body. Textures/mesh were clean before something happened. Now the seam is always there, no matter what textures I use. Just noticed that the discoloured area is quite under breasts too. Just telling that if no clean texture reinstall/install doesn't help, would it not suggest issue being on mesh/skin weights, somehow..?



#7
anjenthedog

anjenthedog

    Resident poster

  • Premium Member
  • 2,789 posts

have you tried rebuilding the body? And make sure you're using the same Bodyslide preset type as your Bodyslide body type (and of course, making sure to check the build morphs checkbox for tri file generation) . You're also running the right diamond skin for your body type, right?



#8
RiqCrow

RiqCrow

    Fan

  • Members
  • PipPipPip
  • 484 posts

Appreciate you trying to help, i really do. Rebuilding the body was first things I tried with texture-reinstall. I use CBB version of Diamond skin textures for vanilla races and make body to "CBBE 3BA Body Amazing" as per usual. Seam is there. Same for custom race (even though it uses different textures). Don't think I have ever selected "build morphs" when creating body in Bodyslide, but remaking body.nif and tri made no difference, seam keeps being there.



#9
anjenthedog

anjenthedog

    Resident poster

  • Premium Member
  • 2,789 posts

Well, I'm stumped.

 

As far as "Build morphs" goes, checking the box instructs Bodyslide to generate ".tri" files upon pressing "Build". Tri files are afaik necessary for in-game use of racemenu.



#10
RiqCrow

RiqCrow

    Fan

  • Members
  • PipPipPip
  • 484 posts

well further investigation shows bug being in Diamond Skin CBBE-textures mod after all, seems Vortex did not clean up thoroughly. Completely removed the texture mod and there is no seam on vanilla mesh/textures, and custom race with its own textures is fine. Installing any version of the Diamond Skin-textures again makes seam appear again on vanilla and custom race which is pretty f***ed up.







Also tagged with one or more of these keywords: seam;, cbbe;, 3ba, textures;, mesh;

IPB skins by Skinbox
Page loaded in: 1.010 seconds