Jump to content

Photo

Download button not working


  • Please log in to reply
7 replies to this topic

#1
810230919

810230919

    Stranger

  • Members
  • Pip
  • 8 posts

I have the same issue here and now. It happened about 3 days ago.

 

The repro step is :

You click the "Manually Download" on any file of any mod for any game on nexus.com.

Click on the "Slow Download" in the following up page. Then nothing happens.

 

If everything goes well, another page should pop up, with a 5s countdown, after it's over, the download will start. But these are all gone and never happen.

 

 

 

I'm using Edge and tried chrome, and I also tried on mobile phone, with WIFI or not, tried the troubleshooting article, this issue still happens. 

 

 

And this issue comes with another two issue:

 

One:

You will notice the total downloads and unique downloads number on the file page of any mod never show up, and just displays as "-" for default, just like it failed to fetch any data from server. No matter how long you wait.

 

 

Two:

Try to use the advanced filter in the mod menu of website, search for anything. It will work for the first time, and give the correct result. But if you change any config such as keywords of file name, and click "Apply Filter", it won't give any feedback and nothing happens, just like you click on the "Slow Download" above.

 

Here is the info I can share. Hope anyone could find the root and resolve it. I will keep trying, and if I find how to resolve it, I will post it.


Edited by 810230919, 11 January 2022 - 03:45 PM.


#2
Dark0ne

Dark0ne

    Webmaster

  • Admin
  • 21,405 posts

I have the same issue here and now. It happened about 3 days ago.

 

The repro step is :

You click the "Manually Download" on any file of any mod for any game on nexus.com.

Click on the "Slow Download" in the following up page. Then nothing happens.

 

If everything goes well, another page should pop up, with a 5s countdown, after it's over, the download will start. But these are all gone and never happen.

 

 

 

I'm using Edge and tried chrome, and I also tried on mobile phone, with WIFI or not, tried the troubleshooting article, this issue still happens. 

 

 

And this issue comes with another two issue:

 

One:

You will notice the total downloads and unique downloads number on the file page of any mod never show up, and just displays as "-" for default, just like it failed to fetch any data from server. No matter how long you wait.

 

 

Two:

Try to use the advanced filter in the mod menu of website, search for anything. It will work for the first time, and give the correct result. But if you change any config such as keywords of file name, and click "Apply Filter", it won't give any feedback and nothing happens, just like you click on the "Slow Download" above.

 

Here is the info I can share. Hope anyone could find the root and resolve it. I will keep trying, and if I find how to resolve it, I will post it.

 

The issues you're mentioning are indicative of javascript not working in your browser. Ensure you do not have anything blocking our javascript from working ("internet security suites", browser plugins, browser settings, etc.) else the site will not function properly.



#3
Pickysaurus

Pickysaurus

    Community Manager

  • Admin
  • 17,991 posts

Split this into a separate thread as you tagged your reply onto an unrelated issue. 



#4
810230919

810230919

    Stranger

  • Members
  • Pip
  • 8 posts

 

I have the same issue here and now. It happened about 3 days ago.

 

The repro step is :

You click the "Manually Download" on any file of any mod for any game on nexus.com.

Click on the "Slow Download" in the following up page. Then nothing happens.

 

If everything goes well, another page should pop up, with a 5s countdown, after it's over, the download will start. But these are all gone and never happen.

 

 

 

I'm using Edge and tried chrome, and I also tried on mobile phone, with WIFI or not, tried the troubleshooting article, this issue still happens. 

 

 

And this issue comes with another two issue:

 

One:

You will notice the total downloads and unique downloads number on the file page of any mod never show up, and just displays as "-" for default, just like it failed to fetch any data from server. No matter how long you wait.

 

 

Two:

Try to use the advanced filter in the mod menu of website, search for anything. It will work for the first time, and give the correct result. But if you change any config such as keywords of file name, and click "Apply Filter", it won't give any feedback and nothing happens, just like you click on the "Slow Download" above.

 

Here is the info I can share. Hope anyone could find the root and resolve it. I will keep trying, and if I find how to resolve it, I will post it.

 

The issues you're mentioning are indicative of javascript not working in your browser. Ensure you do not have anything blocking our javascript from working ("internet security suites", browser plugins, browser settings, etc.) else the site will not function properly.

 

Thank you for your heads-up!

 

I have found the root:

Nexus mod website is using some js libraries from a lot of addresses such as:

https://cdnjs.cloudf...apaparse.min.js

But these addresses have been blocked by GFW in China. (Perhaps recently)

 

So unless your web browser has correct cache of them, or use VPN to get access of these addresses ( better to use global mode), the scripts of web will never work. Download button is just one of them. 

 

 

How to tell if you meet the same issue of mine:

On mod download page, the one you can see "SLOW DOWNLOAD" button and "FAST DOWNLOAD" button, press F12 to enable the developer mode of your web browser.

Click on the error icon to check the error list.

If you see some web links which end with ".js" saying "xxxx closed" or "can't get access xxxx", you got it.


Edited by 810230919, 12 January 2022 - 02:13 PM.


#5
Pickysaurus

Pickysaurus

    Community Manager

  • Admin
  • 17,991 posts

 

 

I have the same issue here and now. It happened about 3 days ago.

 

The repro step is :

You click the "Manually Download" on any file of any mod for any game on nexus.com.

Click on the "Slow Download" in the following up page. Then nothing happens.

 

If everything goes well, another page should pop up, with a 5s countdown, after it's over, the download will start. But these are all gone and never happen.

 

 

 

I'm using Edge and tried chrome, and I also tried on mobile phone, with WIFI or not, tried the troubleshooting article, this issue still happens. 

 

 

And this issue comes with another two issue:

 

One:

You will notice the total downloads and unique downloads number on the file page of any mod never show up, and just displays as "-" for default, just like it failed to fetch any data from server. No matter how long you wait.

 

 

Two:

Try to use the advanced filter in the mod menu of website, search for anything. It will work for the first time, and give the correct result. But if you change any config such as keywords of file name, and click "Apply Filter", it won't give any feedback and nothing happens, just like you click on the "Slow Download" above.

 

Here is the info I can share. Hope anyone could find the root and resolve it. I will keep trying, and if I find how to resolve it, I will post it.

 

The issues you're mentioning are indicative of javascript not working in your browser. Ensure you do not have anything blocking our javascript from working ("internet security suites", browser plugins, browser settings, etc.) else the site will not function properly.

 

Thank you for your heads-up!

 

I have found the root:

Nexus mod website is using some js libraries from a lot of addresses such as:

https://cdnjs.cloudf...apaparse.min.js

But these addresses have been blocked by GFW in China. (Perhaps recently)

 

So unless your web browser has correct cache of them, or use VPN to get access of these addresses ( better to use global mode), the scripts of web will never work. Download button is just one of them. 

 

 

How to tell if you meet the same issue of mine:

On mod download page, the one you can see "SLOW DOWNLOAD" button and "FAST DOWNLOAD" button, press F12 to enable the developer mode of your web browser.

Click on the error icon to check the error list.

If you see some web links which end with ".js" saying "xxxx closed" or "can't get access xxxx", you got it.

 

 

This is useful information, thanks for sharing. I'll pass this onto our developers and see if there's anything we can do from our side. 

 

It's strange that they'd block a CloudFlare URL considering the amount of sites that use it. 



#6
DameOliveCardpalm

DameOliveCardpalm

    Newbie

  • Members
  • Pip
  • 18 posts

Just had this issue, it was malwarebytes browser guard blocking cloudflare, simply selected to trust the site from the browser widget and all good  :thumbsup: 



#7
damon69

damon69

    Fan

  • Members
  • PipPipPip
  • 257 posts

I am also experiencing this problem. No downloads since about an hour or so ago.

 

DameOliveCardpalm: Thank you for the solution... m'lady!


Edited by damon69, 14 May 2022 - 08:31 PM.


#8
Dalquist

Dalquist

    Fan

  • Supporter
  • PipPipPip
  • 402 posts

Started getting this earlier today also.  @DameOliveCardpalm that worked, thanks.


Edited by Dalquist, 14 May 2022 - 09:50 PM.





IPB skins by Skinbox
Page loaded in: 0.943 seconds