Jump to content

Photo

How to edit input.settings for Witcher 3

witcher3 input.settings instant sign instant cast input.settings.part.txt vortex keybind

  • Please log in to reply
2 replies to this topic

#1
garweb

garweb

    Stranger

  • Members
  • Pip
  • 2 posts

Having trouble adding keybinds to the Witcher 3...

 

Vortex always overwrites the input.settings file, so that's a no go.

I've tried editing input_qwerty.ini that doesn't work, even if I delete input.settings first from the vortex folder.

Tried adding the keys into input.settings.part.txt from Friendly HUD, nope

Tried making my own input.settings.part.txt, that failed.

 

I know this has to be easy and I'm just dumb.

 

Oh, to anyone wondering, I'm trying to add in the simple changes to do instant casting with kb/m.  That's why I don't just change the keys in-game.

 

Thanks.



#2
Nagev

Nagev

    Journeyman

  • Premium Member
  • 30 posts

Hi @garweb - the simplest way to add your own input settings would be to:

1. Ensure your automatic deployment settings are disabled

2. Purge your mods.

3. Delete the "Witcher 3 Menu Mod" mod entry inside your mods page.

4. Edit your `input.xml` file manually outside of Vortex

5. Go back inside Vortex and hit the Deploy Mods button.

 

That should ensure your manually added entries are kept from here on out.

 

Edit: Please not that if any of your mods attempt to modify the same variables - your manually added modifications will be overwritten.

To bypass that, you will have to find which mod is doing the changes and change its input.settings.part.txt inside the mod's directory in the staging folder.



#3
garweb

garweb

    Stranger

  • Members
  • Pip
  • 2 posts

Your right and your idea works, right up until this point...

 


That should ensure your manually added entries are kept from here on out.

 

And you're still right, with the addition of "so long as you never ever change them" :smile:  Joking aside, once you delete everything, input.settings will be recreated at least in part by input_qwerty.ini.  But after that has been done once, further changes have no effect.

I've "solved" the problem, aka found a janky workaround.

 

The issue is that Vortex makes 2 files in your  Documents\The Witcher 3 folder:

user.settings.vortex_backup

and input.settings.vortex_backup

 

If you don't delete or overwrite those files, Vortex will replace the user and input.settings with its backup, even if you say to use the newer file on deploying.  Not sure if it's a bug or working as intended.  Vortex seems to not like you to make your own edits, but sometimes I have to.

 

So, my "solution" is that anytime I make changes to user.settings or input.settings, either outside the game or within the game (say changing a keybind or adjusting a mod that has a menu) I copy the new user or input.settings to:

c:\users\{user_name}\Documents\The Witcher 3\input.settings

c:\users\{user_name}\Documents\The Witcher 3\input.settings.vortex_backup  AND

c:\Vortex Mods\witcher3\Witcher 3 Menu Mod Data (your_profile_name)\input.settings

 

- Obviously the path to your files may vary... and replace input.settings with user.settings as needed.

 

Again, maybe I messed up something while installing my mods, but I don't think so. 


Edited by garweb, 15 January 2022 - 12:08 AM.






Also tagged with one or more of these keywords: witcher3, input.settings, instant sign, instant cast, input.settings.part.txt, vortex, keybind

IPB skins by Skinbox
Page loaded in: 0.988 seconds