Jump to content


Skyrim has died.... (Advanced)

support ae vanilla win11

  • Please log in to reply
1 reply to this topic




  • Supporter
  • Pip
  • 4 posts

I was running a modded version of Skyrim with 107 mods enabled and everything was running fine.

2 days ago went to play and my save data corrupted and it is what it is, it can happen.

Tried to make a new save and it kept crashing, Disabled all mods and tried to create a new save and it was still crashing so It was overdue so I ran a clean boot of Win11 with a full factory restart.

Upon reinstalling steam and then Skyrim when launching the game opens to the main menu and is missing the dragon insignia and says

"thanks for purchasing anniversary edition, would you like to download content"
"Download"  (Not really much choice here I know"

Whether I download the AE content or not the insignia will not come back and when I press New game it goes black and instantly crashes and this is vanilla with no mods or skse installed.

I've been trying for about 9 hours and had a friend who works in IT on my PC for 5 more hours neither of us can figure it.

*p.s Game only opens in a windowed version despite not being selected and having Nvidia trying to force it to.

Please help, I may be slow to reply as I will be still trying to fix it or binning my PC so feel free to message me on Discord if you know the cause/fix. Nyri#0666




  • Premium Member
  • 420 posts

Maybe you already did, but in my opinion the best way to do; Uninstall all your mods, not only disable, but real uninstall. Empty your game directory, and go to steam and verify your game. It wil download all the missing files. Then start with the launcher. You must be able to change the settings about windowed or borderless.

Then you are able to reïnstall your mods.

Also tagged with one or more of these keywords: support, ae, vanilla, win11

IPB skins by Skinbox
Page loaded in: 1.008 seconds