Jump to content

Photo

Help! Companions quest broken for all saves

companions quest broken bug vilkas train

  • Please log in to reply
1 reply to this topic

#1
steelfeathers

steelfeathers

    Faithful poster

  • Members
  • PipPipPipPip
  • 2,111 posts

Someone please help! On every one of my skyrim saves, whenever I try to join the companions I get stuck on the 'train with Vilkas' quest. He keeps saying 'we don't use magic here, new blood' and attacking me. I tried waiting, fast traveling away, reloading from an earlier save, even making a new character! BUT HE JUST KEEPS BLOODY DOING IT!!

 

I tried doing the whole "setstage c00 20" then "setstage c00 30" fix, but even though I got the quest to take a sword to Eorlund, Vilkas kept trying to attack me and kept repeating that same line. (I don't know if this helps with troubleshooting, but I keep getting dead dragons dropping out of the sky in the middle of cities as well).

 

(And of course, it goes without saying that I didn't actually use magic anywhere near vilkas)

 

EDIT: Also, I used to have "Enchanced skyrim factions-- the companions" installed (just the requirements version, not the version with changes to the quests), but when I started getting this bug I uninstalled it and loaded an earlier save. But it's still happening even without the mod.

 

 

Here are the mods I'm using. Most are small fixes or single armor sets.

 

-Anorith's shack

-Unlimited bookshelves

-Unicorn mount

-3rd person dual wield animation fix

-no spinning death animation

-Brigandage armor

-colovian armor

-crown helmets

-dwarven mechanical equipment

-fur hide armor

-immersive armors

-jethead armors

-ritual armor of boethiah

-tribunal masks

-heart of the beast- werewolf sounds and textures

-silent dead thrall groans

-sounds of skyrim- dungeons/wilds

-no stretching texture fix

-dawnstar expanded

-bandoilers bag and pouches

-craftable monk hoods

-face masks of skyrim

-grimoas, scarf and gugel

-mage apparel overhaul

-wear circlets with hoods

-dodge mod

-dragon combat realism

-duel combat realism

-better stealth AI for followers

-inigo

-my home is your home

-vivid landscapes (dungeons/ruins)

-better magic

-run for your lives

-when vampires attack

-thieves guild requirements

-apachii sky hair

-lovely hairstyles

-normal dawnguard vampire faces

-dead body collision fix

-get snowy

-guard dialogue overhaul

-exterior lighting enhancement

-immersive patrols

-the big book of alchemy

-traps make noise

-enhanced gauldur amulet

-mystic gloves

-wearable lanterns

-breezehome enchanter

-immersive college of winterhold

-severin manor lighting fix

-harvest overhaul

-apocalypse spell package

-forgotten magic redone

-aMidianBorn armor retextures

-book covers skyrim

-deadly serious shrouded armor

-mage equipment overhaul

-inconsequential NPCs

-Interesting NPCs

-My little kitty

-Climates of tamriel

-ShowRaceMenu precache killer

-unofficial skyrim/dawnguard/hearthfire/dragonborn patch

-ethereal elven overhaul

-better vampires

-quality world map

-better messagebox controls

-skyUI

-Auto unequip ammo

-follower trap safety

-burn freeze shock effects

-pure waters

-JaySUS swords

-torch arrows

-unique uniques

-weapons of the third era

-wulfharths dragonbone weapons

-heavy armory weapons


Edited by steelfeathers, 09 September 2013 - 01:26 AM.


#2
Jistchillin

Jistchillin

    Newbie

  • Members
  • Pip
  • 11 posts

Hi there! I see you have the same problem I do. While this can be annoying, I did find a solution that worked temporarily without the use of mods or console commands. Now, whether it is through luck or whatever, here is what I did. I took a two handed weapon (the ebony blade, though I doubt it makes a difference) and just kept power attacking vilkas. No one else attacked me and Vilkas kept being staggered, but he eventually said the next line about his sword. Now, he didn't actually give me the sword until I power attacked him a few more times. So give that a whirl and see if it works for you.







Also tagged with one or more of these keywords: companions, quest, broken, bug, vilkas, train

IPB skins by Skinbox
Page loaded in: 1.128 seconds