Jump to content

Photo

New to modding on pc, SSE or AE?

new upgrade anniversary

  • Please log in to reply
2 replies to this topic

#1
EclipseScythe

EclipseScythe

    Stranger

  • Members
  • Pip
  • 5 posts

Hello, I just recently got a laptop so I could try modding skyrim. I'm not sure if I should use the downgrade patcher to downgrade to version 1.5.97 or just build my load order around the most up to date version of the game using only updated/compatible mods? If I should go with the latter option then are there any resources to know what mods will work with the newest version?



#2
Algabar

Algabar

    Faithful poster

  • Premium Member
  • 1,497 posts

Well, there are different opinions on this topic.

 

In fact, most mods work in AE (most of them "out of the box", some after an update). There are only some mods, that don't.

Here's an overview of mods NOT working:

https://modding.wiki...rs/skse-plugins

 

In the end, it's up to you: Which mods are "essential" for you? If one or more of them are on the list in the link above, downgrading is probably the way to go. If you do NOT "need" any of the mods, that currently don't work in AE, I'd just go with the latest version of the game.

 

In fact, I've been playing AE (only the free update, not the paid Creation Club content) for some time now. Performance is minimal better than in SE. The game runs stable, everything fine. The only mod I'm missing is "No grass in objects", but there are workarounds. Everything else I want or "need" in my game works in AE.



#3
EclipseScythe

EclipseScythe

    Stranger

  • Members
  • Pip
  • 5 posts
Thank you very much for replying and an extra thank you for the link. Im happy to hear that most mods do still work with the update and will definitely check the list for whats not working.





Also tagged with one or more of these keywords: new, upgrade, anniversary

IPB skins by Skinbox
Page loaded in: 1.107 seconds