Jump to content

Photo

mesh/record identification help request


  • Please log in to reply
3 replies to this topic

#1
radiusrsatti

radiusrsatti

    Journeyman

  • Members
  • Pip
  • 44 posts

I'm trying to make multiple mods like ETaC, JK's Overhaul, grass overhauls, NGIO, DynDOLOD and other similar mods coexist... for the most part, they work well, I've been able to identify and modify/remove all inconsistencies I've come across... except I'm now stuck on a few grass meshes in front of the Riverwood Apothecary of ETaC, which appear to be vanilla remnants (maybe JK's) as they are floating above the ETaC landscape change.

By console, I cannot select them or scroll to identify, even by removing all surrounding meshes in process of elimination... some meshes, such as the ground, are unclickable and unselectable...

If these grass meshes have somehow defaulted to that level of inscrutability, where would these records likely reside? attached to ground mesh records, navmeshes, landscapes, NGIO (No Grass in Objects) cache files or DynDOLOD?

Given my current modcount of 1359, loading into CK is out of the question, specifically due to not knowing which records or last change is being made to know where to look

 

TLDR

 

This isn't game breaking or even affecting, just a graphical inconvenience... I'm just attempting to fix the aesthetics manually, but if anyone has any ideas on record or mesh identification of clickthrough objects via console, preferably without using CK, it would be appreciated

 



#2
IsharaMeradin

IsharaMeradin

    The Pale Redguard

  • Members
  • PipPipPipPipPip
  • 10,502 posts

You can see if anything on the linked page might be of help: https://www.creation...ating_Grass_Fix

 

If you have not, I would recommend testing on a new game to see if that solves the issue.

 

The grasses that you are referring to are rendered into the game world when that area is loaded.  They are not pre-placed object records like bushes or trees.  Instead the area is "painted" to have grass and then the game fills it in with grass based on the various INI settings.



#3
radiusrsatti

radiusrsatti

    Journeyman

  • Members
  • Pip
  • 44 posts

possibly saved me some headache, thanks... tg confirms it's a painted grass field instead of placed meshes, didn't know that was a thing til now, meaning all the landscape and navmesh forwarding I've done requires me to regen the grass cache and DynDOLOD... or at least that's what I'm running with



#4
radiusrsatti

radiusrsatti

    Journeyman

  • Members
  • Pip
  • 44 posts

You can see if anything on the linked page might be of help: https://www.creation...ating_Grass_Fix

 

If you have not, I would recommend testing on a new game to see if that solves the issue.

 

The grasses that you are referring to are rendered into the game world when that area is loaded.  They are not pre-placed object records like bushes or trees.  Instead the area is "painted" to have grass and then the game fills it in with grass based on the various INI settings.

 

confirmed, just finished the rebuild of NGIO and DynDOLOD... grass in front of the apothecary is proper now, and flower fields is now working too :D thanks for assist






IPB skins by Skinbox
Page loaded in: 0.899 seconds