Jump to content

Photo

No idea why my quest alias isn't filling.

follower

  • Please log in to reply
5 replies to this topic

#1
AureliusOfRome

AureliusOfRome

    Enthusiast

  • Members
  • PipPip
  • 121 posts

Note: I have followed Joseph Russells' Tutorial on followers with some slight modifications. I only watched it for the template scripts though.

 

I have set up two quest stages: one is numbered 1 which is just a blank stage to ensure the quest is running from the start (SEQ file is generated and placed in the correct folder). The second is numbered 5 which prevents the custom recruitment/story dialogue appearing again after hiring Ewond (a temporary follower name for now) and also to take away 1000 gold should they decide to hire him + make the player auto-follow if they do pay.

 

The problem is, is that despite seemingly correctly setting up the alias for Ewond to refer to him, it doesn't seem to do anything: the auto-follow and the gold paying script fragment (in a dialogue) does work, and so does the stage setting to 5. However the quest objective which informs the player of Ewond's successful employment is displayed like this: "[...] has become your companion and is now recruitable." instead of "Ewond has become your companion and is now recruitable."

What is strange that is the sqv command shows something amiss too: before hiring Ewond, the alias ref looks like this: "Ewond" ---> NONE (should be correct since the Russells' tutorial never said anything about force referencing or referencing at all) but turns into this after stage 5: "Ewond" ---> "" (Insert Ewond's ID here after) which is strange since the actual ID for Ewond should be something like "GFEwond" or just "Ewond" instead of just blankness.

I tried everything: I made it an optional alias, tried force referencing, tried unique actor referring, but to no result. I am completely stumped what could cause it honestly.

 

Here is my reference alias for Ewond, the Quest Objective tab and what it looks in-game: before starting the conversation, and after starting the conversation: Exhibit A and Exhibit B

 

If someone could help me with this problem, then I will be forever grateful.

 



#2
IsharaMeradin

IsharaMeradin

    The Pale Redguard

  • Members
  • PipPipPipPipPip
  • 10,508 posts

On the reference alias select Specific Reference, click the Select Forced Reference button, select the cell that your pre-placed actor is within, then select the actor reference. Afterwards, okay out of the reference alias and the quest.  Save the plugin and start a new game to test it out.

 

If that does not work, then hopefully someone else has some ideas.



#3
AureliusOfRome

AureliusOfRome

    Enthusiast

  • Members
  • PipPip
  • 121 posts

Hmm, I tried force referencing to GFEwond NPC and it does seemingly display correctly in the Creation Kit, but when I try the sqv command in-game again, it does the same thing: before recruitment the Ref just says NONE and after the recruitment fee paying it just shows the blankness again. I suspect something might be amiss with a messy dialogue script I did for actually recruting Ewond, so I'll post that along with some other things.


Here are my quest stages: 1, this is a blank stage to ensure the quest actually starts and as a condition to start the recruitment dialogue only at this stage, so I can't do much here and 5 (ignore the Log Entries, I don't want them to appear anyway) so it moves on to the next stage to and prevents the stage 1 dialogue from playing again. I did notice something called "kmyQuest" here but I don't believe that could be the cause of it: I'll try it anyways and edit this post to see what happens. Here is also the quest data tab.

 

And as a final, this is the dialogue part that I suspect the most to have broken the alias. The obscured code follows as this:

 
Game.GetPlayer().RemoveItem(Gold001, 1000)
GetOwningQuest().SetStage(5)
GetOwningQuest().SetObjectiveDisplayed(5)
(GetOwningQuest() as GFEwondCommandCenter).SetFollower(akSpeaker)
 

The properties I have in the TIF scripts are the MiscObject for Gold001 (works fine) and a Quest one to refer to GFEwondFollower (SetStage, SetObjectiveDisplayed) for the first two GetOwningQuest() parts.

 

Update: The kmyQuest didn't work, it just resets to none the second I press the OK button on the Quest Stages. The only thing I can select is the GFEwondCommandCenter from the scripts tab.


Edited by AureliusOfRome, 16 May 2022 - 11:10 AM.


#4
AureliusOfRome

AureliusOfRome

    Enthusiast

  • Members
  • PipPip
  • 121 posts

Some breakthrough in the alias scripting: I changed my alias reference to an unique actor one and the alias does work now. No idea why it does work now even though I have tried the unique actor referring a hundred times at this point probably, but at least that persistent bug is gone.

 

But, there is a big problem with it: the second I spawn in Nightgate Inn, Ewond starts to follow me automatically, but the dialogue option to recruit him is still available. The game acts like I have already recruited him in theory, but also not really. Is this something to do with quest stages?

 

Update: I found out that apparently starting the quest automatically (via console or using the "Start Game Enabled" option in CK) triggers the follow script for some reason. However, I still have no idea which script (I suspect one of the packages in the alias tab) is that and specifically which part could cause it. This only begun after I set Ewond's alias to refer to an unique actor (and sadly the alias doesn't work in any other way).


Edited by AureliusOfRome, 17 May 2022 - 02:33 PM.


#5
Sphered

Sphered

    Fan

  • Premium Member
  • 449 posts

Following != Teammate

 

Following is nothing more or less. Doesnt even have to be an actor they are following. Just the AI pack they are using has xyz ref as the pointer. Your NPC there has a package that is telling him to follow you. Which package depends on quest priority or otherwise whichever one is "active" at that time for him, and the conditions give him a green light to do that

 

Aliases need to be flagged as optional if you dont want issues there with empty slots causing others to not fill properly. Persistence matters here too. If in doubt make all aliases optional and fill them manually. IDK just sounds messy whatever is going on



#6
AureliusOfRome

AureliusOfRome

    Enthusiast

  • Members
  • PipPip
  • 121 posts

Hmm, I guess it has something do with the alias then: I set a condition on PlayerFollowerPackage so it only triggers when the GFEwondFollower quest is at stage 5 and that seemingly solved the instant follow when in the inn.

 

However, the dialogue options still act like I haven't hired him via a certain option but also hired him (can still give commands and dismiss) at the same time. Strangely enough, if I dismiss Ewond and talk to him again, the options work correctly (only the hire dialogue appears as it should be). Something is causing the packages and commands to appear before they're supposed to. I'll try making the other package "PlayerFollowerDismissPackage" dependent on a stage too and check the other alias options. If that doesn't work, well, then I'll probably have to remove Ewond (the actor) from some factions and then add him to those same ones via a script in the dialogue tree.







Also tagged with one or more of these keywords: follower

IPB skins by Skinbox
Page loaded in: 1.112 seconds