Jump to content

Photo

Skin Mods not changing the face.


  • Please log in to reply
12 replies to this topic

#1
Taithan

Taithan

    Journeyman

  • Members
  • Pip
  • 21 posts

So I recently did a complete reinstall of Special Edition, and it's been a while since I've tried to work with SE mods, and I've run into an issue. The skin mods do change the skin, but the face texture stays looking like the vanilla face. I'm trying to use Leyenda Skin specifically, but I'm having the same issue with every skin mod. Everything is running right as far as I know (I'm using the Anniversary Script Extender and it's working, either that's what I did last time or I used a version downgrader but I'm not sure it'll help and it's too much of a pain to only try to see if it fixes it) and the only mods that could possibly affect things is Leyenda Skin and Racemenu. This is the first time I've had this issue and I'm at a complete loss for how to fix it. I do use Vortex because I'm a scrub and trying to look elsewhere for answers brings up either something unrelated or the black or blue face bug, which isn't the issue I'm having.



#2
Algabar

Algabar

    Faithful poster

  • Premium Member
  • 1,505 posts

First of all, Vortex has excellent options to handle conflicts. In the "mods" tab, klick on the small arrow next to the mod. Make sure your skin mods "load after" anything else, that may conflict.

 

Second: Is the skin mismatch on the player character? On NPCs? On both? And if it affects NPCs - do you use NPC overhauls or NPC replacers? If so - which ones? Some NPC mods (partly) use their own textures. A well known example is the "Bijin" series. Also, charakter makeovers are often incompatible with custom textures.

 

BTW, using Vortex doesn't mean you're a "scrub". In fact, its one of the best mod managers. It's definitely on the same level as MO2.



#3
Taithan

Taithan

    Journeyman

  • Members
  • Pip
  • 21 posts

With the first option, I think I see what I'm supposed to do, but the skin mod never had any conflicts, I never had the option to ensure that it loads after anything.

 

With the second, after checking, the NPCs look to be working just fine, it's only the player's face texture that doesn't change.

 

If it helps, the only mods I'm using are:

Legacy UUNP
Unofficial Skyrim Special Edition Patch

Alternate Start - Live another Life

Leyenda Skin 4.0 UNP

UIExtensions

SkyUI

Racemenu

AddItemMenuSE



#4
Algabar

Algabar

    Faithful poster

  • Premium Member
  • 1,505 posts

Okay... so that's a rather short list. We can definitely rule out the Unofficial Patch, SkyUI, Alternate Start and AdditemMenu. I'd be very surprised if these mods would do anything about your player character's face. Also, UIExtensions is very unlikely to be the culprit. That leaves us with Racemenu, Legacy UUNP and Leyenda Skin.

 

If you say you "reinstalled Special Edition", which version are you using? If you just redownloaded the game from Steam, you'd get the "Anniverary Edition" (1.6.353). "SE" is 1.5.97. You would have to deliberately downgrade to it with the downgrade patcher. (which I wouldn't recommend BTW - it's absolutely fine to use AE).

 

The reason, why I'm asking about your game version, is this: If you're on AE (1.6.353), you would have to update SKSE, Racemenu and the Unofficial Patch. AdditemMenu won't work in AE. So maybe you got the wrong version of Racemenu for your game version? That woudl explain problems with your player character.

 

If you really have SE (1.5.97), you should also check, if you've got the right versions especially of SKSE and Racemnu. Apart from that, I'd recommend testing with a different body replacer like BHUNP. Why a new body replacer? Since the problem persists with different skin textures, the problem is most likely not Leyenda skin. So, maybe it's "Legacy UUNP".

 

Hope that at least one of the ideas above helps...



#5
Taithan

Taithan

    Journeyman

  • Members
  • Pip
  • 21 posts

I just freshly installed it from Steam, the executable says it's version 1.6.353, so Anniversary edition. I installed the Anniversary Edition version of SKSE, version 2.1.5, I'm pretty sure I installed the correct version of Racemenu, it says it's Anniversary Edition, version 0.4.19.9, so unless that's the wrong version that leaves Legacy UUNP, issue with that is that I've tried testing it without any body replacers and I have the same issue.

 

I use a body replacer because of some other mods I'm planning on installing once I solve this issue, but I'm unfortunately forced to use Legacy UUNP because I have a specific Bodyslide Slider Preset I want to use, which is for UUNP, but I have no idea how to convert it to BHUNP, or if I even can. 

 

Edit: Disregard just about everything I just said, I ran a new game with nothing but Racemenu and Leyenda Skin and the skin works, face changed and everything, I ran it with Racemenu, Leyenda Skin, and Legacy UUNP, and it works, but once I run it with the Unofficial Patch too, it stops working, so that means the issue's gotta be the Unofficial Patch, I didn't think I installed it wrong, seeing as it was the only available option on the Nexus, the version is 4.2.6a, is that the wrong version to use?


Edited by Taithan, 22 May 2022 - 09:36 PM.


#6
Algabar

Algabar

    Faithful poster

  • Premium Member
  • 1,505 posts

Glad you made some progress! The issue with the Unofficial Patch is strange indeed. Never heard of something like that before. You seem to have the correct version. This one is for AE. Playing without the Unofficial patch (USSEP) isn't something I'd recommend TBH. A lot of mods are designed with the fixes already made by USSEP in mind. So, simply uninstalling USSEP unfortunately isn't a good "solution".

 

Also, 0.4.19.9 is the current build of Racemenu here on the Nexus. In fact, there is a newer version, which can be found on expired's Patreon. I don't use it, but maybe worth a try,

 

TBH, I'm still very surprised that the problem comes from USSEP. I'm using the same version as you - although with a CBBE 3BA setup. No problems at all. So this remains a mistery...

 

One last thing: Do you use the current version of Bodyslide? Maybe that's something you could check.



#7
Taithan

Taithan

    Journeyman

  • Members
  • Pip
  • 21 posts

The issue with USSEP really is strange, I haven't ever heard of anything like this happening. Multiple mods I'm keen on using do require it so not using it really isn't an option.

I tried the newest version from the Patreon, it didn't change anything unfortunately. 

I have Bodyslide version 5.5.2, using it didn't change anything.

Lastly I've tried using a different body replacer (BHUNP), and that didn't work.

 

I'm honestly at a loss, this is honestly not a problem I thought I'd be having.



#8
Algabar

Algabar

    Faithful poster

  • Premium Member
  • 1,505 posts

As I said before: This is really strange. TBH, meanwhile I'm somewhat at loss.

 

One thing you could try (if you didn't already): Start a new game. At least this could narrow down the issue: If the problem persists in a new game, it's very likely mod related. If everything works fine in a new game, it's a problem with your save game.



#9
Taithan

Taithan

    Journeyman

  • Members
  • Pip
  • 21 posts

I actually already have been trying it in new games, nothing changes unfortunately.

 

Edit: I just had a thought, maybe it's something from the Creation Club? I sometimes look on there to see if anything's free, even if I never use it, but I've never seen an option to turn them off. Anything I can do to do that?


Edited by Taithan, 24 May 2022 - 11:25 PM.


#10
Algabar

Algabar

    Faithful poster

  • Premium Member
  • 1,505 posts

AFAIK, the only way to "turn off" Creation Club content is to manually delete the files in your Skyrim SE folder. I'm not absolutely sure if this is also true for content downloaded outside of the free "Anniversary Edition" or the paid upgrade. But for "AE", it works this way.

 

At least for the "AE" content, deleted files will also be restored every time you update or verify your game in Steam.






IPB skins by Skinbox
Page loaded in: 0.878 seconds