Jump to content

Photo

Can't activate door from interior cell

loaddoor interior exterior

  • Please log in to reply
4 replies to this topic

#1
Tasheni

Tasheni

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,217 posts

My big ship interior is nearly finished, but I run into an issue with the load door I can't resolve. In fact I'm completely lost. I'm really experienced in creating doors to link interior and exterior cells together. But this damn door refused to get activated ingame.

 

In ck all works fine. The doors are properly linked. Ingame I can activate the door in the exterior that teleports me into the interior cell. But I can't get out, because there is no activation visible.

 

What I tried:

 

Deleted the doors, saved the plugin, cleaned with XEdit and created the doors again. Same result.

Used other loaddoors - same result.

Placed the exterior door inside the same custom worldspace, where my ship is - same result. :wallbash:

Made sure I did not checked any boxes like hidden. I navmeshed the areas and finalized the cells and the green triangles are correctly placed. I shifted the yellow doormarker farther away, narrowed it, same result. Nothing works.

 

I coced into the interior cell, I started a new game to get into the cell - same result. I'm out of ideas. Maybe you know something about loaddoors I don't, your help is much appreciated.



#2
Hanaisse

Hanaisse

    Old hand

  • Members
  • PipPipPip
  • 705 posts

As a guess, perhaps something is blocking it, like collision from something else?



#3
Sphered

Sphered

    Fan

  • Premium Member
  • 447 posts

The nif has flags that are capable of controlling how objects behave and respond in game. If this is a door model you havent successfully used you might try temp using another door mesh to see if thats the culprit. Only thing I can think of beyond record flags in the CK that could also restrict usage



#4
Tasheni

Tasheni

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,217 posts

Solved!!! :laugh:

 

@Sphered: Thank you for your reply. I used custom objects that are no doors as doors and any of them works, so I was really surprised that just this door should not? I compared the farmhousedoorl01 with my door in nifskope and everything was the same.

 

@Hanaisse: Thank you, Hanaisse, this was the right hint, I guess. I'm not completely sure.

 

I tried farmhousedoorl01 and noticed, that the activation was behind the door. I used tcl to go through the door and suddenly the activation appeared. Behind the door. ??? I pulled the door more inside the room and that worked. That worked also with my shipdoor. This is weird, because there is no visible obstacle in the way, if I push the door fitting into the doorframe. Alright, I guess the reason is the interior model of the ship. It has other obstacles which make it very tricky for npcs to move around. Navmeshing was pain. There are outstanding planks and the gratings on the floor are raised a bit above the floor, so I had to put the navmesh slightly above those obstacles to prevent npcs for getting stuck. Like on a ship - there's not much space for moving around :confused:

 

Thank you both, I can live with it as it is now.

 

And I got a new idea. Maybe I will duplicate the ship for using in Skyrim. Then you can go through the interior and after some time you will arrive in Teia. So you could sail the same vessel in Skyrim and in Teia. No additional scripting is needed to get that running. Hey, what a nice idea???!!! :laugh:



#5
Sphered

Sphered

    Fan

  • Premium Member
  • 447 posts

Sounds neat. Two other things on the door. BlockActivation() is a thing but I imagine youd kinda notice something was doing that. Cant remember if this applies to doors, but other refs require having a name before they can be interacted with. Just weird if its not working otherwise







Also tagged with one or more of these keywords: loaddoor, interior, exterior

IPB skins by Skinbox
Page loaded in: 1.063 seconds