Jump to content

Photo

SkyUI Error Code 4

skyui error code 4 skse skyrim.ini error papyrus papyrus ini skyrim

  • Please log in to reply
13 replies to this topic

#1
msw1

msw1

    Newbie

  • Members
  • Pip
  • 10 posts

Hello everyone.

 

Upon trying to load a game, I receive a SkyUI Error Code 4, stating that my Papyrus INI settings are incorrect.

 

I have no mods besides the Skyrim Legendary Edition, SKSE 0.1.6.16, and the latest SkyUI.

 

This is my Skyrim.ini file found in my documents folder:

[General]
sLanguage = ENGLISH
uExterior Cell Buffer = 16
uGridsToLoad = 3
sIntroSequence = 
bBorderRegionsEnabled = 1
iLargeIntRefCount = 131072
fFlickeringLightDistance = 8192

[Display]
fShadowLODMaxStartFade = 1000.0
fSpecularLODMaxStartFade = 2000.0
fLightLODMaxStartFade = 3500.0
iShadowMapResolutionPrimary = 2048
bAllowScreenShot = 0
fSunUpdateThreshold = 2.0
fSunShadowUpdateTime = 0

[Audio]
fMusicDuckingSeconds = 6.0
fMusicUnDuckingSeconds = 8.0
fMenuModeFadeOutTime = 3.0
fMenuModeFadeInTime = 1.0

[Grass]
bAllowCreateGrass = 1
bAllowLoadGrass = 0

[GeneralWarnings]
SGeneralMasterMismatchWarning = One or more plugins could not find the correct versions of the master files they depend on. Errors may occur during load or game play. Check the "Warnings.txt" file for more information.

[Archive]
sResourceArchiveList =Skyrim - Misc.bsa, Skyrim - Shaders.bsa, Skyrim - Textures.bsa, Skyrim - Interface.bsa, Skyrim - Animations.bsa, Skyrim - Meshes.bsa, Skyrim - Sounds.bsa
sResourceArchiveList2 = Skyrim - Voices.bsa, Skyrim - VoicesExtra.bsa
bInvalidateOlderFiles =0
SInvalidationFile =ArchiveInvalidation.txt 

[Combat]
fMagnetismStrafeHeadingMult = 0.0
fMagnetismLookingMult = 0.0
f1PArrowTiltUpAngle = 0.7
f3PArrowTiltUpAngle = 0.7

[Papyrus]
iMinMemoryPageSize=128
iMaxMemoryPageSize=512
iMaxAllocatedMemoryBytes=76800

[Water]
bReflectLODObjects =0
bReflectLODLand =1
bReflectSky =0
bReflectLODTrees =0

[BackgroundLoad]
bLoadBackgroundFaceGen = 1
bSelectivePurgeUnusedOnFastTravel = 1
bBackgroundLoadLipFiles = 1
bUseBackgroundFileLoader = 1

[Interface]
fBookOpenTime = 500.0

[Actor]
fVisibleNavmeshMoveDist = 12288.0000

If anyone knows why this is happening that would be great. Another thing, is the MCM menu has no options, even when I run the game with mods that most certainly use SkyUI.


Edited by msw1, 26 October 2013 - 06:20 AM.


#2
msw1

msw1

    Newbie

  • Members
  • Pip
  • 10 posts

Bump...

 

*EDIT*: Deleted my Skyrim.ini file and it fixed it.


Edited by msw1, 26 October 2013 - 06:42 PM.


#3
Reznik89

Reznik89

    Stranger

  • Members
  • Pip
  • 1 posts

It seems so simple, but this was my fix as well.  Fixed files for 11 hours before i deleted the skyrim.ini. Thank you.



#4
blobvis

blobvis

    Stranger

  • Members
  • Pip
  • 2 posts

I had this problem too. But after I deleted the skyrim.ini it worked as a charm :D

Thanks for the solution msw1 !



#5
shady2097

shady2097

    Stranger

  • Members
  • Pip
  • 1 posts

Hey. it says the same error (error code 4) but i have no skyrim.ini. i have 3 fimilar files

 

1. SkyrimEditorPrefs.ini

2. Skyrim_default.ini

3. SkyrimPrefs.ini

ive tried deleting all 3 of them (together and saperatly) and nothing changed. still get errog 4. anyone can help me please?



#6
camaro_69_327

camaro_69_327

    Faithful poster

  • Members
  • PipPipPipPip
  • 2,100 posts

Hey. it says the same error (error code 4) but i have no skyrim.ini. i have 3 fimilar files

 

1. SkyrimEditorPrefs.ini

2. Skyrim_default.ini

3. SkyrimPrefs.ini

ive tried deleting all 3 of them (together and saperatly) and nothing changed. still get errog 4. anyone can help me please?

Are  you looking in the correct folder?...Its located in your MY DOCS folder. mine is here>>>E:\Users\Dark\Documents\My Games\Skyrim

 

The Game folder, where Skyrim_default.ini is located, is the wrong folder.



#7
lostpro

lostpro

    Fan

  • Members
  • PipPipPip
  • 417 posts

the problem is that Memory stuff you put on Papyrus section, don't know why though...



#8
DracoTheArgonian

DracoTheArgonian

    Stranger

  • Members
  • Pip
  • 5 posts

I don't have a skyrim.ini file...



#9
cdcooley

cdcooley

    Resident poster

  • Premium Member
  • 4,793 posts

It's this line in the Archive section:

 

bInvalidateOlderFiles=0

 

That forces the game to use the original game scripts and ignore the SKSE scripts. I don't know why anyone ever thought it was a good idea to completely reverse the game's logic on how resources should be loaded but that setting has been showing up a lot lately. Remove that line or change it back to a value of 1.



#10
bben46

bben46

    I had a title once, but I forgot what it was.

  • Premium Member
  • 24,973 posts

@ draco -

 

I don't have a skyrim.ini file...

Then the game cannot work. A Skyrim.ini file is required or lots of things in the game are just not possible. My guess is you haven't looked.







Also tagged with one or more of these keywords: skyui, error code 4, skse, skyrim.ini, error, papyrus, papyrus ini, skyrim

IPB skins by Skinbox
Page loaded in: 1.155 seconds