Jump to content

Photo

Large FPS drop after interior->exterior cell travel until restart

exterior fps lag interior cell cell change fps drop

  • Please log in to reply
21 replies to this topic

#1
sanastro

sanastro

    Newbie

  • Supporter
  • Pip
  • 17 posts

Hello, dear Nexus community,

 

after years I've decided to return to Tamriel, this time using survival mods to make the game more interesting. Since my last foray into Skyrim I've got a new computer, so I decided to load up the game with some graphic enhancements. With BOSS and the new CTD-fixing skse_loader change I've not run into major problems, bugs or crashes anymore, however an issue remains: FPS/performance.

 

Most notably there is an issue that occurs sometimes after I travel from an interior cell into an exterior one (Whiterun, Skyrim etc). My FPS will drop to 3-5 from a usual 20-60. Moving back indoors will fix the framerate, but going outside again will start the issue all over again until I restart the game.

 

Important: I don't have a PERMANENT low framerate; of course turning off ENB shoots my framerate through the roof, however this changes nothing about this particular issue! It only happens directly after a cell change from interior to exterior, not always when I'm outdoors, which is why I'm so perplexed. I can launch the game fine in an outdoors section and the framerate will be okay; only cell changes will end up dropping it hard.

 

So, my question is: Can I get rid of this issue, so that my game can finally run without hitches and I can sink hours into it without having to reboot? Why does my FPS drop (sometimes) when going from interior to exterior cells (and ONLY then), and how to fix it?

 

(Also, my framerate SOMETIMES drops really hard when I come close to water, but on other occasions it doesn't. Toggling ENB on/off changes nothing about that. Huh?!)

 

My computer:

 

Windows 7 64-bit

Intel Core i7-2700K @ 8 x 3.50GHz

16 GB RAM

NVIDIA GeForce GTX 660 Ti 2 GB RAM

 

ENBSeries used: RealVision ENB Version B FULL

 

BOSS mod list: Pastebin link

 

Skyrim.ini: Pastebin link

 

SkyrimPrefs.ini: Pastebin link

 

Lastly, here's a picture of my protegé, Alessa Leafwhisper, whose adventures your advice will help make less of a pain.

 

Thank you for reading! Looking forward to your responses.  :blush:

 

- Ivan


Edited by sanastro, 27 January 2014 - 02:16 PM.


#2
ChaoticXeon

ChaoticXeon

    Enthusiast

  • Members
  • PipPip
  • 115 posts

might i suggest resetting your ini files??? seems the ini files are WAY TOOO heavily modified and also please update to latest version



#3
sanastro

sanastro

    Newbie

  • Supporter
  • Pip
  • 17 posts

The latest version of what?



#4
Joeyjoey92

Joeyjoey92

    Journeyman

  • Supporter
  • Pip
  • 49 posts

You can run Real vision FULL with 60 even with all those mods? My system is similar, if not better, but Im surprised. Howd you manage it just a question lol. 

GTX GeForce 760 OC
Intel i5 4670k 4Gz
8 Gig ram. 

Sorry to hijack and ask haha :)



#5
BoromiRofGeo

BoromiRofGeo

    Fan

  • Members
  • PipPipPip
  • 415 posts

i take it you obviously have lastest 1.932 game version, right?

i have same issue sometimes, its  because of all the hd mods and ini tweaks, you can decrease that issue by reseting most of .ini tweaks.

anyway, just alt tab when fps drops, it helps...



#6
Direspawn

Direspawn

    Enthusiast

  • Supporter
  • PipPip
  • 168 posts

I've been dealing with this issue for a long time, and it's aggravating as all hell. All. Hell.

 

I have a handful of HD texture mods, but I mostly pass them by in favor of using ENBs. I ran Skyrim Performance Monitor to see what was happening under the hood and memory was never anywhere near capped.

 

It's the same every damn time. Play for awhile (30 mins) getting ~40 FPS, go inside a dungeon, come back out and WHAM, 10 FPS. Can't Alt-Tab because it will just crash the game.

 

All my mods are up to date, cleaned with TES5Edit, Bashed Patched, BOSSed, etc. Currently using Ewi's INI files with mostly stock settings. Using the latest ENB dlls, Skyrim Project Optimization, SSME, etc.

 

Google something along the lines of "Skyrim fps exterior cell" and you'll see it's a ridiculously common issue, but I've yet to find a working solution.



#7
kraag

kraag

    Faithful poster

  • Supporter
  • PipPipPipPip
  • 1,181 posts
Bump

I've also had this same annoying issue for as long as I've had the game - ~100 different mods of all sorts, all the latest memory managers, latest versions of everything.

All is good running between 40-60 fps for around 30mins to 1hour, then change cells from interior to exterior a few times and the fps drops to ~10-15 on transition from interior to exterior, The interior to exterior thing is a definite, going back to interior straight after the fps has dropped shoots the fps back up to 60 every time without fail.

Checked with performance monitor and memory is fine, tried MANY different INI tweaks over the years to the point of pulling my hair out.

Any more thoughts?

I7-2600k
8GB 1600mhz ram
Nvidia GTX460

(Could be a bug with Nvidia cards? I use ENBoost (no gfx) so I might try setting DisableDriverMemoryManager in enblocal.ini to true...)

Edited by kraag, 02 April 2014 - 11:02 PM.


#8
sanastro

sanastro

    Newbie

  • Supporter
  • Pip
  • 17 posts

I'm sorry to bump this thread after it's been dead for a while, but has any solution been found yet? I've come back from a Skyrim break, and I still face this issue to this day. It's hard to google for this problem due to how specific it is, and I haven't been able to find any fixes.



#9
densetsu42

densetsu42

    Journeyman

  • Supporter
  • Pip
  • 36 posts
Had this identical, very specific-seeming issue. Load the game in an exterior, whiterun in this case, getting 30fps. I consider that playable. Dip into belethor's place, everything looks fantastic, 50fps. Head back out, 8 fps. Not playable. Then i remember something i used to use for morrowind.. If you have this issue on a 64-bit OS, try the 4gb patch to allow the 32-bit skyrim executable to use twice as much ram as it thinks it should need. Just point the patch's exe toward tesv.exe. cleared it up right away
http://www.ntcore.com/4gb_patch.php

#10
densetsu42

densetsu42

    Journeyman

  • Supporter
  • Pip
  • 36 posts
Okay, at first it appeared that the 4gb patch had taken care of this entirely, but upon further review it seems it only extends the amount of time i can play without the issue returning. My new fix is to, immediately after exiting an interior, hit ctrl+alt+del, click task manager (this is windows 8.1) and the task manager will instantly minimize, skyrim screen goes black for about 5 seconds, everything comes back kind of bright for a sec like the shaders hat been reset or something and it works great til the next time i come outside. Much faster than restarting the game. Btw, using gtx 650ti, amd quad-core, 8gb ram, realvision b full and 255 esp/esms activated





Also tagged with one or more of these keywords: exterior, fps, lag, interior, cell, cell change, fps drop

IPB skins by Skinbox
Page loaded in: 1.171 seconds