Jump to content

Photo

Fallout 3 Crashes Fix/Reduce Guide


  • Please log in to reply
22 replies to this topic

#1
Site Bot

Site Bot

    Fear me

  • Members
  • PipPipPipPipPip
  • 2,516,494 posts
Article link: Fallout 3 Crashes Fix/Reduce Guide

If you are experiencing crashes at random or same point of game this article is for you.I try to update that guide with new problems and fix.

----Introduction----

Hi!I see a loots of people have problems with Fallout 3, with that annoying crashes to desktop (like this), so i decided to test and gather, most effective solutions.

----Solutions----

------------------------------------------------------------
1.If you have a multi-core CPU, like the Quad, and you experience a Fallout 3 crash when loading interiors (Specially in closed spaces):

- Open the folder My documents / My Games / Fallout3
- Edit the file FALLOUT.ini.
- Inside FALLOUT.ini look for a group called [general].
- Inside the general group, after all the configuration parameters, just copy and paste the following 2 lines:

bUseThreadedAI=1
iNumHWThreads=2

Now close and save the Fallout 3 configuration file.

------------------------------------------------------------
2.Fallout 3 crashing or crashing to desktop or crashing at the start of the game:

- Click Start
- Click All Programs or Programs,
- Go to the ffdshow folder.
- Click Audio decoder configuration.
- In the left hand pane, click Info & debug or DirectShow control (This is the second entry in the list).
- In the right hand pane, near the bottom, find a check box labelled Don't use ffdshow in
- Check that box, and in the text box underneath (it lights up when you check the check box), add fallout3.exe. Do NOT use spaces, since ffdshow will think that's part of the filename. A valid entry would be explorer.exe;fallout3.exe.
- Finally, click OK and start Fallout 3.

------------------------------------------------------------
3.Fallout 3 crashing after loading my save/autosave (also that solution can help reduce CTD):
- In game menu go to Settings>Gameplay and turn off all autosaves(On wait, sleep and fast travel)

------------------------------------------------------------
4.Solutions reducing CTD:

- it's simple turn off HDR(Fallout Launcher>Options>Screen Effects and chose Bloom or None
------------------------------------------------------------
-Click Start
-Click on Run
-Type dxdiag
-Clink on Display tab
-Disable AGP Texture Acceleration
(Also update DirectX to latest version)
------------------------------------------------------------
-Update your .NET Framework to higher then 3.0 version
------------------------------------------------------------
-If u are using mods(for egzample:WMK, FWE, PB, FOOK, MMM, UF3P(Unofficial Fallout 3 Patch) etc together) and have crashes, download FO3Edit,
-Unpack it to Fallout 3 directory,
-Run FO3Edit,
-Tick all mods that you use,
-Pres "OK" button and wait,
-If program load all mods pres Right mouse button anywhere and chose option "Create Merged Patch" and give it some name for egzample "Fallout 3 Merged Patch"
-Close program save changes and this should help work mods together,
------------------------------------------------------------
-Also if you are running UF3P(Unofficial Fallout 3 Patch), MasterUpdate can help you,
-Download FO3Edit,
-Unpack it to Fallout 3 directory,
-Make a copy of FO3 or rename it to FO3FO3MasterUpdate,
-Run it, wait and play,
------------------------------------------------------------
I noticed(on my self) that a 90% of my CTD was corrupted save, so here are my advices:
-First look at point 3,
-Then when u play try not to use autosave future every 2 sec,
-Use ESC>Save game and crate new save(don't overwrite existing save),
------------------------------------------------------------
5.Few fix for Windows 7 by Thor.:

-Remove Alchemy,
-If you are running Windows 7 try install the older audio drivers from xp, this is in Windows seven pro,
-Install them using the the XP compatibility mode it should work, the xp drivers don't use alchemy.

(This is for people using Creative cards)

it might work for you.

Note Windows 7 will run just fine without it. No noticeable change.
------------------------------------------------------------
-I found that also will stop that nasty crash to desktop when launching the game in Windows 7, try using the basic taskbar lay out. the old vista one. That also works.

It doesn't like many of the Windows 7 features for some reason, even Vista's.

#2
demon737

demon737

    Newbie

  • Members
  • Pip
  • 12 posts
I tried solution 2 but there isn't a programs folder in all programs

PS ur comment counter is being weird, b4 it said there were -1 comments, now it says theres none

#3
Thor.

Thor.

    Possesessed Thor twinspark

  • Banned
  • PipPipPipPipPip
  • 4,668 posts
Its funny i had this issue once before, but what i did was remove Alchemy witch does mean things to Fallout, if you are running windows 7 try install the older audio drivers from xp, this is in windows seven pro, install them using the the xp compatibility mode it should work, the xp drivers don't use alchemy.

This is for people using Creative cards.

it might work for you.

Note windows 7 will run just fine without it. No noticeable change.

#4
philak

philak

    Journeyman

  • Members
  • Pip
  • 21 posts
I have a bloody annoying problem witch is causing game to crash straight after playing the ending movie, it happens straight after it ends at starts to load something then crashes to the loading screen can someone help plz. Thx.

#5
Swampfox92

Swampfox92

    Fan

  • Supporter
  • PipPipPip
  • 269 posts
This makes no sense to me.

When I create a merged patch with FO3Edit, it generates it just fine, and then I exit. It shows that window with the merged patch checked, and I press OK. Finally, when I go into FOMM, it shows no merged patch. I go to my Data folder, and there is no merged patch there at all.

FO3Edit continues to show that there is a merged patch.esp when in fact there isn't one.

Help...

#6
nimil

nimil

    Stranger

  • Members
  • Pip
  • 2 posts
what should i do if i don't have ffdshow on my computer but i am crashing to desktop when i hit continue or new game?

i used to play this game on my windows xp computer, had no problems. computer died, bought a new computer with windows 7, tried to play, and it won't. i click on continue and the game crashes. figured it might be a mod so i took out my mods, tried again, crashed. tried to get a new game started instead cause i figured i had corrupted saves, hit new and game crashes.

i've searched my machine for ffdshow but it doesn't exist on there so what should i do :(

changing to the basic theme for my desktop did not help either. and i don't have anything called alchemy on my system.

#7
kucadobru

kucadobru

    Stranger

  • Members
  • Pip
  • 1 posts
I believe I may have found a reasonable fix for a few Fallout 3 crash to desktop issues. I put the solution at the bottom in case you don't feel like reading the whole thing.

I started playing Fallout 3 again yesterday after putting playing on hiatus about 2 months ago. The game ran without incident, and I hadn't made any major changes to my OS, other than video card drivers. Last week, I had updated my video card drivers to Nvidia's 258.96 WHQL to make another game run correctly. I started up Fallout 3 version 1.7 with Pitt/Steel/Anchorage loaded, and decided it was time to start a new game from scratch.

The game didn't crash up until I left the vault. I made it to megaton, did a few things, then headed out into the wasteland. I couldn't travel very far until the game crashed. I reloaded my autosave, and it crashed again in just a few minutes time. What went wrong? The game ran just fine months ago.... until I loaded new video card drivers.

I tried everything. FFDShow was already fixed. I turned off everything threaded in fallout.ini. I ran the game in windowed mode. I ran the windows live disabler program. I turned off my paging file. After making all sorts of changes, I would run the game for a few minutes and it would crash to desktop in a matter of minutes. It seemed that no matter what I did, the game would always crash. I was about to go through the process of re-installing the entire game, re-patching it, and re-loading windows live, when I thought I'd try doing something else for a change:

______________Skip to the solution________________
Long story short, I deleted my old falloutprefs.ini and fallout.ini, put the DVD in, let it detect the graphics settings, and restore the game's default configuration. I was able to play the game for an hour straight, even after modifying some of the graphics settings. It worked in full-screen, windowed mode, any resolution. I have been playing it nonstop since this morning and have not seen a crash yet.

Fallout.ini and falloutprefs.ini are located in "C:\Documents and Settings\*username\My Documents\My Games\Fallout3"

Or, just do a windows search, and delete them.

Hope this helps

#8
TigerWild

TigerWild

    Stranger

  • Members
  • Pip
  • 3 posts
I believe I have found another issue. Selling 'Live Iguana' or similar items that come from a mod cause a lockup as soon as I attempt to exit the sale.

Solution: Don't sell 'live' anything! lol... simple eh?

#9
Franpa

Franpa

    Fan

  • Members
  • PipPipPip
  • 275 posts
Uhm, you can just open Alchemy and exclude Fallout 3, heck I don't think Alchemy even comes with a profile for Fallout 3 by default.

Point is, no one needs to remove Alchemy.

Edited by Franpa, 02 May 2011 - 01:18 PM.


#10
vajoiner

vajoiner

    Journeyman

  • Members
  • Pip
  • 29 posts

I believe I have found another issue. Selling 'Live Iguana' or similar items that come from a mod cause a lockup as soon as I attempt to exit the sale.

Solution: Don't sell 'live' anything! lol... simple eh?


I have an issue with the live iguana where it ctd if i try to remove it from an inventory either my own or from say a locker.
if it's in my inventory, i can drop it though.

i got it into the locker the first time only.

Edited by vajoiner, 07 June 2011 - 12:30 AM.





IPB skins by Skinbox
Page loaded in: 0.980 seconds