Jump to content

Photo

Modding Skyrim with Wine (PlayOnLinux) in Linux Ubuntu

skyrim ubuntu linux playonlinux mods fnis skse wine os mod

  • Please log in to reply
47 replies to this topic

#1
thekrimzonghost

thekrimzonghost

    Journeyman

  • Members
  • Pip
  • 46 posts

Hey there I am TheKrimzonGhost and I've been part of many coding projects in the past this one is of significance to me because Im currently bed ridden from spinal surgery and will be for the next few weeks and am looking for something fun to do whilst Im incapacitated...Without further Alduine this thread will mainly be for Modding Skyrim on Linux or in my case Ubuntu Ive had great success both with running Skyrim and modding it through a tool called PlayOnLinux so firstly I'll give a you rundown of my system.

 

Operating System: UbuntuStudiox86_64 low Latency  14.04 kernal 3.13.0-35

Graphics: Geforce GTX780

RAM: 6Gb

Processor: i3 3240

MotherBoard: MSI Z77A-G45

USB 3.0

Windows Emulation: Wine 1.7.22 PlayOnLinux

Snakebyte 6 Axis wired PS3 controller

 

Install instructions are as follows for most mods with the exception of FNIS (FNIS is more complex and something Im still working on getting to work).

 

Install For General .esp .esm mods

 

1. Install Playonlinux (open terminal enter command)

   sudo apt-get install playonlinux

 

      2. While in terminal enter command

         playonlinux

 

            3. In playonlinux GUI

        -Tools

           -Manage Wine versions

              -Add version 1.7.22 (this version is very stable)

 

                4. In playonlinux GUI

         -Install

           -Enter Steam into search bar and click Install

              -Welcome to wizard hit next

                //"Its going to ask for a virtual drive name it MUST be labeled z: or FNIS wont work"

                   - z and Enter

                //"a wine toast message may appear stating that wine is configuring a virtual drive"

 

                         5. Once your drive and steam install is complete navigate to your z: drirectory.

                      

                            6. create this folder structure z:/meshes/actors/character/animations (this is for FNIS) 

                   

                               7. Run Steam from playonlinux

         

                                   8. Install Skyrim

 

                                     9. BY THE NINES Jump up and down, pick pocket your brother, and Fus Ro Dah!

 

Ok there are very few mods that I havent gotten to work and a very few have been slightly glitchy. through out all of this battery of surgery Ill be testing mods and increasing this list below any help would be apreciated.

 

 To Add Mods to your freshly installed skyrim is the same as the normal PC version with the exception that manual install is a must and nexus mod manager is not exactly Wine friendly as of yet.

 

 the manual method is as follows

 

   1. Download mod.zip

 

       2. Unzip Mod package

 

           3. Drag Data Folder to your new skyrim directory

      PlayOnLinux's virtual drives/z/drive_c/Program Files/Steam/SteamApps/common/Skyrim/

 

               4. Launch Skyrim

               -Data

               -check installed mods that you want to run

               -Play

               -enjoy your bosemer armor and those hot new body mods... Fus Ro Dah again yolo

 

OK SO WE DID NOT GET INTO FNIS OR SKSE IM LOOKING INTO THESE AS WE SPEAK PLEASE FEEL FREE TO COMMENT AS ID LOVE TO GET FNIS AND SKSE FULLY FUNCTIONING UNDER WINE.

 

skse.exe I have downloaded this and installed it along with and without SkyUI interestinly enough it appears to run SkyUI beutifully but Im not sure that mod handeling is working. Ive installed skse.exe with the following method.

 

   1. Download skse.exe

      2.RUN playonlinux

        3.Configure

           4.click z:

             5. navigate to miscelaneous tab

               6.run a .exe in this virtual drive

                 7. select skse.exe

 

FNIS ok I have gotten pieces of this to work intermitenly by sheer fiddlry but no perminent solution as it is dependant on an application that uses C++ and Visual studio and causes JIT complitaion errors at runtime.

 

Ive tried the following to get this to work.

 

   1. Download FNIS

       2.Extract to Data Skyrim directory

          3.RUN playonlinux

             4.Configure

                5.Navigave to install components tab

                   -install dx_9,dx_10,dx_11

                   -install directx9

                   -install dotnet40

                   -install mono28

                   -install msxml8

                   -install msvc90

                   -install physx

                          6.click z:

                             7. navigate to miscelaneous tab

                                8.run a .exe in this virtual drive

                                   9. select FNISforUsers.exe

 

as previously stated you need to have the folder structure meshes/actors/animations on the root of your z: for the FNIS program to run at all but it still appears as though it doesnt generate an .hkx files.

 

Could someone post what the FNIS program actually does when it runs and how to test if it is generating files properly.?

 

Also Im wondering if the mods only show up with skse and sky UI when the FNIS is successfull because both skse and Sky UI appear to be functioning the UI works and has all of it icons yet there is nothing under the Mod settings other than for SkyUI itself. Ive tried running SkyUI without skse and it works but there are no icons so I believe that skse's UI components are working.

 

so again what does FNIS actually do?

( is it some batch script that searches a folder for a folder and generates files based on file nomenclasure?)

 

and what does skse actually do?

(does skse just replace the original launch handler to superceed some at runtime events?)

 

WORK AROUND FOUND FOR FNIS: JAN 18 2015

 

1. get 30 day free trial of windows 7,or 8 from microsoft.com from chat with technician.

2. install windows on a virtual mach ie VM ware or virtual box

3. install skyrim on virtual box

4. copy past skyrim folder from your wine evironment into vbox skyrim

5. Run FNIS in virtual box

6. copy paste Skyrim folder back into wine skyrim install location

7. run skse

 

I will update when more stable wine libraries are available ffabris may have found a more stable library to use .

 

Ok one last bit of awesomeness I picked up a snakebyte controller for like 20$ I plugged it into my system and no GO what the Fus!...so I did some digging here is how to get that controller working and mapped out this should work for any usb wired controller.

 

   1. Install qjoypad (using this command in terminal)

     sudo apt-get install qjoypad

 

      2. RUN qjoypad "with no tray for setup" (using this command in terminal)

       qjoypad --notray

 

Im attaching a picture of my joypad settings as its kind of confusing to figure out the button numbering terminal says something different then the UI does so it took some playing around...lol

Attached File  qjoypadsettings.png   97.43KB   20 downloads

 

I hope I helped someone

-THE KRIMZONGHOST STRIKES AGAIN!


Edited by thekrimzonghost, 18 January 2015 - 09:57 PM.


#2
wernervw

wernervw

    Journeyman

  • Members
  • Pip
  • 24 posts

Hi, can launch skse loader.exe with playonlinux and i can play the game. I even see skse version number when i push escape in game. But script don't work. Can you help me on this please?

 

Thank you very much.

 

Best regards.



#3

    Enthusiast

  • Account closed
  • PipPip
  • 233 posts

First fo all, thank you SO much for having posted this - it was very helpful! Especially when combined with the step-by-step in this.

 

I'm stuck with FNIS, however. It starts fine, but when I try to generate, I get an error: "ERROR(5): Procedure call or argument is not valid." The FNIS docs say Error 5 is:

 

(Access denied): You have to run as Administrator. Right-click on the Generator (in in Explorer, or on the desktop Link) and click "Run as Administrator".

 

No idea how to do that in POL. Suggestions appreciated.



#4

    Enthusiast

  • Account closed
  • PipPip
  • 233 posts

Aha - found this. So now to find a legit scrrun.dll that isn't a virus/trojan. :-|



#5

    Enthusiast

  • Account closed
  • PipPip
  • 233 posts

OK, so that soultion failed: FNIS crashes on start.

 

[Added;] I got a different lib, and that works. I think. The first was from a Win7 64-bit, but taken from the System32 folder; the second, which worked, was from a Win7 32-bit.

 

(And yes, I am talking to myself here....)



#6
thekrimzonghost

thekrimzonghost

    Journeyman

  • Members
  • Pip
  • 46 posts
Ok sorry I havent been around I've been nearly dead from bout after bout of spinal surgery....Im glad this helped somewhat I found out that if you copy paste your skyrim folder to a virtual machine running windows with skyrim installed and run FNIS in a windows virtual environment and copy paste your Skyrim folder back to your linux wine Skyrim install location that everything works just fine...What Lib did you use ffabris?

Edited by thekrimzonghost, 18 January 2015 - 09:50 PM.


#7

    Enthusiast

  • Account closed
  • PipPip
  • 233 posts

No sorry needed - I hope you're much improved now!

 

I wanetd to avoid the VM route since that would imply actually owned a copy of Windows, which I don't, and rather not invest in for one game. ;-)

 

As for the lib: scrrun.dll from a Win7 32-bit install. I asked a friend for a copy.



#8
thekrimzonghost

thekrimzonghost

    Journeyman

  • Members
  • Pip
  • 46 posts
You can get a free 30 day trial of windows from a microsoft.com chat technician as an .Iso image that can be mounted.


#9
thekrimzonghost

thekrimzonghost

    Journeyman

  • Members
  • Pip
  • 46 posts

I tried the scrrun.dll rout and it didnt work for me can you leave the steps I'll add them to this guide with your name attached.

 



#10

    Enthusiast

  • Account closed
  • PipPip
  • 233 posts

I linked to the steps above:

http://forums.nexusm...37#entry7189182

 

meantime, I have managed to screw ip my skyrim install totally, somehow ... it won't go past the inial "shield" (meaning, I don't see the menu with New, coninue, etc). Bleah... time to reinstall it I guess.







Also tagged with one or more of these keywords: skyrim, ubuntu, linux, playonlinux, mods, fnis, skse, wine, os, mod

IPB skins by Skinbox
Page loaded in: 1.103 seconds