Jump to content

Photo

Project ENB Color banding / Dither

enb project enb climates of tamriel cot color banding dither

  • Please log in to reply
5 replies to this topic

#1
514Y32

514Y32

    Enthusiast

  • Members
  • PipPip
  • 100 posts

Hi everybody,

I have some bad "color banding" in the night, with Project ENB (Realistic) & Climates of Tamriel + Climates Of Tamriel - Weather Patch (Night Level 2).

(Only using these mods for troubleshooting so no other mods activated)

Here are 3 screenshots showing the issue (click to enlarge):

Attached File  Skyrim_ColorBanding_01.jpg   53.41KB   25 downloadsAttached File  Skyrim_ColorBanding_02.jpg   47.58KB   21 downloadsAttached File  Skyrim_ColorBanding_03.jpg   48.22KB   15 downloads

The color transition should be smooth like on the left of this illustration, but due to color banding it looks like the picture on the right :

 

Attached File  Colour_banding_example01.png   24.7KB   19 downloads

If you don't know what the problem is, here is what I'm talking about.

It is only visible on a computer's monitor, I can't see the issue on a mobile screen (But I don't think it is a screen issue as I tried with different computer screens)

By the way, I don't have this issue with other ENBs like Realvision for example, and I have calibrated the brightness value as said by the ENB's author.

 

Anyway thank you for reading this;

And thanks in advance for any help you can provide :blush:

 

514Y32


Edited by 514Y32, 03 November 2014 - 01:18 PM.


#2
prod80

prod80

    You can see more when you close your eyes

  • Supporter
  • PipPipPipPipPip
  • 5,694 posts

So you make nights to turn off your monitor and then complain you get banding. Consumer monitors do not have the Dynamic Range to do such things nicely. Also Skyrim lighting system isn't build for such things. RealVision is much brighter, heck even Project ENB is brighter than your screenshots, so likely you turned down ENB lighting to your taste.

 

BUT, I don't have banding on your screenshots at all. How about you visit http://www.lagom.nl/lcd-test/ and calibrate your monitor, pay special attention to black level calibration (0 should be black, 1 should be just a very very very tiny bit brighter) that should help.



#3
514Y32

514Y32

    Enthusiast

  • Members
  • PipPip
  • 100 posts

Thanks for the reply, but as I said, the ENB settings are "vanilla" I didn't touch anything.
I've just set the Skyrim Brightness settings "all the way down" like the author said.
Without this, I don't have banding at all.

The dark night level is due to CoT Weather Patch NL2 recommended by the author and listed above.

 

And by the way, Realvision was as dark as this, but without banding, because I used the Night Level 3 recommended by SkyrimTuner.

I think this is due to the fact that Project ENB needs Skyrim's brightness "All the way down"

 

I'll look at your link when home.

 

EDIT: I looked at your link and my monitor is perfectly calibrated.

When using default Brightness Setting (Skyrim), there's no banding, it only appears if I set it all the way down.


Edited by 514Y32, 04 November 2014 - 09:51 AM.


#4
prod80

prod80

    You can see more when you close your eyes

  • Supporter
  • PipPipPipPipPip
  • 5,694 posts

Project ENB doesn't recommend any Night level, actually it's not tuned for Weather Patch NL (I'm author of Weather Patch). So try using it without Weather Patch and then view nights. I have changed how nights look like lighting wise but Project ENB has not adapted to those changes... So not disable the NL plugin, disable the entire weather patch instead... open up game and wait 24h, then check again.

 

RealVision has adapted to weather patch fully, so it has no problems with the lighting changes at night.



#5
514Y32

514Y32

    Enthusiast

  • Members
  • PipPip
  • 100 posts

You confirm what I thought, although it seemed to me that Project ENB was compatible with Night Levels, as the description says :

"The nights options are not required, but choose wisely or else you'll probably be eaten by wolves at night! :D"

 

Skyrim's engine really don't like dark brightness levels (ENB Brightness=... in [COLORCORRECTION] and Skyrim fGamma=... )
 

I'll try to tweak it to make them compatible;

Anyway thank you for you replies :blush:

 

514Y32


Edited by 514Y32, 04 November 2014 - 07:52 PM.


#6
prod80

prod80

    You can see more when you close your eyes

  • Supporter
  • PipPipPipPipPip
  • 5,694 posts

Yes, it's compatible with CoT original night levels, but not with mine... so you should raise ambient and direct light intensities which will probably fix it. Try without weather patch first so you have a good idea how it looks normally before starting to tweak. Should not be too hard to make them compatible.

 

Enjoy ;)


Edited by prod80, 04 November 2014 - 09:19 PM.






Also tagged with one or more of these keywords: enb, project enb, climates of tamriel, cot, color banding, dither

IPB skins by Skinbox
Page loaded in: 1.049 seconds