Jump to content

Photo

"Object Fade" Setting & Random Stuttering (on powerful PC)

stutter cell loading vanilla object fade distant object detail ini microstutter skyrim annoying

  • Please log in to reply
55 replies to this topic

#1
njkilleen

njkilleen

    Newbie

  • Members
  • Pip
  • 12 posts

Here we go, the forty bagillionath stutter-related thread.

I recently rebuilt my gaming PC. After getting everything in place and booting up the game, I found that it has a rather strange intermittent stutter. I hesitate to call it micro-stutter as I know that exact terminology is a little fuzzy, but instances of it are definitely not longer than a quarter of a second... if even that long at all. Most consistently it seems to occur when (I would assume) the game is loading a new cell or pulling textures and various objects from the hard drive. If I were to walk down the road from Helgen to Riverwood multiple times, it would occur in almost exactly the same places each time. Keep in mind, this is not a game-breaking issue by any means, its just a little bit of an annoyance given the time and money I put into my new computer.

 

The funny thing is, I had a similar issue with my last computer. The stutter was much more pronounced, however, and I fixed it completely by reformatting the computer and doing a clean installation of my graphics drivers. But this time I've tried... pretty much every stutter-related solution so far. Vsync on/off. Forcing Vsync with external applications. Limiting the frame rate to 60/59/58. Enboost (with various settings). Skyrim Memory Patch. Reverting to completely vanilla Skyrim with absolutely no mods installed. Reformatting my computer again and making sure all of my driver's were good to go. You name it, I've probably done it.

The issue does get more noticeable the more texture mods I pile into the game, but it most certainly is present in Vanilla as well. My GPU has 4GB of VRAM, so I don't think that is the problem.

 

After all this, I was resolved to simply call it a fundamental issue with Skyrim's rather... quirky engine. None of my other games were doing this. About to give up, I reverted everything to Vanilla and set all of the game settings to 'Low.' Boom, stutter gone. Curious, I began raising individual settings back to Ultra and found - after some trial and error - that the settings causing stutter were, without a doubt, "Object Fade" and "Distant Object Detail." Pulling those to Low eliminates the issue.

All of this is to say:  I'm am fully aware that Skyrim's engine has its optimization and memory issues. I must ask, however, are there any INI tweaks (or any other solutions) that would allow me to retain Ultra (or at least decently high) settings for Object Fade / Distant Object Detail without re-introducing stutter? I've seen many forums with people describing things like iMaxAllocatedMemoryBytes and iPreloadSizeLimit along with other things. I've also seen conflicting posts saying its a bad idea to mess with those settings. I have not changed the uGrids value, not have I done any major INI shenanigans on my own. Like I said, the stuttering happens in Vanilla.

My specs:
Intel i7 - 4790K
Gigabyte GA-Z97X-SLI Mobo

Asus Strix GTX 970 4GB

OCZ Agility 240GB SSD (that Skyrim is installed on)

16GB G.Skill DDR3 Ram
(Nothing is overclocked)


Edited by njkilleen, 06 February 2015 - 04:58 AM.


#2
njkilleen

njkilleen

    Newbie

  • Members
  • Pip
  • 12 posts

A little update:

It looks like the another thing that does make a difference is adding "iFPSClamp=60" under the [General] section in the Skyrim.ini.  This seems to virtually eliminate stutter entirely. The pretty significant downside to this approach is that if the FPS ever drops below 60 the game engine "slows down" making everything seem to go into slow motion. From what I've read, it seems that this setting 'locks' the game engine to the number you place after it. Go below it and you go into slow motion, go above (which isn't possible with Vsync and a 60hz monitor) and you go into fast motion.

Because this setting had such a strong impact, it seems likely Skyrim's stuttering is a problem inherent to the engine.

Still, if there is anyone else out there with fixes that I could apply, I'd be grateful.



#3
Reynard131

Reynard131

    Old hand

  • Members
  • PipPipPip
  • 533 posts

Here we go, the forty bagillionath stutter-related thread.

I recently rebuilt my gaming PC in such a way that it should have no problem absolutely destroying Skyrim. After getting everything in place and booting up the game, I found that it has a rather strange intermittent stutter. I hesitate to call it micro-stutter as I know that exact terminology is a little fuzzy, but instances of it are definitely not longer than a quarter of a second... if even that long at all. Most consistently it seems to occur when (I would assume) the game is loading a new cell or pulling textures and various objects from the hard drive. If I were to walk down the road from Helgen to Riverwood multiple times, it would occur in almost exactly the same places each time. Keep in mind, this is not a game-breaking issue by any means, its just a little bit of an annoyance given the time and money I put into my new computer. Apart from this, my game maintains 60fps 99% of the time.

 

The funny thing is, I had a similar issue with my last computer. The stutter was much more pronounced, however, and I fixed it completely by reformatting the computer and doing a clean installation of my graphics drivers. But this time I've tried... pretty much every stutter-related solution so far. Vsync on/off. Forcing Vsync with external applications. Limiting the frame rate to 60/59/58. Enboost (with various settings). Skyrim Memory Patch. Reverting to completely vanilla Skyrim with absolutely no mods installed. Reformatting my computer again and making sure all of my driver's were good to go. You name it, I've probably done it.

The issue does get more noticeable the more texture mods I pile into the game, but it most certainly is present in Vanilla as well. My GPU has 4GB of VRAM, so I don't think that is the problem.

After all this, I was resolved to simply call it a fundamental issue with Skyrim's rather... quirky engine. None of my other games were doing this. About to give up, I reverted everything to Vanilla and set all of the game settings to 'Low.' Boom, stutter gone. Curious, I began raising individual settings back to Ultra and found - after some trial and error - that the settings causing stutter were, without a doubt, "Object Fade" and "Distant Object Detail." Pulling those to Low eliminates the issue.

 

Okay, cool, so I can play Skyrim with HD Texture packs, Ultra Vanilla settings, and awesome lighting mods... but to play without stutter rocks are gonna have to appear six feet in front of my character. Seems a little strange to me.

All of this is to say:  I'm am fully aware that Skyrim's engine has its optimization and memory issues. I must ask, however, are there any INI tweaks (or any other solution) that would allow me to retain Ultra (or at least decently high) settings for Object Fade / Distant Object Detail without re-introducing stutter? I've seen many forums with people describing things like iMaxAllocatedMemoryBytes and iPreloadSizeLimit along with other things. I've also seen conflicting posts saying its a bad idea to mess with those settings. I have not changed the uGrids value, not have I done any major INI shenanigans on my own. Like I said, the stuttering happens in Vanilla.

My specs:
Intel i7 - 4790K
Gigabyte GA-Z97X-SLI Mobo

Asus Strix GTX 970 4GB

OCZ Agility 240GB SSD (that Skyrim is installed on)

16GB G.Skill DDR3 Ram
(Nothing is overclocked)

 

 

 

In your NV video driver settings.

 

Manage 3D settings

 

Global Settings tab

 

Multi-display/mixed-GPU acceleration : change from  Multi-Display peformance mode to Single display performance mode. If you only have one monitor

 

Power management mode : change from adaptive to Prefer maximum performance.

 

 

Save and Exit... 

 

Where is your pagefile located ? and the size etc. ?



#4
njkilleen

njkilleen

    Newbie

  • Members
  • Pip
  • 12 posts

Thanks for the response. Changing both of those settings in the NV Control Panel doesn't seem to have had an effect.

 

I have not changed any settings involving the page file since installing Windows on this computer. According the stuff in System Properties --> Performance Options --> Virtual Memory it is located on my C Drive (SSD) and is 'System Managed.' The 'automatically manage paging file size' check box is ticked, and most of the settings are grayed out.

Is there something I could change?



#5
Reynard131

Reynard131

    Old hand

  • Members
  • PipPipPip
  • 533 posts

Thanks for the response. Changing both of those settings in the NV Control Panel doesn't seem to have had an effect.

 

I have not changed any settings involving the page file since installing Windows on this computer. According the stuff in System Properties --> Performance Options --> Virtual Memory it is located on my C Drive (SSD) and is 'System Managed.' The 'automatically manage paging file size' check box is ticked, and most of the settings are grayed out.

Is there something I could change?

 

 

 

 

 

Microsoft recommends that it is off the C:\ drive.

 

Control Panel/ System/ Advanced settings/ Advanced tab/ Performance/ Advanced tab/ Virtual memory

 

1 x physical RAM Min. 1.5 x physical RAM Max.

 

Save and reboot,      See if helps.



#6
njkilleen

njkilleen

    Newbie

  • Members
  • Pip
  • 12 posts

Unfortunately that doesn't seem to have made much of a difference either.

Any other ideas?



#7
KimberJ

KimberJ

    Bipolar Gemini

  • Banned
  • PipPipPip
  • 917 posts

Toms hardware found graphical lag tied to i7 hyperthreading, or hyperthreading in general.  Though micro stutter was tied to input lag in the old games.  I think it's only adjusted via max pre-rendered frames.  There's a difference between stutter an micro-stutter  That being said I got micro stutter running Skyrim at 30 fps on a EVGA 570 GTX.  It's like a 560ti with 4Gb of Vram.  All that being said I don't really give a crap about it.  You know not enough to attempt to fix it.  I see it walking down the hill outside solitude.  Just around grass that is animated.

 

I tell you this though if I had your video card I wouldn't bother with this crap, I'd be learning about ENB an how to set one up, an you prolly won't run 60 FPS or ultra using those.  The trade off being using more advanced rendering tech that typically goes un-used due to the power requirements.  That all depends though, I mean even if your card would run a ENB at 60 FPS I probably wouldn't run it at that just to keep the heat down.  Just to make the card last.  That being said most of the advanced render stuff heats up no matter what.


Edited by KimberJ, 15 January 2015 - 06:46 AM.


#8
KimberJ

KimberJ

    Bipolar Gemini

  • Banned
  • PipPipPip
  • 917 posts
At least what I saw was tied to animated grass, it's not like that everywhere, so it could be localized, which I'd check that.

*edit*


I saw This mod which might fix it...

#9
njkilleen

njkilleen

    Newbie

  • Members
  • Pip
  • 12 posts

Some experimenting with Skyrim Performance Monitor has shown that the 'stutters' undeniably coincide with moments of increased Disk I/O activity. It doesn't happen on all cell borders, nor does it always happen on cell borders, but when it does happen it is clearly the game loading 'something.'

 

Attached File  stutters.png   21.1KB   18 downloads

It would seem that this stuttering is less an issue with my hardware, and more a fundamental part of the game engine that was harder to notice with the lower frame rates I was getting before. Now, when the frame rate is consistently at a monitor's refresh rate, it would seem that tiny perturbations like load stutter are significantly more noticeable. It's like being able to easily spot a ripple in a still pond versus a ripple in a flowing river.

Still, I'm genuinely curious if there is a way to lessen the stuttering. I'm not the kinda person to just give up on something like this. I keep seeing solutions with people who say they have a 'butter smooth' skyrim... and its got me wondering if its actually possible.

Turning off Hyperthreading is an interesting idea. I'm not entirely sure how it would help, but I'll give it a shot. 


Edited by njkilleen, 16 January 2015 - 09:35 AM.


#10
njkilleen

njkilleen

    Newbie

  • Members
  • Pip
  • 12 posts

Disabling Hyper threading didn't seem to change anything.

It would seem that the lower the Texture Quality setting the less pronounced (and common) the stutters are. This includes the enabling / disabling of Texture mods. That makes sense, the higher the resolution the texture the more data that needs to be loaded from the drive as the game loads new stuff. At least, that's what I think is going on.

Still, the only setting that completely eliminates it is 'Object Fade.' At minimum, its gone - regardless of anything else.

I feel like I might just be going crazy at this point.







Also tagged with one or more of these keywords: stutter, cell loading, vanilla, object fade, distant object detail, ini, microstutter, skyrim, annoying

Page loaded in: 1.119 seconds