Jump to content

Photo

Dragons stuck in 't-pose' like thing?

dragon animation skelenton pose tpose static stuck

  • Please log in to reply
5 replies to this topic

#1
piperman123

piperman123

    Old hand

  • Members
  • PipPipPip
  • 687 posts

For some reason every dragon I spawn is stuck in a static pose, wings spread out mouth open etc. they fly around and attack but they won't animate. Any ideas what's wrong? I'm spawning them at the start of the game (using Live Another Life so I'm passed helgen) if that makes a difference. Also, I've gone to helgen to watch alduin fly past and his animation is on and off but any dragon I spawn just won't use any animations at all.

 

Disabling all the dragon mods I'm using makes no difference. I've also tried re-running FNIS, just in case, no luck. Any help would be brilliant. I don't think my load order is necissary as, like I said, I've disabled all my dragon mods and SkyTest but if you think it will help I'll add it and anything else that might be useful.



#2
fore

fore

    behavior mudcrab

  • Premium Member
  • 12,443 posts

Did you ever have a dragon animation mod using FNIS? I don't know any except FNIS Zoo. But if you ever had, you should have pressed the FNIS "De-Install Creatures" button once before you uninstalled the Creature Pack.

 

But simply look in the actors/dragon folders. Remove every .hkx file you find there. Especially the ones in behaviors, and the skeleton.

 

If there are none, then this is not an animation/behavior problem. I recommend checking the ReAnimate mod/tool.



#3
piperman123

piperman123

    Old hand

  • Members
  • PipPipPip
  • 687 posts

Thanks for the reply fore. I checked my meshes/actors/dragon folder and the only .hkx files were some waterdive ones added by dawnguard in dragon/animations/dlc which I'm guessing are supposed to be there? I've also not used FNIS Zoo, at least not with this profile (Using Mod Organiser) so none of it's files should be there. I think I may have used the creatures plugin for FNIS at some point but seeing as there's no .hkx files there I'm guessing it's not the issue like you said?

 

I'll try getting rid of the mods mentioned on the ReAnimate page just to see if they are causing it and then try that mod, thanks for the help.

 

EDIT: Yeah just checked my FNIS files and the only file it adds is Meshes/character/* so not an animation thing then. So looks like this ain't going to be an easy fix.

 

EDIT 2: Ok, tried disableing all dragon, creature and AI mods which didn't fix it. I then tried using the ReAnimate mod which reset the dragons after a minute or so of them flying around in their static t-pose-ness and then they'd either stay on the floor and not move about but use their animations or glitch and fly around in their standing animations which was really wierd, also their wings were a bit shaky and just not quite normal.

 

So I'm at a loss, only thing I can think of is that either something has gone missing from my base game which I really hope isn't the case as redownloading Skyrim will take me days or spawning dragons before the quest which brings them into the game makes them all glitchy? I don't think the latter is the case but I'm lost for ideas so...

 

EDIT 3: Tried again with absolutley no AI, Dragon or Creature Mods and spanwing the 'dragon' FF000ABC and it's a mess, they all start off with the static tpose thing and then after a bit they reset thanks to ReAnimate and do one of several things:

  • Sit there with no visable AI, motionless except for when they watch me or other things moving (they are animated just not moving from that spot).
  • Fly around with animations that stop and start irratically such as wings might stop when they flap down and get stuck in that pose or vise versa.
  • Fly around stuck in their walking animations.
  • Fly through floors, mountains etc.

So, anyone have any ideas?


Edited by piperman123, 26 January 2015 - 04:25 PM.


#4
piperman123

piperman123

    Old hand

  • Members
  • PipPipPip
  • 687 posts

Still not been able to get any further with this, does no one have any more ideas as to what might be going on? Even if someone can let me know if spawning dragons before they start spawning in the game causes issue like this or if they should work fine regardless would be a great help.


Edited by piperman123, 27 January 2015 - 07:49 PM.


#5
piperman123

piperman123

    Old hand

  • Members
  • PipPipPip
  • 687 posts

Wow, that was annoying. After spending ages messging with these mods, redownloading vanilla, changing my ini files, getting dragon animation mods, animation fixing mods, playing through the anoyingly long intro of a totally vanilla game and loads of other things I found out what the issue was. The damned TLC command that turns collision off! I was using it and the TGM so I could test all my dragon mods and after still having the issue in a tottally vanilla, completely fresh game I thought I'd try toggling that after spawning a dragon with the same issue. And what do you know, TLC affects dragons as well as the player?!  >.<

 

So, there you go. Incase anyone else has this issue.



#6
ZechromEZ

ZechromEZ

    Stranger

  • Members
  • Pip
  • 1 posts

bro you did it, thank you. i was having the same problem and its hard to find your answer. 







Also tagged with one or more of these keywords: dragon, animation, skelenton, pose, tpose, static, stuck

IPB skins by Skinbox
Page loaded in: 1.067 seconds