Jump to content

Photo

Follower custom voice not working

custom follower custom voice unique voice

  • Please log in to reply
2 replies to this topic

#1
anonimus94

anonimus94

    Stranger

  • Members
  • Pip
  • 2 posts

Hi all.

First of all, some backstory time.
I wanted to make a custom, voice acted follower. Having some, but not nearly enough CK experience I went searching for a tutorial and found one. ( http://deck16.net/po...n-skyrim-part-1) . So I started " developing" ( I guess? ) and everything was going fine. After a day the character had complete follower functionality and all responses and dialgue ( idles, combat voiceover, complete follower responses, general random comments, everything... ) was finished except a unique conversation ( by that I mean real conversations that you can have with the follower) . So, my next step was to expend on that A LOT, and create conversations which is why I decided to test this first extensively.

Long story short the tutorial suggest copying (duplicating) premade dialogues for follower funcionality and just changing getisid and the voice obviously. And due to the tutorial being old it was editting the file with the " *" by it, which was correct at the time I guess, but now one of the 2 files is the original ( duh! ) and the duplicated one has everything except the original voice over and guess which one I was edditing. Yeah... So I discovered that Mjoll was broken as a follower which I didn't mind very much but I intend to share the mod so... we can't have that. Tried to fix it which, of course, made it worse so I decided to start over.

IMPORTANT! This follower worked with absolutely no problems with main menu coc to his cell and on multiple ( different) characters. The only thing that I had to do was save and load in front of him once ( Dialogue bug) an voila!
Details: no seq, audio files in .wav
 

Now the utterly annoying bit. I reinstalled Skyrim ( so that I don't have to mess around while archiving and avoid any " may have been" bugs) and started from scratch. Did everything completely identical as the first time. And I hit my first testing milestone ( + means done) actor+ , custom voice+ , player relationship+ , cell placement+ and dialogue quest with a few greetings lines. Went into the game to test it and no dialogue.

TRIED:
- thousand reinstalls
- a million starts from scratch
- save/ load a billion times

- multiple different cells

- multiple saves

- tried with cleaned/ uncleaned masters

- multiple actor races

- generating a .seq via tes5edit

- generating a .seq via CK

- converting .wavs to .xwms
- different dialogue quest priorities and types

- skyrim.esm + update.esm as masters, just skyrim.esm as master

- with and without SKSE

and all imaginable variations of the things stated above.

 

DETAILS:
- custom voice set in actor traits
- dialogue quest linked with getisid on subject to actor

- voice over plays with no problems in CK
                  - .wav, 16bit, 44100Hz, mono
- not archived in any way, the files are loose with the correct file structure
                  - data\ sound\ voice\ modname\ voicename\ : here:

- vanilla game for testing and creation

To me this looks as if the voice files are not linked to the voice correctly but that makes no sense because it works in CK ( not by clicking on preview but by dubble clicking the sound file) .

Any help is APPRECIATED IMMENSELY.
Thanks in advance,
Z

 


Edited by anonimus94, 28 February 2015 - 08:03 PM.


#2
DanBlaire

DanBlaire

    Newbie

  • Members
  • Pip
  • 11 posts

I followed that same tutorial and ended up with the same problem, only I managed to break J'zargo instead of Mjoll. If anyone knows of a way to fix this issue without me having to redo the entire follower, I would appreciate it. Everything else seems to work for my follower, except all the dialogues I copied from J'zargo. Now options such as "It's time for us to part ways" work neither for J'zargo or my follower.



#3
Thurkar

Thurkar

    Stranger

  • Supporter
  • Pip
  • 2 posts

I know this post is from 2015 but I leave this message here for posterity.

 

I have spent the last 3 days following one video tutorial after the other, reading one guide after the other about creating a custom voiced follower.

 

Everything would go smoothly as long as I used the default voice type, but as soon as I got to creating my own voice type, my character would never say "Hello" to me. I tried everything, and was as desperate as OP. The files were there, in the correct folder, everything was exactly as instructed, it SHOULD work, but my character would just shake his arms and not utter a sound.

 

Today out of desperation I re-installed Skyrim (once more...) but on another drive (D:\ rather than C:\) and I deleted the folder Documents\My Games\Skyrim. I then re-installed the CK and proceeded to immediately re-create my follower. Used the launcher to detect quality, checked that the .esp was loaded, coc whiterun, save, load save, coc whiterunbanneredmare and finally, after 3 days of trying and doing the exact same thing, it worked. Was it the different drive ? Was it the Documents\My Games\Skyrim folder ? I don't know, all I know is that my follower SPEAKS FINALLY !

 

TL;DR : Reinstall but this time on another drive and delete Documents\My Games\Skyrim too.







Also tagged with one or more of these keywords: custom follower, custom voice, unique voice

Page loaded in: 1.123 seconds