Jump to content

Photo

EAX difficulties


  • Please log in to reply
12 replies to this topic

#1
oc3

oc3

    Fan

  • Premium Member
  • 418 posts
I have installed the Oblivion EAX mod and Sides EAX control. Also installed Creative Labs ALchemy to make it work in Vista. The directional sound is now working very well and sounds seem to fade in and out based on distance, however, there seem to be no noticeable EAX effects. Following the readme in the EAX mod, I tried using the console commands it suggested to check out a couple of 'cool' effects but nothing seemed different. I tried the "initeax" command and some others but I never got any indication that it was working. I would have expected a message saying EAX enabled or something. What am I doing wrong? Do I need to do something to Sides EAX control to get EAX to function? I have tinkered with various settings in the Tuning fork menus, but nothing sounds any different. Thanks.

#2
Hickory

Hickory

    Indigenous species

  • Premium Member
  • 8,422 posts
In your oblivion.ini make sure of the following settings:

bDSoundHWAcceleration=1
bUseSoftwareAudio3D=0

#3
oc3

oc3

    Fan

  • Premium Member
  • 418 posts

In your oblivion.ini make sure of the following settings:

bDSoundHWAcceleration=1
bUseSoftwareAudio3D=0


thanks, I will give it a try as soon as I can. I know for sure the software3d setting is enabled so hopefully that is it.

#4
oc3

oc3

    Fan

  • Premium Member
  • 418 posts

In your oblivion.ini make sure of the following settings:

bDSoundHWAcceleration=1
bUseSoftwareAudio3D=0


I set bUseSoftwareAudio3D=0. Still no change in sound. No reverb or echo effects at all. EAX works inside of the the soundblaster control panel, but not in the game. I have the EAX.dll inside of the obse\plugins folder. ALchemy is set to recognize Oblivion. None of the console commands mentioned in the readme seem to have any effect and none of them give any on screen messages. That's all of the clues I can think of to help you out. Also, temporarily, I have disabled all other mods, so it's not a conflict.

Using Audigy SE and Vista 64. Game installed to C: games\Oblivion. Running everything as admin.

Thanks for helping.

#5
Hickory

Hickory

    Indigenous species

  • Premium Member
  • 8,422 posts
Ok, I was intrigued by this -- I normally use Soundscaper -- so I installed it, and also couldn't tell the difference. However, after playing with the tuning fork for a while, found that it does indeed make a difference, but I couldn't make it consistent. For an extreme effect (so you can hear that it works) set the effect volume to -100. Like I said, I couldn't get a consistent result (YMMV). I think I'll stick to Soundscaper.

Edit: You can set your preferences in the ini file, but make sure you use valid values.

#6
oc3

oc3

    Fan

  • Premium Member
  • 418 posts

Ok, I was intrigued by this -- I normally use Soundscaper -- so I installed it, and also couldn't tell the difference. However, after playing with the tuning fork for a while, found that it does indeed make a difference, but I couldn't make it consistent. For an extreme effect (so you can hear that it works) set the effect volume to -100. Like I said, I couldn't get a consistent result (YMMV). I think I'll stick to Soundscaper.

Edit: You can set your preferences in the ini file, but make sure you use valid values.


Thanks Hickory. Maybe I'll try soundscaper. Do you like it pretty well?

#7
Hickory

Hickory

    Indigenous species

  • Premium Member
  • 8,422 posts
I run Soundscaper alongside Atmospheric Oblivion and Storms and Sounds, and they suit me fine, but I don't get the extreme EAX effects with Soundscaper that Side777 mentions in his description. Remember that Soundscaper requires You Are Here.

#8
oc3

oc3

    Fan

  • Premium Member
  • 418 posts

I run Soundscaper alongside Atmospheric Oblivion and Storms and Sounds, and they suit me fine, but I don't get the extreme EAX effects with Soundscaper that Side777 mentions in his description. Remember that Soundscaper requires You Are Here.



Thanks again.

#9
jaime74

jaime74

    Faithful poster

  • Premium Member
  • 1,110 posts
Unfortunately, I am facing exactly the same issues as oc3, having tried exactly the same to solve the problem (at least I think so):

- installed a new Soundblaster Titanium Fatal1ty audio card
- tested new audio ingame (without EAX), successfully
- enabled (and tested) EAX presets in the Soundblaster Console Launcher
- enabled EAX (choosing preset "none")
- installed OblivionEAX and Side's EAX effects (including Data\Side's EAX Control.esp (activated!), Data\OBSE\Plugins\OblivionEAX.dll and Data\Ini\Side's EAX Control.ini)
- added Oblivion to ALchemy's list of "ALchemy-enabled games"
- ensured that both Oblivion.ini settings mentioned above (bDSoundHWAcceleration=1, bUseSoftwareAudio3D=0) are correct
- ran whatever console test command I could find in OblivionEAX's and side's readmes ("initeax", "initializeEAX", "seteaxenv -1 25", "seteaxroom -1 -10000", "seteaxrrof -1 1", "seteaxrrof -1 0", "enableEAX", "SetEAXenv -1 10", ...)

But I haven't heard any difference!
The only thing I notice is that once Oblivion has been added to ALchemy, any ingame sound appears much more "dull" and indirect (i.e there at least some effect, but it's definitely not EAX, but simply a loss of quality and high frequencies, with no reverb at all).

I am running Oblivion on Windows 7 since several weeks. Before that, on WinXP, EAX was running fine with my "old" onboard Realtek HD Audio.
I haven't changed the game setup (except for temporarily disabling and then reactivating EAX).

I'd be really glad about any help on this, because it's quite frustrating having bought a fancy new audio device (especially because of the EAX support), and then not getting it to work... :(
Thanks a lot!!

P.S.: Just detected something new that might be important:
After activating ALchemy for Oblivion, I know have a file called dsound.log in my Oblivion directory, which contains the following output:
Logging Time : 29/4/2011 at 22:04:56

Loaded C:\playground\Oblivion\DSOUND.ini

Failed to init OpenAL

Using Creative Software 3D Library
Failed to init OpenAL
Failed to init OpenAL
Failed to init OpenAL
...
Any idea, why my OpenAL doesn't seem to initialize??

The dsound.ini (mentioned in the log) reads as follows:
Buffers=4
Duration=25
MaxVoiceCount=128
DisableDirectMusic=0


#10
jaime74

jaime74

    Faithful poster

  • Premium Member
  • 1,110 posts
Alright, I need to recall: Problem solved!

In short terms: I wasn't running the game in Soundblaster's "Game Mode", but in "Entertainment Mode"! Switching to Game Mode immediately brought EAX back to work!
This means that ALchemy obviously needs to run in "Game Mode"! I wasn't aware of that (and hadn't found any hint about it in the docs, maybe just missed them)!

The difference can be seen clearly in the dsoundlog.txt. It now reads:
Logging Time : 29/4/2011 at 22:18:35

Loaded C:\playground\Oblivion\DSOUND.ini


Using Native OpenAL Renderer

Why I wasn't in Game Mode originally? I didn't like the initial sound settings of it (too much bass boost, too dull overall sound impression), so I tried around with the Entertainment Mode a lot.
Now that I know that I need Game Mode, I am using the EQ to create a more clear sound. This does the trick all the same.

I am happy again!
@oc3: Maybe this will help you solve your problem as well?




Page loaded in: 0.984 seconds