Jump to content

Photo

Stutter....St-st-st-t-st-stutter never changes!

frame graphics vsync fps fullscreen borderless windowed micro stutter enb

  • Please log in to reply
9 replies to this topic

#1
SooperWood

SooperWood

    Regular

  • Members
  • PipPip
  • 68 posts

Hey guys,

So I installed ENBoost (http://www.nexusmods...out4/mods/332/?) and everything worked fine, got a nice solid frame rate most of the time, but there are still problems that ENBoost didn't fix and I can't figure out hw to fix it myself;
 

I just recently managed to make my color adjustment from the NVIDIA control panel persistent, even with fullscreen gaming (before it would always turn off when starting a fullscreen appllication).
How I did it:

Spoiler

So I changed Fallout 4 from borderless to fullscreen, disabled all vsync ingame/in enblocal and forced VSync via NVIDIA control panel (tripple buffer=off, prerendered frames=1).

This made my game much smoother so dips down to 50 fps wouldn't cause stutter like they did in borderless (even after I installed ENBoost).

But then again this left me with the known bug that in fullscreen mode you get terrible microstutters (not hardware related->persistent at 60fps) when strafing/circling. 

The two fixes for this, that I found were turning to borderless (want to avoid that) which gives me an overall more 'stuttery' experience or to add the line 'iFPSClamp=60' under [General] in the fallout4.ini but a lot of people report fps bugs with that (being stuck at terminal, slowdown etc.).

So atm I'm not able to find a proper workaround using;

-RivaTuner -> capping the frames at 60 for windowed borderless -> not so smooth feeling,
-ENBoost using fpscap and or forcevsync in enblocal.ini -> same results as with RivaTuner/ingame VSync (slightly better fps than with ingame VSync),
-NVIDIA VSync (tripple buffer off, prerendered frames=1),
-ingame VSync (ipresentInterval), borderless windowed/fullscreeen mode

All got major advantages and disadvantages.


So, is somebody here able to run this game full screen without micro stutters?

 


Edited by SooperWood, 21 November 2015 - 03:05 AM.


#2
zaty1

zaty1

    Enthusiast

  • Members
  • PipPip
  • 175 posts

I did framelimiting through nvidia inspector for borderless and it had absolutely no effect. Looking at my current setup - I'm limiting to 58fps and zero stutter. I tested 59fps just now and it was ever so slightly visible. I don't know if I should chalk it up to my gpu, the game, my drivers, my old monitor (says 60hz) but even 10 years ago there was limiting to 58/59. This of course doesn't enable vsync so there is some tearing. Maybe tinkering with an extra frame in prerender will help.

 

My vsync with triple buffering on is horrible. Triple off is not as bad, but still stutters. =\



#3
SooperWood

SooperWood

    Regular

  • Members
  • PipPip
  • 68 posts

I did framelimiting through nvidia inspector for borderless and it had absolutely no effect. Looking at my current setup - I'm limiting to 58fps and zero stutter. I tested 59fps just now and it was ever so slightly visible. I don't know if I should chalk it up to my gpu, the game, my drivers, my old monitor (says 60hz) but even 10 years ago there was limiting to 58/59. This of course doesn't enable vsync so there is some tearing. Maybe tinkering with an extra frame in prerender will help.

Ok, didn't know about limiting to 58/59, I will try that. I will try to limit the frames with RivaTuner and will try out how the ENBoost forced VSync and the ingame VSync effect the performance/stutter

And somehow even with all VSyncs off I don't experience any tearing, in fact since I got my new 1080p (60Hz) monitor I never had tearing issues (unlike with my old 1600x900 59Hz monitor <- was a pain in the ass to avoid tearing for that one).

I will post my results here.

Spoiler

I will have to try out more but wil definetly stick to the NVIDIA VSync as it makes the fps drops so much less noticeable (aiming down sights and looking around at 50 fps feels like 60fps).

If anyone has more suggestions feel free to post and I will try it out ASAP.


Edited by SooperWood, 21 November 2015 - 04:21 AM.


#4
zaty1

zaty1

    Enthusiast

  • Members
  • PipPip
  • 175 posts

iPresentInterval=0

 

You are using this correct?

If you do not read only the file - if you mess with the settings in launcher it will revert that to 1.

(Unless you changed it in the steamapps\fo4 directory as well but I haven't verified if that works)



#5
SooperWood

SooperWood

    Regular

  • Members
  • PipPip
  • 68 posts

iPresentInterval=0

That's what I meant when saying 'in-game VSync'

 

You are using this correct?

If you do not read only the file - if you mess with the settings in launcher it will revert that to 1.

(Unless you changed it in the steamapps\fo4 directory as well but I haven't verified if that works)

 

I used the 'Fallout4ConfigTool to edit the .ini;
- doesn't have much options but always sets the .inis back to read-only
- has a 'Play Game' button so it's perfect for tsts like this where I switch between borderless/fulsscreen Vsync lock on/off


Edited by SooperWood, 21 November 2015 - 04:20 AM.


#6
zaty1

zaty1

    Enthusiast

  • Members
  • PipPip
  • 175 posts

Ah ok, I don't use any of that. I prefer the rawness of hand editing... :D

And this discussion caused me to google my monitor/etc - finding out it is totally capable/sold with the funcitonality of 75hz capability.

Time to bump that up a bit and tinker some more.


Edited by zaty1, 21 November 2015 - 04:44 AM.


#7
SooperWood

SooperWood

    Regular

  • Members
  • PipPip
  • 68 posts

And this discussion caused me to google my monitor/etc - finding out it is totally capable/sold with the funcitonality of 75hz capability.

Time to bump that up a bit and tinker some more.

 

"TINKER,TINKER,TINKER.... Strong bored!"



#8
zaty1

zaty1

    Enthusiast

  • Members
  • PipPip
  • 175 posts

So, the no vsync - 75hz with framelimit at 73/74 felt better - it had a different issue with it - and instead of 1 tear - multiples. Yuk.

So I returned to 60hz to mess around some more.

 

Using enblocal.ini - framelimit to 60. Vsync through nvidia - zero stutter/lag while strafing, and no tearing. Testing on 59 or 61 both gave issue. Prerender 1 - no ingame vsync.

I also tried vsync in enblocal and framelimiter through nvidia - no good even with matching settings... /boggle.

Might just be specific to my machine but I am super happy now that I can play without tearing, AND, not suffer strafe stuttering as I scavenge -.-



#9
SooperWood

SooperWood

    Regular

  • Members
  • PipPip
  • 68 posts

So, the no vsync - 75hz with framelimit at 73/74 felt better - it had a different issue with it - and instead of 1 tear - multiples. Yuk.

So I returned to 60hz to mess around some more.

 

Using enblocal.ini - framelimit to 60. Vsync through nvidia - zero stutter/lag while strafing, and no tearing. Testing on 59 or 61 both gave issue. Prerender 1 - no ingame vsync.

I also tried vsync in enblocal and framelimiter through nvidia - no good even with matching settings... /boggle.

Might just be specific to my machine but I am super happy now that I can play without tearing, AND, not suffer strafe stuttering as I scavenge -.-

Playin on fullscreen or borderless windowed?

Defintly will try your setup.



#10
zaty1

zaty1

    Enthusiast

  • Members
  • PipPip
  • 175 posts

Fullscreen







Also tagged with one or more of these keywords: frame, graphics, vsync, fps, fullscreen, borderless, windowed, micro, stutter, enb

IPB skins by Skinbox
Page loaded in: 1.190 seconds