Jump to content

Photo

Strange Behavior in using Mothership Zeta's Weapons in Fallout: New Vegas

mothership zeta import model weapon alien

  • Please log in to reply
No replies to this topic

#1
ManehattanProject

ManehattanProject

    Fan

  • Members
  • PipPipPip
  • 268 posts

Strange issue popped up last night. I recently "re-added" both the Alien Disintegrator (Rifle) & Alien Atomizer (DLC-only Pistol) weapons into New Vegas. I went through all the various weapon control material, such as damage, FOV, fire rate and all that jazz. I give them both unique names and assign the AMMOAlienBlaster list for an ammunition type. I included the 1stpersonModels and went through everything you normally do for a custom weapon. (I used the Alien Blaster sound effects as a temporarily replacement until my SFX crew gets new sound files set up)

 

Then I load up the modified .ESP and head over to my testing room. The weapons appear perfectly...but they don't have the custom names I gave them, they're requiring "Alien Power Module" and they even have the special notes "Higher Crit Chance" that they did in Fallout 3...

 

In other words, they are identical to the Fallout 3 weapons, including requiring the DLC05-only ammo.

 

I'm completely flummoxed as to how this could have happened. Is there somewhere in FalloutNV.esm where the data for the DLC05AlienPistol/DLC05AlienRifle is kept that's somehow overwriting the changes I've done? 

 

Any advice would be greatly appreciated. 







Also tagged with one or more of these keywords: mothership zeta, import, model, weapon, alien

IPB skins by Skinbox
Page loaded in: 1.077 seconds