Jump to content

Photo

Texture mods not working

bugs texture mods

  • Please log in to reply
28 replies to this topic

#11
jaeleam

jaeleam

    Stranger

  • Supporter
  • Pip
  • 1 posts

So I am fairly new to modding. Have used NMM for Fallout 4 and skyrim. I am having the same issue for some custom armor and paints not showing up. Even with mods being supported now do I still need to set up an ini file? Ive searched the files for the above referenced files and have not found any in my system Any help would be greatly appreciated. 



#12
Karnickill

Karnickill

    Stranger

  • Members
  • Pip
  • 4 posts

Ok so I've finally got mine working and I  think I've found the problem for those still having the no texture/meshes issue even after setting up their .INI files following the guide at http://wiki.tesnexus...od_Installation

 

What I found was that in addition to the three 3 .INI files in Documents/MyGames/Fallout4 that we are supposed to edit, there was also a Fallout4.INI file in Program Files (x86)/Steam/SteamApps/common/Fallout4/Data, aka the file where we install the mods. This .INI had a lot more text than the others, but what I did was Ctrl+F [Archive], and there was a line:

 

bInvalidateOlderFiles=0

 

change this to

 

bInvalidateOlderFiles=1

 

this must have been overriding the changes we made to the .INI in the documents folder. Also, a bit lower down, still under [Archive] there was a line:

 

sResourceDataDirsFinal=TEXTURES\, MESHES\,

 

change this to 

 

sResourceDataDirsFinal=

 

And now everything is working as it should on my end.


Thank you! This really helped me out!



#13
blockbuster

blockbuster

    Enthusiast

  • Supporter
  • PipPip
  • 114 posts

 

 

Exact same problem here. The items and armours all show up in the inventory but the textures/meshes aren't applying and my character is invisible.

 

I have in the Fallout4Custom.ini

[Archive]
bInvalidateOlderFiles=1
sResourceDataDirsFinal=
 
and Fallout4Prefs
[Launcher]
bEnableFileSelection=1
 
 
 
Any help much appreciated. I was also using the beta version of Fallout before the update if that may have changed something?

 

If your custom weapon/armors show up, but invisible when worn, then problem is missing texture/mesh.  90% of the time the authors on Nexus are smart enough to have the right path, all you need is to click on NMM to install.  Some new authors (by looking at the simple description), they are likely to mess up the path (and sometimes install outside of Data folder).  If your mod is the case, you have to manually install it. 

Summary: the .esp .esm are in the right location for them to show up in inventory.  But meshes, materials, textures are not there (either 1 or all 3).

 

Was no fallout4.ini in the data folder for me.



#14
StacyRect

StacyRect

    Stranger

  • Members
  • Pip
  • 4 posts

Ok so I've finally got mine working and I  think I've found the problem for those still having the no texture/meshes issue even after setting up their .INI files following the guide at http://wiki.tesnexus...od_Installation

 

What I found was that in addition to the three 3 .INI files in Documents/MyGames/Fallout4 that we are supposed to edit, there was also a Fallout4.INI file in Program Files (x86)/Steam/SteamApps/common/Fallout4/Data, aka the file where we install the mods. This .INI had a lot more text than the others, but what I did was Ctrl+F [Archive], and there was a line:

 

bInvalidateOlderFiles=0

 

change this to

 

bInvalidateOlderFiles=1

 

this must have been overriding the changes we made to the .INI in the documents folder. Also, a bit lower down, still under [Archive] there was a line:

 

sResourceDataDirsFinal=TEXTURES\, MESHES\,

 

change this to 

 

sResourceDataDirsFinal=

 

And now everything is working as it should on my end.

I checked twice there's no Fallout4.ini in there. but there was a Fallout4Pref.ini  in C:\Program Files (x86)\Steam\steamapps\common\Fallout 4\Fallout4



#15
pawheet

pawheet

    Stranger

  • Members
  • Pip
  • 8 posts

I'm having an issue getting any type of texture mods/overhauls to work. I've tried the N7 armor mod, power armor textures, WIPAG Immersive Power Armors, Pip-Boy skins, True Storms and so on. For whatever reason, the textures in these mods just don't show up. I will attempt to select the texture in the power-armor interface or spawn the N7 armor, and it just looks invisible.

 

In regards to the N7 Armor, the game registers that it exists. It goes into my inventory, I can equip it and it affects my stats. But when I put it on, it just shows my underclothes.

 

With any of the power armor skins/overhauls, I can enter the workshop for it, select the mods or textures, but the textures just don't show up.

 

Mods like the Armorsmith Extended, Craftable Armor Sizes and Legendary Modification work fine. It seems like whenever the game tries to replace textures, it just doesn't want to cooperate.

 

True Storms works ... kinda. The game will start the storm event, but it looks as if the game failed to replace the textures again. When I got a rainstorm, the rain looked like bars that you would see in "Pong" or something. It was completely devoid of textures.

 

Things like my Weapon Balance Overhaul and Mega Explosions mod work flawlessly. But mods like "Any Mod Any Weapon" don't work at all.

 

I am at a loss here, and any help the modding community here at Nexus can offer would be greatly appreciated. All of my mods are installed with NMM. I'm not really willing to install mods manually. I will attach screenshots of my NMM interface/mod order, plugins.txt, the "properties" section of my plugins.txt to show that it is no longer read-only. I have also attached screenshots of my Fallout4.ini Fallout4Prefs.ini and Fallout4Custom.ini for reference. The Fallout4 and Fallout4Prefs files have been captured on the relevant areas for modding, at anyone's request, I will screenshot other sections as well.

[SHOLVED]

 

WEAPON / TEXTURES MOD "TEXTURES AND MESHES MISSING / WEAPON IS INVISIBLE??? HEY IT SHOLVED!!!!!!"

 

Q : MY WEAPON / SUIT / VIVID TEXTURES / LANDSCAPE TEXTURES MOD i DOWNLOADED WONT APPEARS/ WORKS/ WEAPON IS INVISBLE / TEXTURES MOD FROM NEXUS WONT WORKS???? HOW DO I SHOLVE THIS PROBLEM?????

 

A : I HAVE YOUR GUYS ISSUES FOR ALMOST 4 MONTHS!!!! IT ALMOST MADE ME CRAZY DANG!!! BUT I WONT GIVE UP!! AND YEAH I SHOLVED IT !!! I DONT KNOW IT WORKS OR NOT WITH YOU GUYS, BUT I HOPE IT WORKS ALOS FOR YOU, I DO REALLY HOPE TOO, BUT DONT BULLY ME IF IT DOESNT WORK WITH YOU GUYS, SO TO THE POINT, I WILL TELL YOU HOW WAS,,,

 

 

1. Ofcourse you have to setting your "Fallout4Prefs.ini" TEXT in your MY DOCUMENT >> MY GAMES >> FALLOUT 4, this is the important thing to do at first

 

setting to :

 

[ArchIve]

bInvalidateOlderFiles=1
sResourceDataDirsFinal=

 

 

You can see how to do it more detail from Nexus, here is the link how to Enabling MOD on your Fallout 4 game
http://www.nexusmods...ut4/videos/87/?

follow the intruction Correctly :)

 

2. After you change the FalloutPrefs.INI and Fallout4.INI

Then Many people People said

 

"I dont have any problem on My mod after i set up the INI files, My MODS are works perfectly"

 

But hey, im not stop in here, There's still many people who still Stuck in their MODS become WORKS though they had setting up the INI files

 

and yes Including me, before,,,

 

So how to sholve your problem guys,,,

 

we need 1 more file from NEXUS SITE!!!

 

WE NEED "ELF - Enable Loose Files for Fallout 4"

 

But trust me guys i dont know how it works cuz i also dont know my problem too before,,,

 

but after i UNZIPED this ELF and COPIED this to my DATA FOLDER on my FALLOUT 4 game, then after I RUN / PATCHED the ELF file,,,

 

and when i RUN THE GAME,,,

 

you know what, ALL MY MODS WHO LOST THEIR TEXTURES and MESHES is WORKED PERFECTLY!!!!

 

* IT MADE MY CRAFTING MOD like [WEAPONSMITH, CRAFTING BULLET WORKBENCH, CWSS REDUXE/ everything about Crafting MODS] BECAME WORKED!!!!

** IT MADE MY MOD WEAPON like [STAND ALONE WEAPONS, MURDERING CHAINSAW, LIGHT SABER!!!! uhh i love it] BECAME WORKED!!!!

*** IT MADE MY VIVID LANDSCAPE, WEATHER, ROCK and ROADS, BRIDGE, WATER MOD BECAME WORKED!!!!

 

so guys Try this one "ELF - ENABLE LOOSE FILES" for fallout 4 :

 

Here is the link of ELF :

 

http://www.nexusmods...ut4/mods/4020/?

NOTE : SO GUYS I HOPE YOUR MODS WORKS TO AS ME, I DO REALLY HOPE WE HAVE THE SAME HAPPINESS TO DO MODDING IN FALLOUT 4!!!

 

AND IM SORRY ABOUT MY ENGLISH IF BAD hahahaha, Cuz i from Indonesia,,, :D

 

OKAY GUYS TRY IT, AND LEAVE A COMMENT ON ME, SO I CAN KNOW YOURS TOO!!!!

 

KEEP SMILE !!! :)



#16
pawheet

pawheet

    Stranger

  • Members
  • Pip
  • 8 posts

Mate, i'm having exactly the same problems. Unfortunately, still haven't found a fix.  Best ofluck =D

[SHOLVED]

 

WEAPON / TEXTURES MOD "TEXTURES AND MESHES MISSING / WEAPON IS INVISIBLE??? HEY IT SHOLVED!!!!!!"

 

Q : MY WEAPON / SUIT / VIVID TEXTURES / LANDSCAPE TEXTURES MOD i DOWNLOADED WONT APPEARS/ WORKS/ WEAPON IS INVISBLE / TEXTURES MOD FROM NEXUS WONT WORKS???? HOW DO I SHOLVE THIS PROBLEM?????

 

A : I HAVE YOUR GUYS ISSUES FOR ALMOST 4 MONTHS!!!! IT ALMOST MADE ME CRAZY DANG!!! BUT I WONT GIVE UP!! AND YEAH I SHOLVED IT !!! I DONT KNOW IT WORKS OR NOT WITH YOU GUYS, BUT I HOPE IT WORKS ALOS FOR YOU, I DO REALLY HOPE TOO, BUT DONT BULLY ME IF IT DOESNT WORK WITH YOU GUYS, SO TO THE POINT, I WILL TELL YOU HOW WAS,,,

 

 

1. Ofcourse you have to setting your "Fallout4Prefs.ini" TEXT in your MY DOCUMENT >> MY GAMES >> FALLOUT 4, this is the important thing to do at first

 

setting to :

 

[ArchIve]

bInvalidateOlderFiles=1
sResourceDataDirsFinal=

 

 

You can see how to do it more detail from Nexus, here is the link how to Enabling MOD on your Fallout 4 game
http://www.nexusmods...ut4/videos/87/?

follow the intruction Correctly :)

 

2. After you change the FalloutPrefs.INI and Fallout4.INI

Then Many people People said

 

"I dont have any problem on My mod after i set up the INI files, My MODS are works perfectly"

 

But hey, im not stop in here, There's still many people who still Stuck in their MODS become WORKS though they had setting up the INI files

 

and yes Including me, before,,,

 

So how to sholve your problem guys,,,

 

we need 1 more file from NEXUS SITE!!!

 

WE NEED "ELF - Enable Loose Files for Fallout 4"

 

But trust me guys i dont know how it works cuz i also dont know my problem too before,,,

 

but after i UNZIPED this ELF and COPIED this to my DATA FOLDER on my FALLOUT 4 game, then after I RUN / PATCHED the ELF file,,,

 

and when i RUN THE GAME,,,

 

you know what, ALL MY MODS WHO LOST THEIR TEXTURES and MESHES is WORKED PERFECTLY!!!!

 

* IT MADE MY CRAFTING MOD like [WEAPONSMITH, CRAFTING BULLET WORKBENCH, CWSS REDUXE/ everything about Crafting MODS] BECAME WORKED!!!!

** IT MADE MY MOD WEAPON like [STAND ALONE WEAPONS, MURDERING CHAINSAW, LIGHT SABER!!!! uhh i love it] BECAME WORKED!!!!

*** IT MADE MY VIVID LANDSCAPE, WEATHER, ROCK and ROADS, BRIDGE, WATER MOD BECAME WORKED!!!!

 

so guys Try this one "ELF - ENABLE LOOSE FILES" for fallout 4 :

 

Here is the link of ELF :

 

http://www.nexusmods...ut4/mods/4020/?

NOTE : SO GUYS I HOPE YOUR MODS WORKS TO AS ME, I DO REALLY HOPE WE HAVE THE SAME HAPPINESS TO DO MODDING IN FALLOUT 4!!!

 

AND IM SORRY ABOUT MY ENGLISH IF BAD hahahaha, Cuz i from Indonesia,,, :D

 

OKAY GUYS TRY IT, AND LEAVE A COMMENT ON ME, SO I CAN KNOW YOURS TOO!!!!

 

KEEP SMILE !!! :)



#17
pawheet

pawheet

    Stranger

  • Members
  • Pip
  • 8 posts

So. I have done exactly as everyone has instructed, and I don't have any changes. I'm beginning to think that it is an issue with NMM. I may have to risk manually installing the mods.

I really appreciate the insight and advice everyone has provided. Thanks so much! If anyone has any other suggestions, I'm all ears.

[SHOLVED]

 

WEAPON / TEXTURES MOD "TEXTURES AND MESHES MISSING / WEAPON IS INVISIBLE??? HEY IT SHOLVED!!!!!!"

 

Q : MY WEAPON / SUIT / VIVID TEXTURES / LANDSCAPE TEXTURES MOD i DOWNLOADED WONT APPEARS/ WORKS/ WEAPON IS INVISBLE / TEXTURES MOD FROM NEXUS WONT WORKS???? HOW DO I SHOLVE THIS PROBLEM?????

 

A : I HAVE YOUR GUYS ISSUES FOR ALMOST 4 MONTHS!!!! IT ALMOST MADE ME CRAZY DANG!!! BUT I WONT GIVE UP!! AND YEAH I SHOLVED IT !!! I DONT KNOW IT WORKS OR NOT WITH YOU GUYS, BUT I HOPE IT WORKS ALOS FOR YOU, I DO REALLY HOPE TOO, BUT DONT BULLY ME IF IT DOESNT WORK WITH YOU GUYS, SO TO THE POINT, I WILL TELL YOU HOW WAS,,,

 

 

1. Ofcourse you have to setting your "Fallout4Prefs.ini" TEXT in your MY DOCUMENT >> MY GAMES >> FALLOUT 4, this is the important thing to do at first

 

setting to :

 

[ArchIve]

bInvalidateOlderFiles=1
sResourceDataDirsFinal=

 

 

You can see how to do it more detail from Nexus, here is the link how to Enabling MOD on your Fallout 4 game
http://www.nexusmods...ut4/videos/87/?

follow the intruction Correctly :)

 

2. After you change the FalloutPrefs.INI and Fallout4.INI

Then Many people People said

 

"I dont have any problem on My mod after i set up the INI files, My MODS are works perfectly"

 

But hey, im not stop in here, There's still many people who still Stuck in their MODS become WORKS though they had setting up the INI files

 

and yes Including me, before,,,

 

So how to sholve your problem guys,,,

 

we need 1 more file from NEXUS SITE!!!

 

WE NEED "ELF - Enable Loose Files for Fallout 4"

 

But trust me guys i dont know how it works cuz i also dont know my problem too before,,,

 

but after i UNZIPED this ELF and COPIED this to my DATA FOLDER on my FALLOUT 4 game, then after I RUN / PATCHED the ELF file,,,

 

and when i RUN THE GAME,,,

 

you know what, ALL MY MODS WHO LOST THEIR TEXTURES and MESHES is WORKED PERFECTLY!!!!

 

* IT MADE MY CRAFTING MOD like [WEAPONSMITH, CRAFTING BULLET WORKBENCH, CWSS REDUXE/ everything about Crafting MODS] BECAME WORKED!!!!

** IT MADE MY MOD WEAPON like [STAND ALONE WEAPONS, MURDERING CHAINSAW, LIGHT SABER!!!! uhh i love it] BECAME WORKED!!!!

*** IT MADE MY VIVID LANDSCAPE, WEATHER, ROCK and ROADS, BRIDGE, WATER MOD BECAME WORKED!!!!

 

so guys Try this one "ELF - ENABLE LOOSE FILES" for fallout 4 :

 

Here is the link of ELF :

 

http://www.nexusmods...ut4/mods/4020/?

NOTE : SO GUYS I HOPE YOUR MODS WORKS TO AS ME, I DO REALLY HOPE WE HAVE THE SAME HAPPINESS TO DO MODDING IN FALLOUT 4!!!

 

AND IM SORRY ABOUT MY ENGLISH IF BAD hahahaha, Cuz i from Indonesia,,, :D

 

OKAY GUYS TRY IT, AND LEAVE A COMMENT ON ME, SO I CAN KNOW YOURS TOO!!!!

 

KEEP SMILE !!! :)



#18
okaypunk

okaypunk

    Regular

  • Members
  • PipPip
  • 65 posts
I'm having these problems as well and I've already tried a clean install... I haven't tried that ELF thing yet tho. I'll have to try it.

#19
okaypunk

okaypunk

    Regular

  • Members
  • PipPip
  • 65 posts

I'm having these problems as well and I've already tried a clean install... I haven't tried that ELF thing yet tho. I'll have to try it.



#20
okaypunk

okaypunk

    Regular

  • Members
  • PipPip
  • 65 posts
Okay so the ELF didn't work unfortunately





Also tagged with one or more of these keywords: bugs, texture mods

Page loaded in: 1.087 seconds