Jump to content

Photo

Unable to use NMM with Windows 7

windows windows 7 windows 10 .net net framework version nmm unable 4.6

  • Please log in to reply
2 replies to this topic

#1
WinglessPriest

WinglessPriest

    Stranger

  • Members
  • Pip
  • 1 posts

Nexus mod manager requires .NET framework 4.6 which is only compatible with windows 10. The problem is I have Windows 7 and updated my NMM, now I can't even launch NMM without getting error stating:

http://i.imgur.com/p6wJMUR.png

If yes, I get linked to .NET Framework and this happens:

http://i.imgur.com/ICtg9eH.png
 

So is my only option updating to Windows 10? I don't want Windows 10 but I do want NMM, what can I do about this?



#2
obobski

obobski

    Fan

  • Members
  • PipPipPip
  • 481 posts

.NET 4.6 does not require Windows 10. What version of .NET do you presently have installed? Do you have updates enabled on your system? (I'm assuming not, as .NET is not up to date, and this is something Windows Update will, by default, keep updated) .NET has dependencies (including Service Pack 1 for Windows 7) and may be refusing to install because you haven't met those. If you have other .msi installers running in the background it will prevent .NET from properly installing as well.

 

Offline installers for .NET 4.6 Preview:

https://support.micr...n-us/kb/2969351 (supports Vista)

and .NET 4.6.1:

https://www.microsof...s.aspx?id=49982



#3
Dazaster

Dazaster

    Resident poster

  • Premium Member
  • 8,195 posts

You need Windows 7 updated with service pack 1 before 4.6 will install.







Also tagged with one or more of these keywords: windows, windows 7, windows 10, .net, net, framework, version, nmm, unable, 4.6

Page loaded in: 1.023 seconds