Jump to content

Photo

Invisible Models & Textures

mods models textures bethesda fallout

  • Please log in to reply
32 replies to this topic

#21
bill8872

bill8872

    Faithful poster

  • Members
  • PipPipPipPip
  • 2,063 posts

NMM has major issues with many mods. There are time when I download a mod through Nexus, and NMM will not even recognize I downloaded it, or places it in the unassigned category. 

 

I find more often than not, it is NMM that is the problem, not the mods. 


Edited by bill8872, 22 July 2016 - 02:17 PM.


#22
GuyotF

GuyotF

    Stranger

  • Members
  • Pip
  • 1 posts

I too encountered the same problem with textures being invisible. I am just posting to say that if someone is playing Fallout 4 through steam, like I do, than I may have a solution (it worked for me).
 
In addition to editing the Fallout4Custom.ini file within:
C:\Program Files (x86)\Steam\SteamApps\common\Fallout 4
 
I also had to edit a 2nd Fallout4Custom.ini file within:
C:\Users\<user>\Documents\My Games\Fallout4
 
*note the <user> is actually your Windows log in name
 
And for anyone who doesn't already know the required edits for both these files are (should be able to copy paste what I have below):
 
[Archive]
bInvalidateOlderFiles=1
sResourceDataDirsFinal=
 
Be very wary of typos on both files including extra spaces.
 

Omg thanks bro. You are best. Im so happy because my mods are working now!

#23
pawheet

pawheet

    Stranger

  • Members
  • Pip
  • 8 posts

[SHOLVED]

 

WEAPON / TEXTURES MOD "TEXTURES AND MESHES MISSING / WEAPON IS INVISIBLE??? HEY IT SHOLVED!!!!!!"

 

Q : MY WEAPON / SUIT / VIVID TEXTURES / LANDSCAPE TEXTURES MOD i DOWNLOADED WONT APPEARS/ WORKS/ WEAPON IS INVISBLE / TEXTURES MOD FROM NEXUS WONT WORKS???? HOW DO I SHOLVE THIS PROBLEM?????

 

A : I HAVE YOUR GUYS ISSUES FOR ALMOST 4 MONTHS!!!! IT ALMOST MADE ME CRAZY DANG!!! BUT I WONT GIVE UP!! AND YEAH I SHOLVED IT !!! I DONT KNOW IT WORKS OR NOT WITH YOU GUYS, BUT I HOPE IT WORKS ALOS FOR YOU, I DO REALLY HOPE TOO, BUT DONT BULLY ME IF IT DOESNT WORK WITH YOU GUYS, SO TO THE POINT, I WILL TELL YOU HOW WAS,,,

 

 

1. Ofcourse you have to setting your "Fallout4Prefs.ini" TEXT in your MY DOCUMENT >> MY GAMES >> FALLOUT 4, this is the important thing to do at first

 

setting to :

 

[ArchIve]

bInvalidateOlderFiles=1
sResourceDataDirsFinal=

 

 

You can see how to do it more detail from Nexus, here is the link how to Enabling MOD on your Fallout 4 game
http://www.nexusmods...ut4/videos/87/?

follow the intruction Correctly  :smile:

 

2. After you change the FalloutPrefs.INI and Fallout4.INI

Then Many people People said

 

"I dont have any problem on My mod after i set up the INI files, My MODS are works perfectly"

 

But hey, im not stop in here, There's still many people who still Stuck in their MODS become WORKS though they had setting up the INI files

 

and yes Including me, before,,,

 

So how to sholve your problem guys,,,

 

we need 1 more file from NEXUS SITE!!!

 

WE NEED "ELF - Enable Loose Files for Fallout 4"

 

But trust me guys i dont know how it works cuz i also dont know my problem too before,,,

 

but after i UNZIPED this ELF and COPIED this to my DATA FOLDER on my FALLOUT 4 game, then after I RUN / PATCHED the ELF file,,,

 

and when i RUN THE GAME,,,

 

you know what, ALL MY MODS WHO LOST THEIR TEXTURES and MESHES is WORKED PERFECTLY!!!!

 

* IT MADE MY CRAFTING MOD like [WEAPONSMITH, CRAFTING BULLET WORKBENCH, CWSS REDUXE/ everything about Crafting MODS] BECAME WORKED!!!!

** IT MADE MY MOD WEAPON like [STAND ALONE WEAPONS, MURDERING CHAINSAW, LIGHT SABER!!!! uhh i love it] BECAME WORKED!!!!

*** IT MADE MY VIVID LANDSCAPE, WEATHER, ROCK and ROADS, BRIDGE, WATER MOD BECAME WORKED!!!!

 

so guys Try this one "ELF - ENABLE LOOSE FILES" for fallout 4 :

 

Here is the link of ELF :

 

http://www.nexusmods...ut4/mods/4020/?

NOTE : SO GUYS I HOPE YOUR MODS WORKS TO AS ME, I DO REALLY HOPE WE HAVE THE SAME HAPPINESS TO DO MODDING IN FALLOUT 4!!!

 

AND IM SORRY ABOUT MY ENGLISH IF BAD hahahaha, Cuz i from Indonesia,,,  :D

 

OKAY GUYS TRY IT, AND LEAVE A COMMENT ON ME, SO I CAN KNOW YOURS TOO!!!!

 

KEEP SMILE !!!  :smile:



#24
NickRiddman

NickRiddman

    Stranger

  • Members
  • Pip
  • 6 posts

Well, I got my game back and it's annoyingly simple HOW.

 

As many have noted, patching (or removing) the mod DEF_UI, I think it's called, fixed the problem of crashing with the bInvalidateOlderFiles flag in the Fallout4Custom.ini file.   With the following change to the Fallout4Custom.ini:

 

[Archive]
bInvalidateOlderFiles=1
sResourceDataDirsFinal=
 

All my meshes and textures appear like they should.  The reason I removed those lines was because "they" were causing me to crash.  But it wasn't them, it was ~something~ in my INTERFACE folder.  I still do not know what orphaned files caused the crash, but when I deleted the INTERFACE folder entirely, and restored the Fallout4Custom.ini file back to what it was pre-1.5 patch..... everything worked.

 

I tried deleting the INTERFACE folder before, but I was still crashing, but that could have been caused by anything.  So this may not be a cure-all, but if you have ~any~ INTERFACE folder with files in it, remove any mods you think may have put stuff there (like a scope mod or the full dialog mod) and delete the folder.  You can later install mods that alter the UI (if they are properly patched to 1.5, apparently) but clearing out the "orphaned" files that cause you to be unable to use the InvalidateOlderFiles change to the INI might fix your problems.

 

Sorry if this is rambling and long-winded --- this is my seventh hour tinkering with the game just to get things to work like they worked pre-patch. :tongue:

 

Well, I got my game back and it's annoyingly simple HOW.

 

As many have noted, patching (or removing) the mod DEF_UI, I think it's called, fixed the problem of crashing with the bInvalidateOlderFiles flag in the Fallout4Custom.ini file.   With the following change to the Fallout4Custom.ini:

 

[Archive]
bInvalidateOlderFiles=1
sResourceDataDirsFinal=
 

All my meshes and textures appear like they should.  The reason I removed those lines was because "they" were causing me to crash.  But it wasn't them, it was ~something~ in my INTERFACE folder.  I still do not know what orphaned files caused the crash, but when I deleted the INTERFACE folder entirely, and restored the Fallout4Custom.ini file back to what it was pre-1.5 patch..... everything worked.

 

I tried deleting the INTERFACE folder before, but I was still crashing, but that could have been caused by anything.  So this may not be a cure-all, but if you have ~any~ INTERFACE folder with files in it, remove any mods you think may have put stuff there (like a scope mod or the full dialog mod) and delete the folder.  You can later install mods that alter the UI (if they are properly patched to 1.5, apparently) but clearing out the "orphaned" files that cause you to be unable to use the InvalidateOlderFiles change to the INI might fix your problems.

 

Sorry if this is rambling and long-winded --- this is my seventh hour tinkering with the game just to get things to work like they worked pre-patch. :tongue:

Wow, thank you, i had problems with equipping this mod - http://shiala92.devi...out-4-601383301, and i busted my ass finding solution,  but once i uninstalled this damn INTERFACE folder, everything works fine 



#25
GuyInDogSuit

GuyInDogSuit

    Enthusiast

  • Supporter
  • PipPip
  • 209 posts

 

Is nexus mod manager in the same same drive as your fallout 4 install? Also I had the same problem last night. I deleted everything related to NMM and Fallout 4 and reinstalled both and I no longer had this issue. I was running up to date NMM and Fallout and this fixed textures and meshes not installing. 


 

I also moved my NMM to the same drive as my fallout 4 install. So it was either the reinstall of both or it was putting them both on the same drive.

 

 

Both on the same drive fixes it.


Edited by GuyInDogSuit, 23 April 2017 - 05:09 PM.


#26
Asapxkhaliis

Asapxkhaliis

    Stranger

  • Members
  • Pip
  • 2 posts

 

[SHOLVED]

 

WEAPON / TEXTURES MOD "TEXTURES AND MESHES MISSING / WEAPON IS INVISIBLE??? HEY IT SHOLVED!!!!!!"

 

Q : MY WEAPON / SUIT / VIVID TEXTURES / LANDSCAPE TEXTURES MOD i DOWNLOADED WONT APPEARS/ WORKS/ WEAPON IS INVISBLE / TEXTURES MOD FROM NEXUS WONT WORKS???? HOW DO I SHOLVE THIS PROBLEM?????

 

A : I HAVE YOUR GUYS ISSUES FOR ALMOST 4 MONTHS!!!! IT ALMOST MADE ME CRAZY DANG!!! BUT I WONT GIVE UP!! AND YEAH I SHOLVED IT !!! I DONT KNOW IT WORKS OR NOT WITH YOU GUYS, BUT I HOPE IT WORKS ALOS FOR YOU, I DO REALLY HOPE TOO, BUT DONT BULLY ME IF IT DOESNT WORK WITH YOU GUYS, SO TO THE POINT, I WILL TELL YOU HOW WAS,,,

 

 

1. Ofcourse you have to setting your "Fallout4Prefs.ini" TEXT in your MY DOCUMENT >> MY GAMES >> FALLOUT 4, this is the important thing to do at first

 

setting to :

 

[ArchIve]

bInvalidateOlderFiles=1
sResourceDataDirsFinal=

 

 

You can see how to do it more detail from Nexus, here is the link how to Enabling MOD on your Fallout 4 game
http://www.nexusmods...ut4/videos/87/?

follow the intruction Correctly  :smile:

 

2. After you change the FalloutPrefs.INI and Fallout4.INI

Then Many people People said

 

"I dont have any problem on My mod after i set up the INI files, My MODS are works perfectly"

 

But hey, im not stop in here, There's still many people who still Stuck in their MODS become WORKS though they had setting up the INI files

 

and yes Including me, before,,,

 

So how to sholve your problem guys,,,

 

we need 1 more file from NEXUS SITE!!!

 

WE NEED "ELF - Enable Loose Files for Fallout 4"

 

But trust me guys i dont know how it works cuz i also dont know my problem too before,,,

 

but after i UNZIPED this ELF and COPIED this to my DATA FOLDER on my FALLOUT 4 game, then after I RUN / PATCHED the ELF file,,,

 

and when i RUN THE GAME,,,

 

you know what, ALL MY MODS WHO LOST THEIR TEXTURES and MESHES is WORKED PERFECTLY!!!!

 

* IT MADE MY CRAFTING MOD like [WEAPONSMITH, CRAFTING BULLET WORKBENCH, CWSS REDUXE/ everything about Crafting MODS] BECAME WORKED!!!!

** IT MADE MY MOD WEAPON like [STAND ALONE WEAPONS, MURDERING CHAINSAW, LIGHT SABER!!!! uhh i love it] BECAME WORKED!!!!

*** IT MADE MY VIVID LANDSCAPE, WEATHER, ROCK and ROADS, BRIDGE, WATER MOD BECAME WORKED!!!!

 

so guys Try this one "ELF - ENABLE LOOSE FILES" for fallout 4 :

 

Here is the link of ELF :

 

http://www.nexusmods...ut4/mods/4020/?

NOTE : SO GUYS I HOPE YOUR MODS WORKS TO AS ME, I DO REALLY HOPE WE HAVE THE SAME HAPPINESS TO DO MODDING IN FALLOUT 4!!!

 

AND IM SORRY ABOUT MY ENGLISH IF BAD hahahaha, Cuz i from Indonesia,,,  :D

 

OKAY GUYS TRY IT, AND LEAVE A COMMENT ON ME, SO I CAN KNOW YOURS TOO!!!!

 

KEEP SMILE !!!  

You have saved my fking day, thank you so much. The enable loose files thing fixed it.



#27
Dragonexile93

Dragonexile93

    Stranger

  • Members
  • Pip
  • 1 posts

OK I'v done everything reinstall fallout 4 re download one mod and extra mods, transfer all files to where the need to be, uninstalled NMM, transfered files here and there here and there, and im still getting invisible textures, and meshes. NOTHING I'VE DONE FROM READING HAS FIXED THIS..........please someone help, i cant figure this out



#28
DrCollateralDamage

DrCollateralDamage

    Stranger

  • Supporter
  • Pip
  • 4 posts

OK I'v done everything reinstall fallout 4 re download one mod and extra mods, transfer all files to where the need to be, uninstalled NMM, transfered files here and there here and there, and im still getting invisible textures, and meshes. NOTHING I'VE DONE FROM READING HAS FIXED THIS..........please someone help, i cant figure this out

Try just reinstalling all your mods and make sure the textures are in the folder.  But that's all I got



#29
AggaAgostini

AggaAgostini

    Newbie

  • Members
  • Pip
  • 18 posts
Its nmm it puts files in wrong places
Yes nmm doesnt copy all files to right folders
I run nmm to activate only then run game from launcher on pc.
Nmm has issues with online offline
It has issues everywhere
I dont play my games online at all ever im updated to i think is 1.8 somthing and apart frm nmm putting files in wrong folders the game runs fine for upto 6hrs before it crashes

#30
vlad9988

vlad9988

    Journeyman

  • Members
  • Pip
  • 35 posts

Necro to help others, I hope.

 

I had the problem with invisible items from mods. Invisible Crossbow, invisible backpack workbench, invisible gun mods, etc. 

Many hours of trial and error later, mine seems fixed.

 

Had to delete or rename  \Steam\steamapps\common\Fallout 4\Data\Interface folder

 

I also edited Fallout4.ini and Fallout4Custom.ini to include

[Archive]
bInvalidateOlderFiles=1
sResourceDataDirsFinal=

 

 

Until I renamed that folder the .ini edits just resulted in a CTD on load.

 

Now I have a CROSSBOW!







Also tagged with one or more of these keywords: mods, models, textures, bethesda, fallout

Page loaded in: 1.202 seconds