Jump to content

Photo

Creation Kit - Offset mouse in render window.

creation kit render window mouse cursor selection offset

  • Please log in to reply
5 replies to this topic

#1
SGTbayk47

SGTbayk47

    Old hand

  • Supporter
  • PipPipPip
  • 516 posts

Hey everyone,

 

I've just started using the render window to create stuff in the CK, and have noticed a small, but annoying, issue.

 

When in the render window (I haven't experienced this in any other CK windows) all of my selections are offset from my mouse cursor. Whatever I select is actually roughly 1cm above my cursor, and it has been rather annoying and difficult to adjust to without drastically lengthening the time it takes me to make something.

 

I was wondering if anyone knows any fixes for this, or even if someone else is having the issues?

 

Here's a video showing the offset in action.

 

Cheers, Bayk.



#2
KDStudios

KDStudios

    The Master of Puppets

  • Supporter
  • PipPipPipPipPip
  • 3,591 posts

I would much rather not make a new topic for this same issue, despite the necro. Considering the OP details it perfectly with a video to match.

 

A "quick" fix seems to be restarting the CK but it reoccurs too often in the same session and needs a permanent/semi permanent solution.

 

Has anyone else encountered this offset mouse issue? Or have a way to actually correct it?

Perhaps now someone else has had this issue and can help.

It is beyond infuriating trying to work on the render window, it's no wonder there's barely any mods coming out that actually affect the world in a significant way and I refuse to believe we are the only two people that experience this.



#3
Dsheck

Dsheck

    Journeyman

  • Members
  • Pip
  • 29 posts

Hopefully this thread isn't completely dead but-

 

I have this issue too. Can't figure out how to fix it without restarting the CK. I have noticed this error in the Warnings repeatedly:

 

Pointer value cannot be cast as NumericID : Size bust BSUInt32.

 

This issue is rather new to me. It started happening in the last few weeks. I run the CK through MO2. I don't remember ever having this issue when I run CK by itself.

 



#4
BlahBlahDEEBlahBlah

BlahBlahDEEBlahBlah

    Faithful poster

  • Premium Member
  • 2,070 posts
Resizing (grabbing a corner and dragging) the Render Window fixes it for me usually.

#5
ClandestineGhost85

ClandestineGhost85

    Stranger

  • Supporter
  • Pip
  • 1 posts

Resizing (grabbing a corner and dragging) the Render Window fixes it for me usually.

Holy cow, this is fantastic advice. I just noticed this happening, so I googled it and found your suggestion and holy cow, thank you for this. Restarting the CK every time would be horrible.



#6
Andyno

Andyno

    Fan

  • Supporter
  • PipPipPip
  • 392 posts

 

Restarting the CK every time would be horrible.

 

Restarting the CK didn't work for me. It looks like the CK is saving the settings when exitting or something.

Anyway, thanks to Mr. BlahBlah! :thumbsup:







Also tagged with one or more of these keywords: creation, kit, render, window, mouse, cursor, selection, offset

Page loaded in: 1.040 seconds