Jump to content

Photo

3ds nif plugin deforms meshes

fallout 4; 3ds max; modelling;

  • Please log in to reply
10 replies to this topic

#1
SydneyB

SydneyB

    Fire and Blood

  • Premium Member
  • 32,130 posts

I am only using the 3ds max nif plugin to act as a bridge between Blender and Fallout 4. 

 

3ds max exporter distorts my mesh horribly as you can see in the picture. 
 
 
27014918926_9a681ebf29_o.jpg
 
Inside 3ds it is fine (at the top), but once exported the mesh gets distorted (as you can see in the picture taken in NifSkope).
 
Any ideas on how to fix it? I am only using 3ds as a bridge between Blender and Fallout 4 and I don't really know much about it.
 
Thanks in advance,
 
Ashara
 
 
PS: I've also tried using Outfit Studio (exporting the mesh from Blender as an obj, importing it into Outfit Studio and then exporting it as a nif file), but I get the invisible mesh bug in game. I think it is related to the rigging, as I managed to fix that in Blender deleting unused bones from meshes, but I don't know much about Outfit studio either, is it possible to delete unused bones from a mesh in Outfit Studio? Or is there another way of fixing the invisible mesh bug?


#2
leo2link

leo2link

    Faithful poster

  • Supporter
  • PipPipPipPip
  • 1,494 posts

I've notice this too, I got an issue where it makes the meshes morph in malleable manner I can't seem to figure out what it is that causes it.


Edited by leo2link, 16 May 2016 - 04:13 PM.


#3
TrickyVein

TrickyVein

    Eulalia!

  • Members
  • PipPipPipPipPip
  • 3,228 posts

I've used the niftools for max on many an occasion and never seen this, so I'm guessing:

 

(Though I've never exported clothes or anything skinned if that's a clothing mesh for Fallout 4);

 

there are export settings there in the exporter dialog which weld vertices together so you could try increasing the threshold to a larger number.

 

But the issue could be weights on the vertices not being painted fully if it's skinned as well (also, just a guess).



#4
SydneyB

SydneyB

    Fire and Blood

  • Premium Member
  • 32,130 posts

I've used the niftools for max on many an occasion and never seen this, so I'm guessing:

 

(Though I've never exported clothes or anything skinned if that's a clothing mesh for Fallout 4);

 

there are export settings there in the exporter dialog which weld vertices together so you could try increasing the threshold to a larger number.

 

But the issue could be weights on the vertices not being painted fully if it's skinned as well (also, just a guess).

All vertices are skinned, it is a mesh exported from Blender and imported into 3DS max. Blender exports it fine, but 3ds fails :S

 

About the welding thing: this are the export options I have used:

 

http://wiki.nexusmod...lloutExport.jpg

 

The welding vertices is set to 0, do you mean that I should increase it? I'll try and see if that fixes things :smile:

 

Thanks! :smile:

 

EDITED:

I've tried increasing that. Setting it to 0,1 makes no difference, then I've increased it to 10 ... well, the mesh look like it was melting! LOL! 

 

The worst thing is that exporting the same mesh for Skyrim from 3DS, using the same nif plugin and with the same default options, exports a perfect mesh:

 

26961392952_4b8b4e2aa1_o.png

 

I am thinking there is a big bug in that plugin that only happens with Fallout 4 ... :sad:

 

Ash



#5
TrickyVein

TrickyVein

    Eulalia!

  • Members
  • PipPipPipPipPip
  • 3,228 posts

The tools are buggy in more ways than probably just this, unfortunately. 



#6
BigAndFlabby

BigAndFlabby

    Faithful poster

  • Premium Member
  • 1,890 posts

This has been an issue for ages (since FO4 model modding started). FO4 nif's have lower default precision. Newer Outfit Studio has an option to flag an internal per mesh parameter that allows to use full precision but you'd have to get the model into OS without the distortion first.
 
One option might be:

  • Export to a skyrim nif. You could opt to try export direct to obj and skip to step 5, but you will probably have to manually scale it in OS then.
  • Load nif in OS.
  • Export shape to OBJ or FBX (you'll lose need to redo any weights that are applicable).
  • Close and reload OS with an empty slate (sometimes it glitches otherwise).
  • Import your OBJ/FBX file.
  • Right click your shape and goto properties (or double click shape) and then the Geometry tab and check Full Precision.
  • Export to new nif. This will typically make it a BSSubIndexTriShape. If that's not appropriate you can try using NifSkope to convert it to just plain BSTriShape, though I ran into issues with that.

Another alternative though a bit trickier would be to use the Bethesda max plugin. However it only supports Max 2013 (reports that it sorta works on 2014). It's located in the Fallout4\Tools folder after installing the CK. If going this route, make sure you read the README file and check Bethesda.net's forums about it.

 

Edit: Something else I thought of, maybe scaling the mesh up say 10x (or more) in max and save nif. Then in OS or NifSkope scale it back down. I have no clue how that will react but it's worth a try as a last ditch effort if one of the previously mentioned methods aren't viable.


Edited by BigAndFlabby, 17 May 2016 - 05:51 AM.


#7
SydneyB

SydneyB

    Fire and Blood

  • Premium Member
  • 32,130 posts

Thanks Big, I'll try the Geometry thing in Outfit Studio. I already tried the Blender -> OBJ -> Outfit Studio -> nif route, and the meshes looked not bad, but the problem was that the meshes were invisible in game ... :sad:

 

I was also thinking about the official nif plugin, that should work! And lol! I had the same idea about scaling the mesh! XD I will try it, too :smile:

 

Thanks

 

Ashara

 

EDITED: The resizing doesn't works. It deforms the meshes the same way :sad: I am going to try the Outfit Studio route now, using and OBJ (I guess it is the same if it is an obj or a fbx as in both cases the weights are lost)

 

EDITED 2: It worked this time with Outfit Studio! No more invisible meshes and no big deformation! Thanks a lot! I'll add that to the tutorial 

Now I only need to fix some clipping and pray that next time it works again! :)



#8
JuJooGuppy

JuJooGuppy

    Faithful poster

  • Members
  • PipPipPipPip
  • 1,091 posts

Crazy, I have yet to encounter that issue with my exporter. I havent yet done skinned meshes, so I wonder if that has anything to do with it at all. Id be curious if you removed the skin modifiers and exported it as a static mesh, if it would distort or not (Purely curiosity at this point since you got it working)



#9
SydneyB

SydneyB

    Fire and Blood

  • Premium Member
  • 32,130 posts

I've just tried it (I am curious, too ;)) and it deforms the mesh just the same way. 

 

Matzman explained this on the official forums: 

 

 

For some unknown reason Bethesda decided to use half-float (16-bit floating point numbers) for vertex positions in FO4 meshes. Due to the reduced precision you get distorted meshes when you export delicate meshes. There is a flag in the nif which can be set to support full floats (32-bit), but figment's exporter does not support it yet. Also the official nif exporter also does not support this flag for whatever reason (Why, Bethesda, why? It does not make the least sense). Going the Bodyslide route is currently the only way to utilize full floats in FO4 meshes.


#10
AlexScorpion

AlexScorpion

    Resident poster

  • Members
  • PipPipPipPipPip
  • 2,525 posts

I always get this issue when my pivot is not centered to the mesh and the X-form has not been reset, transform and scale too

 


Edited by AlexScorpion, 22 May 2020 - 12:46 PM.






Also tagged with one or more of these keywords: fallout 4;, 3ds max;, modelling;

IPB skins by Skinbox
Page loaded in: 1.026 seconds