Jump to content

Photo

Looping fnv4gb/Nvse/adminstator/steam starting sequence

startup looping failure mods nvse fnv4gb steam administrator

  • Please log in to reply
3 replies to this topic

#1
purekaos

purekaos

    Journeyman

  • Members
  • Pip
  • 46 posts

Please help!

 

So the other day I finally managed to get fnv4gb to work with nvse, on my steam bought fallout new vegas. up till this point I simply used nvse to launch, but realised my game was using up memory to fast so i extended it with fnv4gb. it worked for a few days. now when I attempt to launch with fnv4gb. it begins a weird looping sequence that has me scratching my head as to a solution.

 

To explain better, I use nexus mod manger v (0.61.23) with the latest nvse 5.03 and the latest fnv4gb. now I use nexus mod manger to launch fnv4gb, which in turn is supposed to launch nvse, both have administrator privileges and must be confirmed on start up, but now its a never ending cycle. I would click to launch, click to allow administrator whatever, then it would show steams opening fallout new vegas window. but suddenly the admin y/n box appears again. and this is a never ending loop. I cant figure out what is wrong. all my files are there, I've verified the local files, I've checked to make sure nothing is conflicting load order wise. but that should affect launch. I have no idea what to do.

 

I'm trying to avoid re downloading the entire game as I'm Aussie who lives rurally, meaning my internet is slow and it would take me almost 3-4 weeks to download again.

 

P.s Nvse + the normal fallout luncher also does the same thing, so its not just fnv4gb to clarify.


Edited by purekaos, 10 June 2016 - 09:33 PM.


#2
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 7,964 posts

If I understand you correctly, you are launching from the Steam Library screen?  Try launching from a shortcut on your desktop to the FNV4GB executable, AFTER you have launched the Steam Client.  (You can configure Steam to run in "offline mode", but even then you still have to use the Steam Client to connect to their server first. Don't you love DRM?)  You should only need to confirm your Administrator credentials once that way.  Configure the shortcut (Properties | "Shortcut" tab | "Advanced" button) to "run as administrator", not the executable itself.

 

Once that is working, then configure NMM to use that shortcut to launch the game.

 

It is not necessary to require NVSE to use Administrator credentials.  Because it is launched as a sub-process of FNV4GB, it inherits that environment and credentials.

 

All that said, I never found it necessary to run either FNV4GB or NVSE as an Administrator.  You should only do so when actually forced into it.  Consequently, I suspect you installed into the default "C:\Program Files" folder?  (This is the most common reason people feel they need Admin privs to run something.)  Please read the "Installing Games on Windows Vista+" article in my signature.  Moving games out of that folder tree is the single biggest favor you can do yourself, now and for the future (no matter how painful.)

 

-Dubious-


Edited by dubiousintent, 10 June 2016 - 10:15 PM.


#3
purekaos

purekaos

    Journeyman

  • Members
  • Pip
  • 46 posts

If I understand you correctly, you are launching from the Steam Library screen?  Try launching from a shortcut on your desktop to the FNV4GB executable, AFTER you have launched the Steam Client.  (You can configure Steam to run in "offline mode", but even then you still have to use the Steam Client to connect to their server first. Don't you love DRM?)  You should only need to confirm your Administrator credentials once that way.  Configure the shortcut (Properties | "Shortcut" tab | "Advanced" button) to "run as administrator", not the executable itself.

 

Once that is working, then configure NMM to use that shortcut to launch the game.

 

It is not necessary to require NVSE to use Administrator credentials.  Because it is launched as a sub-process of FNV4GB, it inherits that environment and credentials.

 

All that said, I never found it necessary to run either FNV4GB or NVSE as an Administrator.  You should only do so when actually forced into it.  Consequently, I suspect you installed into the default "C:\Program Files" folder?  (This is the most common reason people feel they need Admin privs to run something.)  Please read the "Installing Games on Windows Vista+" article in my signature.  Moving games out of that folder tree is the single biggest favor you can do yourself, now and for the future (no matter how painful.)

 

-Dubious-

Hello thankyou for the quick reply, but I managed to fix the issue.

 

1. I didn't explain it very well I'm sorry, only fnv4gb has been given admin privileges everything else just follows along as you say.

2. I eventually learned that this was happening to all my games, and that it was a problem with steam itself, after noticing that after multiple failed attempts the system would always ask to troubleshoot steam, rather then any of the launchers I thought were the issue.

3. Knowing it was a steam issue, I was able to refine my search and quickly found a fix.

4. I'm linking the video, and the processes I recommend doing in an attempt to fix. In case anybody else has similar issues and this may help. 

 

steps.

 

1. verify integrity of game cache

2. ensure admin privileges are enabled on the launcher

3. ensure launchers are up to date (they may require newer versions of NVSE or FNV4GB)

4. if that all fails, and this is happening with all of your games, then its a steam issue.

5. If steam issue follow this video. (its long but usually fixes the issue)

6.  



#4
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 7,964 posts

Glad to hear you solved it, and thanks especially for reporting your solution.  I've added it to my (wip) troubleshooting article.

 

For those who don't care for a 3.5 minute video that boils down to a single sentence resolution:

 

* Locate your "Steam" (not the game) folder (i.e. "C:\Program Files\Steam") and delete the "ClientRegistry.blob" file.  (If you are the paranoid type, you could try just renaming it.)

 

* Though it is important to note you have to completely shutdown (as in "log out" and wait for it to close) the Steam Client first.

 

-Dubious-







Also tagged with one or more of these keywords: startup, looping, failure, mods, nvse, fnv4gb, steam, administrator

Page loaded in: 1.098 seconds