Jump to content

Photo

Can someone help a poor girl?


  • Please log in to reply
1 reply to this topic

#1
Littlemage

Littlemage

    Enthusiast

  • Members
  • PipPip
  • 176 posts

I have an HP G62 with an integrated Intel HD and an ATI Radeon. I just installed "Mass Effect", the 2008 game, and, even if it launches and run ( I can hear sounds), my screen is totally black. I looked into configuration stuff and found out he is ( trying to ) run on the Intel video card, and it seems to don't see at all the radeon (  only shows "generic pnp monitor with Intel ® Hd graphics in configuration-system-video). I setted my pc to launch all 3D apps with the radeon, optimized the game through the amd tool, setted the ME app to lauch with radeon.. nothing, it still keeps trying to run on the Intel ( which of course isn't compatible ).. can someone help me pls?



#2
blakrajder

blakrajder

    Journeyman

  • Members
  • Pip
  • 49 posts

Are you sure you have the latest drivers for your Intel graphics and discrete AMD mobility? If yes, try to install the ones that were delivered with your laptop. Newer isn't always better.

Make sure that ME exe file is set to compatibility with MS Windows XP SP3.

Check the laptop BIOS, graphics priority might be set there to use Intel HD and overrule OS settings.

You can also launch game, connect monitor (if you have one) to external VGA port to see if there is image sent thru it or simply, when no monitor on hand, use Fn button and F5(can be other key) to try and switch display mode from Laptops display to external VGA port and the other way around.






Page loaded in: 0.937 seconds