Jump to content

Photo

Having trouble with invisible walls

invisible walls trouble error wall creation kit ck skyrim

  • Please log in to reply
10 replies to this topic

#1
waroki11

waroki11

    Stranger

  • Supporter
  • Pip
  • 6 posts

Hi guys, I just got started making my first player home in Creation Kit to prepare for Skyrim Special Edition.

Everything was going smooth, until I playtested it.

Walls were popping in and out, while everything else works flawlessly.

I've searched around for a fix, but were unable to find anything that worked.

 

The player home is a copy/pasted version of Temple of Kynareth in Whiterun

 

I've clicked "show>portals and markers" and deleted any marker that could cause the error. (I left the "COCMarkerHeading" and "NorthMarker" in)

 

I uploaded a Youtube video to showcase the problem.

 

Any help would be greatly appreciated!

 

https://youtu.be/xSHgKiS_L-k


Edited by waroki11, 22 October 2016 - 01:34 AM.


#2
Aragorn58

Aragorn58

    Old hand

  • Members
  • PipPipPip
  • 712 posts

Hi guys, I just got started making my first player home in Creation Kit to prepare for Skyrim Special Edition.

Everything was going smooth, until I playtested it.

Walls were popping in and out, while everything else works flawlessly.

I've searched around for a fix, but were unable to find anything that worked.

 

The player home is a copy/pasted version of Temple of Kynareth in Whiterun

 

I've clicked "show>portals and markers" and deleted any marker that could cause the error. (I left the "COCMarkerHeading" and "NorthMarker" in)

 

I uploaded a Youtube video to showcase the problem.

 

Any help would be greatly appreciated!

 

https://youtu.be/xSHgKiS_L-k

Sounds like a room bounds issue if you copied a vanilla cell. In the show hide window, tick room bounds. If large blue boxes appear covering areas of the cell, than that is your problem. Just click on the boxes and delete them.

 

Then go into the cell, using the console "coc" command, and your walls should not disappear. But be careful, the room bounds and portals prevent stuff from rendering that is not in the players LOS and can cause performance issues in large cells.

 

Good luck. 



#3
waroki11

waroki11

    Stranger

  • Supporter
  • Pip
  • 6 posts

Hi, I tried to find the Room Bounds, but came up empty handed.

 

Do you have any other suggestions? Should I try to upload the file, so you can get a closer look?

 

https://youtu.be/QpRQMPPMhrk

Here is a Youtube video showing you exactly what i did to search for it. I also searched for "Bounds", "Room" etc.

 

Thanks for helping!



#4
csbx

csbx

    Old hand

  • Supporter
  • PipPipPip
  • 960 posts

I've had walls haphazardly be invisible--like 1/10 times I load my cell in the game 1 particular wall would be invisible depending on the angle I stood at. My issue, because it's fairly random, is likely a memory / graphics issue; though I never did really pin it down.

 

Upload your .esp to a trusted person and see if things render the same in-game as for you. It might just be happening on your system.

 

But yeah, it does sound like a roombound problem--your video shows that that's not what it is, though. Weird.

 

One question: what cell did you duplicate to add your house in ?



#5
waroki11

waroki11

    Stranger

  • Supporter
  • Pip
  • 6 posts

I've had walls haphazardly be invisible--like 1/10 times I load my cell in the game 1 particular wall would be invisible depending on the angle I stood at. My issue, because it's fairly random, is likely a memory / graphics issue; though I never did really pin it down.

 

Upload your .esp to a trusted person and see if things render the same in-game as for you. It might just be happening on your system.

 

But yeah, it does sound like a roombound problem--your video shows that that's not what it is, though. Weird.

 

One question: what cell did you duplicate to add your house in ?

 

I duplicated "WhiterunTempleofKynareth".

 

Uploaded the file to the Skyrim Nexus, if anyone wants to take a look

 

http://www.nexusmods...im/mods/79648/?


Edited by waroki11, 22 October 2016 - 06:11 PM.


#6
waroki11

waroki11

    Stranger

  • Supporter
  • Pip
  • 6 posts

UPDATE: I found a workaround, simply copying everything within the cell, duplicating "aaaMarkers" and pasting it in there. While I doubt that this is the proper way of fixing this issue, I'll be able to continue finishing the home.

 

Thanks for all the help. Ill leave the file up on the nexus for anyone who is interested in checking out the problem.


Edited by waroki11, 22 October 2016 - 06:26 PM.


#7
waroki11

waroki11

    Stranger

  • Supporter
  • Pip
  • 6 posts

NEVERMID, back to square one, the problem reoccured.



#8
Aragorn58

Aragorn58

    Old hand

  • Members
  • PipPipPip
  • 712 posts

NEVERMID, back to square one, the problem reoccured.

Just loaded it up and in game the walls are not disappearing. But there is an issue with the lighting. Lights are popping on and off and there may be too many shadow casting lights. Also I noticed you may have too many effects happening in a small area, causing performance issues in such a small cell all in the same place. When I loaded it up in the CK and looked at the shaders, The one corner of the room (lower right) it shows as red indicating that too many objects are being struck by lights at the same time.

 

My system is not the top of the line, but it has a lot of memory and a 6 core processor, but my graphics card is a bit low end. But that being said I can run Skyrim on high settings and get consistent 40 FPS outside and 50 -60 in most interior cells.

 

Not sure why the walls are disappearing on your end. Maybe its too much for your system. Try running FRAPS or Skyrim Performance monitor to see how it is effecting your system.



#9
waroki11

waroki11

    Stranger

  • Supporter
  • Pip
  • 6 posts

 

NEVERMID, back to square one, the problem reoccured.

Just loaded it up and in game the walls are not disappearing. But there is an issue with the lighting. Lights are popping on and off and there may be too many shadow casting lights. Also I noticed you may have too many effects happening in a small area, causing performance issues in such a small cell all in the same place. When I loaded it up in the CK and looked at the shaders, The one corner of the room (lower right) it shows as red indicating that too many objects are being struck by lights at the same time.

 

My system is not the top of the line, but it has a lot of memory and a 6 core processor, but my graphics card is a bit low end. But that being said I can run Skyrim on high settings and get consistent 40 FPS outside and 50 -60 in most interior cells.

 

Not sure why the walls are disappearing on your end. Maybe its too much for your system. Try running FRAPS or Skyrim Performance monitor to see how it is effecting your system.

 

Thanks for having a look! Yesterday, a couple of hours after my last post, the wall-problem disappeared. I have no idea how though...

I'll look into the lighting situation. I left the lighting effects as it was when i duplicated the "WhiterunTempleofKynareth", and have added more since.



#10
FrankFamily

FrankFamily

    The Evil Blacksmith

  • Supporter
  • PipPipPipPipPip
  • 7,090 posts

If its a memory issue you could try optimizing the cell: http://www.creationk...al_Optimization, might solve odd issues.







Also tagged with one or more of these keywords: invisible walls, trouble, error, wall, creation kit, ck, skyrim

IPB skins by Skinbox
Page loaded in: 1.027 seconds