Jump to content

Photo

Armor Shows in NifSkope, But Invisible In-Game Except...

armor invisbile red look up geck nifskope troubleshoot fallout nv fallout

  • Please log in to reply
4 replies to this topic

#1
Onyxx1606

Onyxx1606

    Newbie

  • Supporter
  • Pip
  • 11 posts

okay so i'm using a helgast armor here, but everytime i look at in Nifskope it shows fine, but in-game and in-geck its invisible but not really...
 
 -what it actually is doing is, its completely red-ish and only appears off character in its T-pose skewed across the screen, but only when i look up
 -i have skinned the mesh

 -i have placed BSDismemberskinInstance
 -i used a skeleton from a vanilla outfit

 

**additional info** if a NPC has the item and their inventory and it is un-eqquiped it will also show in T-pose strapped to their sides or hovering above their head, i could not recreate the event for a photo sadly


Edited by Onyxx1606, 28 October 2016 - 12:33 AM.


#2
M48A5

M48A5

    Resident poster

  • Members
  • PipPipPipPipPip
  • 8,522 posts

Did you run the .nif file through blender?

 

In blender, did you parent the armor to the skeleton?

 

Did you copy the bone weights from the skeleton to the armor?

 

After doing the work in Blender, did you go back to NifSkope and set the flags in BSShaderPPLightingProperty?

 

Is the path to the texture correct in BSShaderTextureSet?


Edited by M48A5, 28 October 2016 - 02:15 AM.


#3
Onyxx1606

Onyxx1606

    Newbie

  • Supporter
  • Pip
  • 11 posts

well i use 3DS max actually, what i did what
-imported a vanilla nif. and imported skeleton  > Imported my mesh > Skinwrapped Imported mesh IAW vanilla mesh > Converted Results to weighted skin > Deleted the vanilla mesh. and exported Nif.

if i send you the files does anyone believe they can complete this for me?



#4
Vyxenne

Vyxenne

    Naughty Girl

  • Premium Member
  • 7,181 posts
did you go back to NifSkope and set the flags in BSShaderPPLightingProperty?

I'm looking for a tutorial on how to set the right BSLightingShaderProperty Flags 1 & 2 in Nifskope on a new shape I added (polished toenails) that show up great in NifSkope and Outfit Studio but are invisible in-game when the BSLightingShaderProperty is classified as an Environment Map but show up fine in-game when the shader property is set to Skin Tint... except that the colors are off then.

 

I can't find any guide on how to know which flags to set.



#5
dubiousintent

dubiousintent

    Resident poster

  • Premium Member
  • 7,962 posts

Found the following in a search for "nifskope shader flags":

* BSLightingShaderProperty Basics

The thread has a "quick reference" guide and some links to additional information.

 

The most common advice I have seen is to find an existing model with similar characteristics to what you want and see what settings they use.

 

You may also find some of the links and tips in the "NifSkope Mesh Editor" section of the wiki "Getting started creating mods using GECK" article helpful.

 

-Dubious-







Also tagged with one or more of these keywords: armor, invisbile, red, look, up, geck, nifskope, troubleshoot, fallout nv, fallout

Page loaded in: 1.201 seconds